Επιλογή Σελίδας

Το Πανελλήνιο Σχολικό Δίκτυο παρέχει πρόσβαση στο Διαδίκτυο (Ίντερνετ) σε 150.000 μαθητές και διατηρεί τα στοιχεία τους, καθώς και στατιστικά στοιχεία, σχετικά με την πρόσβασή τους στο Διαδίκτυο. Να κατασκευάσετε πρόγραμμα το οποίο:

Δ1. Να περιλαμβάνει κατάλληλο τμήμα δηλώσεων.
Μονάδες 2

Δ2. Για κάθε μαθητή να διαβάζει:
α) τον αλφαριθμητικό κωδικό του και να τον καταχωρίζει σε μονοδιάστατο πίνακα με όνομα ΚΩΔ
β) το φύλο του, «Α» αν είναι αγόρι και «Κ» αν είναι κορίτσι, και να το καταχωρίζει σε μονοδιάστατο πίνακα με όνομα Φ
γ) τον συνολικό χρόνο πρόσβασής του στο Διαδίκτυο ανά μήνα, για ένα έτος, και να τον καταχωρίζει σε δισδιάστατο πίνακα ΧΡ.
Μονάδες 3

Δ3. Να υπολογίζει και να καταχωρίζει σε πίνακα ΣΧ το συνολικό ετήσιο χρόνο πρόσβασης κάθε μαθητή.
Μονάδες 3

Δ4. Να εμφανίζει τον κωδικό του αγοριού με το μεγαλύτερο συνολικό χρόνο πρόσβασης και, στη συνέχεια, τον κωδικό του κοριτσιού με το μεγαλύτερο συνολικό χρόνο πρόσβασης, καλώντας τη συνάρτηση ΘΕΣΗ_ΜΑΧ, που περιγράφεται στο ερώτημα Δ5, μία φορά για τα αγόρια και μία για τα κορίτσια.
Μονάδες 4

Δ5. Να αναπτύξετε συνάρτηση ΘΕΣΗ_ΜΑΧ η οποία:
α) να δέχεται ως παραμέτρους: τον πίνακα του φύλου, τον πίνακα του συνολικού ετήσιου χρόνου πρόσβασης των μαθητών και τον χαρακτήρα «Α» ή «Κ» που αντιστοιχεί στο φύλο (μονάδες 2)
β) να βρίσκει τη θέση της μέγιστης τιμής του ετήσιου χρόνου πρόσβασης αγοριών ή κοριτσιών, ανάλογα με την τιμή «Α» ή «Κ» του φύλου (μονάδες 4)
γ) να επιστρέφει τη θέση της μέγιστης τιμής (μονάδες 2)
Μονάδες 8

(Σημείωση: Δεν απαιτείται έλεγχος εγκυρότητας. Να θεωρήσετε ότι όλες οι εισαγωγές γίνονται σωστά και όλες οι συνολικές τιμές χρόνου πρόσβασης είναι μοναδικές).

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ Θέμα_4
 ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: i, j, ΧΡ[150000, 12], ΣΧ[150000], ΘΕΣΗ_ΑΓΟ, ΘΕΣΗ_ΚΟΡ
 ΧΑΡΑΚΤΗΡΕΣ: ΚΩΔ[150000], Φ[150000]
 ΑΡΧΗ
 ! Δ2
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 150000
     ΔΙΑΒΑΣΕ ΚΩΔ[i], Φ[i]
     ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12
         ΔΙΑΒΑΣΕ ΧΡ[i, j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 ! Δ3
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 150000
     ΣΧ[i] <-- 0
     ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12
         ΣΧ[i] <-- ΣΧ[i] + ΧΡ[i, j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! Δ4
 ΘΕΣΗ_ΑΓΟ <-- ΘΕΣΗ_ΜΑΧ(Φ, ΣΧ, "Α")
 ΘΕΣΗ_ΚΟΡ <-- ΘΕΣΗ_ΜΑΧ(Φ, ΣΧ, "Κ")
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ ΘΕΣΗ_ΜΑΧ(ΦΥΛ, ΣΧΕ, φύλο): ΑΚΕΡΑΙΑ
 ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: i, ΣΧΕ[150000], max, θmax
 ΧΑΡΑΚΤΗΡΕΣ: ΦΥΛ[150000], φύλο
 ΑΡΧΗ
 max <-- 0
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 150000
     ΑΝ ΦΥΛ[i] = φύλο ΚΑΙ ΣΧΕ[i] > max ΤΟΤΕ
        max <-- ΣΧ[i]
        θmax <-- i
     ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΘΕΣΗ_ΜΑΧ <-- θmax
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

 

Share This