Επιλογή Σελίδας

Να γραφεί αλγόριθμος που να εμφανίζει τους αριθμούς από 1 έως 100.
Στον αλγόριθμο αυτό επιζητείται η παρουσίαση μίας σειράς αριθμών. Αν οι αριθμοί αυτοί ήσαν λίγοι, τότε αυτό θα μπορούσε να γίνει με την παράθεση αντίστοιχων εντολών εμφάνισης. Το ίδιο θα συμβεί και στην περίπτωση που οι αριθμοί είναι περισσότεροι, αλλά δεν έχουν καμία σχέση μεταξύ τους, π.χ. 5, 207, -32 κ.ο.κ. Όμως στο ζητούμενο αλγόριθμο παρατηρούμε ότι κάθε αριθμός παράγεται από τον προηγούμενό του με απλό τρόπο, δηλαδή προσθέτοντας κάθε φορά το 1. Μπορεί λοιπόν να χρησιμοποιηθεί μια μεταβλητή, έστω i, η οποία αρχίζει από το 1 και καταλήγει στο 100 αυξανόμενη κατά 1. Η εκάστοτε αύξηση της μεταβλητής αυτής μπορεί να γίνει με τη χρήση της εντολής εκχώρησης

i ← i + 1

Η αρχική τιμή της μεταβλητής i ορίζεται εύκολα με την εντολή i ←1. Το ζητούμενο είναι να εκτελεστεί 100 φορές η εντολή i ← i + 1. Αυτό επιτυγχάνεται με τη χρήση της εντολής Όσο …επανάλαβε. Η σύνταξη της εντολής αυτής είναι:
Όσο συνθήκη επανάλαβε
        εντολές
Τέλος_επανάληψης
Η λειτουργία της εντολής είναι η εξής: Επαναλαμβάνεται η εκτέλεση των εντολών, όσο η συνθήκη είναι αληθής. Όταν η συνθήκη γίνει ψευδής, τότε ο αλγόριθμος συνεχίζεται με την εντολή που ακολουθεί το ‘Τέλος_ επανάληψης’. Με την εισαγωγή της εντολής αυτής η σχεδίαση του ζητούμενου αλγορίθμου είναι:
Αλγόριθμος Παράδειγμα_7
i ← 1
Όσο i ≤ 100 επανάλαβε
Εμφάνισε i
i ← i + 1
Τέλος_επανάληψης
Τέλος Παράδειγμα_7

Παρατήρηση: Το τμήμα του αλγορίθμου που επαναλαμβάνεται, δηλαδή από την εντολή Όσο μέχρι το τέλος_επανάληψης αποκαλείται βρόχος.

Share This