Επιλογή Σελίδας

Έστω ότι δίνονται δύο δισδιάστατοι πίνακες Α και Β διαστάσεων 5×5 ο καθένας. Να γραφεί ένας αλγόριθμος που θα διαβάζει τα στοιχεία των πινάκων και θα υπολογίζει το άθροισμα των πινάκων, το οποίο θα αποθηκεύεται σε ένα νέο πίνακα.

ΛΥΣΗ:

Αλγόριθμος Αθροισμα_Πινάκων
Για i από 1 μέχρι 5 
Για j από 1 μέχριΔιάβασε A[i,j], B[i,j]   
C[i,j] ← A[i,j] + B[i,j] 
Τέλος_επανάληψης 
Τέλος_επανάληψης 
Αποτελέσματα // C // 
Τέλος Αθροισμα_Πινάκων
Share This