Επιλογή Σελίδας

Σε μία εταιρεία εργάζονται 200 υπάλληλοι και είναι γνωστός ο μισθός του καθενός. Να χρησιμοποιηθεί η δομή του πίνακα για να αποθηκεύονται οι μισθοί των υπαλλήλων και να βρεθεί ο κατάλληλος αλγόριθμος υπολογισμού του μεγαλύτερου μισθού. Στο τέλος αυτού του κεφαλαίου προσδοκάται ότι θα έχεις συνειδητοποιήσει τη σπουδαιότητα των δεδομένων για την επίλυση ενός προβλήματος. Θα έχεις ενστερνισθεί τη θεώρηση ότι οι αλγόριθμοι και οι δομές δεδομένων αποτελούν αδιάσπαστη ενότητα. Θα μπορείς να χειρίζεσαι με ευχέρεια προβλήματα σχετικά με εργασίες με πίνακες. Ακόμα θα μπορείς να κάνεις μια περιληπτική αναφορά σε άλλες δομές δεδομένων (στοίβα, ουρά, λίστα, δένδρο). Τέλος εκτιμάται ότι θα έχεις κατανοήσει τη λειτουργία της αναδρομής. Έτσι έρχεσαι σε επαφή με ένα πανόραμα δομών και αλγορίθμων, που αποτελεί ένα ικανοποιητικό σύνολο εργαλείων για την επίλυση πρακτικών προβλημάτων.

ΛΥΣΗ:

Αλγόριθμος Μεγαλύτερος_Μισθός
 Διάβασε MIS[1] MAX ← MIS[1]  
 Για i από 2 μέχρι 200  Διάβασε MIS[i]
 Αν MIS[i] > MAX τότε MAX ← MIS[i]  
 Τέλος_αν  
 Τέλος_επανάληψης
 Αποτελέσματα // MAX//
 Τέλος Μεγαλύτερος_Μισθός

Ένα παρόμοιο παράδειγμα είχε χρησιμοποιηθεί στο προηγούμενο κεφάλαιο (παράδειγμα 3). Η δομή του πίνακα χρησιμοποιείται ώστε οι μισθοί των υπαλλήλων να αποθηκεύονται στις θέσεις του πίνακα και να μπορούν να χρησιμοποιηθούν και στη συνέχεια. Αντίθετα, στο προηγούμενο κεφάλαιο δεν αποθηκεύονταν κάπου οι τιμές των θερμοκρασιών αλλά απλά χρησιμοποιούνταν στις συγκρίσεις για την αναγνώριση της μέγιστης θερμοκρασίας.

Share This