Επιλογή Σελίδας

Πολλά από τα προγράμματα που αναπτύχθηκαν στα προηγούμενα κεφάλαια μπορούν να γραφούν καλύτερα με τη χρήση υποπρογραμμάτων. Εδώ θα δούμε το πρόγραμμα που υπολογίζει τα βασικά στατιστικά μεγέθη, τη μέση τιμή, την τυπική απόκλιση και τη διάμεσο τιμή που παρουσιάστηκε στο βιβλίο σου στο κεφάλαιο 9. Το πρόγραμμα χρησιμοποιεί τις εξής διαδικασίες και συναρτήσεις:

Υπολόγισε_ΜΟ_ΤυπΑπ: Υπολογίζει τη μέση τιμή και την τυπική απόκλιση ακεραίων αριθμών. Το τμήμα αυτό θα μπορούσε να υλοποιηθεί και με δύο συναρτήσεις, μία για τον υπολογισμό της μέσης τιμής και μίας δεύτερης για τον υπολογισμό της τυπικής απόκλισης.

Ταξινόμησε: Η διαδικασία αυτή ταξινομεί τα στοιχεία του πίνακα χρησιμοποιώντας μία παραλλαγή του αλγορίθμου που παρουσιάστηκε στο βιβλίο σου.

Υπολογισμός_Διαμέσου: Πραγματική συνάρτηση η οποία υπολογίζει τη διάμεσο τιμή.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ Στατιστική 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ: Ι, Πλήθος, Στοιχεία[100], Μέγιστο, Άθροισμα, Άθροισμα_2, Βοηθητική 
ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ,Τυπ_Απόκλιση,Διάμεσος 
ΑΡΧΗ 
! Εισαγωγή στοιχείων 
ΓΡΑΨΕ 'Δώσε το πλήθος των αριθμών (μέγιστο 100)' 
ΔΙΑΒΑΣΕ Πλήθος 
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Πλήθος 
    ΓΡΑΨΕ 'Δώσε έναν αριθμό' 
    ΔΙΑΒΑΣΕ Στοιχεία[Ι] 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΚΑΛΕΣΕ Υπολόγισε_ΜΟ_ΤυπΑπ(Στοιχεία, Πλήθος, ΜΟ, Τυπ_Απόκλιση) 
ΚΑΛΕΣΕ Ταξινόμησε(Στοιχεία, Πλήθος) 
Διάμεσος <-- Υπολογισμός_Διαμέσου(Στοιχεία,Πλήθος) 
! Εκτύπωση αποτελεσμάτων 
ΓΡΑΨΕ 'ΑΠΟΤΕΛΕΣΜΑΤΑ ΓΙΑ ΤΟΥΣ ', Πλήθος, 'ΑΡΙΘΜΟΥΣ' 
ΓΡΑΨΕ 'ΜΕΣΟΣ ΟΡΟΣ:', ΜΟ 
ΓΡΑΨΕ 'ΤΥΠΙΚΗ ΑΠΟΚΛΙΣΗ: ', Τυπ_Απόκλιση 
ΓΡΑΨΕ 'ΔΙΑΜΕΣΟΣ:', Διάμεσος 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Στατιστική ! Παρόραμα

ΔΙΑΔΙΚΑΣΙΑ Υπολόγισε_ΜΟ_ΤυπΑπ(Πίνακας, Ν, ΜΟ, ΤυπΑποκλ) 
! Υπολογισμός μέσου όρου 
!Υπολογισμός τυπικής απόκλισης 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ:Πίνακας[100],Ν, I, Άθροισμα, Άθροισμα_2 
ΠΡΑΓΜΑΤΙΚΕΣ:ΜΟ, ΤυπΑποκλ 
ΑΡΧΗ 
Άθροισμα <-- 0 
Άθροισμα_2 <-- 0 
ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ Ν 
    Άθροισμα <-- Άθροισμα+ Πίνακας[I] 
    Άθροισμα_2 <-- Άθροισμα_2+ Πίνακας[I]^2 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΜΟ <-- Άθροισμα/Ν 
ΤυπΑποκλ <-- Τ_Ρ(Άθροισμα_2 / Ν - ΜΟ^2) 
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ Υπολόγισε_ΜΟ_ΤυπΑπ ! Παρόραμα

ΔΙΑΔΙΚΑΣΙΑ Ταξινόμησε(Πίνακας, Ν) 
!Ταξινόμηση των στοιχείων του πίνακα 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ:I,Ν1,Τ,Βοηθητική, Πίνακας[100], Ν 
ΑΡΧΗ 
Ν1 <-- Ν 
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ 
    Τ <-- 0 
    ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ Ν1-1 
        ΑΝ Πίνακας[I] > Πίνακας[I+1] ΤΟΤΕ 
           Βοηθητική <-- Πίνακας[I] 
           Πίνακας[I] <-- Πίνακας[I+1] 
           Πίνακας[I+1] <-- Βοηθητική 
           Τ <-- I 
        ΤΕΛΟΣ_ΑΝ 
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
    Ν1 <-- Τ 
ΜΕΧΡΙΣ_ΟΤΟΥ Τ=0 
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ Ταξινόμησε ! Παρόραμα

ΣΥΝΑΡΤΗΣΗ Υπολογισμός_Διαμέσου(Α,Ν): ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ ! Παρόραμα - λείπει η εντολή
ΑΚΕΡΑΙΕΣ:Α[100],Ν 
ΑΡΧΗ 
ΑΝ Ν MOD 2 =0 ΤΟΤΕ 
! Παρόραμα - πραγματικός δείκτη πίνακα (casting)
   Υπολογισμός_Διαμέσου <-- (Α[Ν DIV 2]+Α[Ν DIV 2+1])/2 
ΑΛΛΙΩΣ 
! Παρόραμα - πραγματικός δείκτη πίνακα (casting)
  Υπολογισμός_Διαμέσου <-- Α[(Ν+1) DIV 2] 
ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ ΣΥΝΑΡΤΗΣΗΣ Υπολογισμός_Διαμέσου ! Παρόραμα
Share This