Επιλογή Σελίδας

Να γραφεί πρόγραμμα το οποίο διαβάζει τα ονόματα 50 αεροπορικών εταιρειών και τις αντίστοιχες εισπράξεις τους. Να τυπώνει τα ονόματα των εταιρειών που έχουν εισπράξεις περισσότερες από το μέσο όρο.

ΠΡΟΓΡΑΜΜΑ Αεροπορικές_εταιρείες 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ: Ν,Ι, Εισπράξεις[50], Σύνολο 
ΠΡΑΓΜΑΤΙΚΕΣ:ΜΟ 
ΧΑΡΑΚΤΗΡΕΣ: Εταιρεία[50] 
ΑΡΧΗ 
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Αριθμός εταιρειών.. (μικρότερο από 50)'
    ΔΙΑΒΑΣΕ Ν
ΜΕΧΡΙΣ_ΟΤΟΥ Ν<=50
Σύνολο <-- 0
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΡΑΨΕ 'Δώσε αεροπορική εταιρεία …'
    ΔΙΑΒΑΣΕ Εταιρεία[Ι]
    ΓΡΑΨΕ 'Δώσε εισπράξεις …'
    ΔΙΑΒΑΣΕ Εισπράξεις[Ι]
    Σύνολο <-- Σύνολο+Εισπράξεις[Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΜΟ <-- Σύνολο/Ν
ΓΡΑΨΕ 'Μεγαλύτερες από το μέσο όρο'
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΑΝ Εισπράξεις[Ι]> ΜΟ ΤΟΤΕ
       ΓΡΑΨΕ Εταιρεία[Ι]
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Οι παραπάνω πίνακες λέγονται παράλληλοι. Δύο ή περισσότεροι πίνακες λέγονται παράλληλοι, αν σε αυτούς έχουμε αποθηκεύσει τα χαρακτηριστικά οντοτήτων με τέτοιο τρόπο ώστε τα δεδομένα κάθε οντότητας να βρίσκονται σε στοιχεία με την ίδια τιμή δείκτη. Στο παραπάνω παράδειγμα οι πίνακες Εισπράξεις και Εταιρεία είναι παράλληλοι αφού τα στοιχεία που αναφέρονται σε κάθε γραμμή τους, δηλαδή το όνομα και οι εισπράξεις, αφορούν την ίδια εταιρεία.

Share This