Επιλογή Σελίδας

Το σύστημα ημερομηνίας που χρησιμοποιείται από το Excel βασίζεται στο Γρηγοριανό ημερολόγιο, το οποίο καθιερώθηκε για πρώτη φορά το 1582 από τον Πάπα Γρηγόριο XIII. Αυτό το ημερολόγιο σχεδιάστηκε για να διορθώσει τα σφάλματα που παρουσιάστηκαν από το λιγότερο ακριβές Ιουλιανό ημερολόγιο.

Στο Γρηγοριανό ημερολόγιο, ένα κανονικό έτος αποτελείται από 365 ημέρες. Επειδή η πραγματική διάρκεια ενός αστρικού έτους (ο χρόνος που απαιτείται για μια πλήρη περιφορά της Γης γύρω από τον Ήλιο) είναι 365.25635 ημέρες, το «δίσεκτο έτος” των 366 ημερών χρησιμοποιείται μία φορά κάθε τέσσερα χρόνια προκειμένου να ελαχιστοποιηθεί το σφάλμα που προκαλείται από τα τρία κανονικά (αλλά ελλιπή) έτη. Κάθε έτος το οποίο διαιρείται ακριβώς σε 4 ίσα μέρη είναι δίσεκτο έτος. για παράδειγμα, τα έτη 1988, 1992 και 1996 είναι δίσεκτα έτη.

Ωστόσο, εξακολουθεί να υπάρχει ένα μικρό σφάλμα που πρέπει να ληφθεί υπόψη. Για να εξαλειφθεί αυτό το σφάλμα, το Γρηγοριανό ημερολόγιο ορίζει ότι ένα έτος που διαιρείται ακριβώς με το 100 (για παράδειγμα, το έτος 1900) είναι δίσεκτο έτος μόνο εάν διαιρείται ακριβώς και με το 400.

Για αυτόν το λόγο, τα ακόλουθα έτη

1700, 1800, 1900, 2100, 2200, 2300, 2500, 2600

ΔΕΝ είναι δίσεκτα, επειδή διαιρούνται ακριβώς με το 100 αλλά ΟΧΙ και με το 400.

Τα ακόλουθα έτη

1600, 2000, 2400

ΕΙΝΑΙ δίσεκτα, επειδή διαιρούνται ακριβώς τόσο με το 100 όσο και με το 400.

Για να προσδιορίσετε αν ένα έτος είναι δίσεκτο, ακολουθήστε τα εξής βήματα:

  1. Εάν το έτος διαιρείται ακριβώς με το 4, μεταβείτε στο βήμα 2. Διαφορετικά, προχωρείστε το βήμα 5.
  2. Εάν το έτος διαιρείται ακριβώς με το 100, μεταβείτε στο βήμα 3. Διαφορετικά, προχωρήστε το βήμα 4.
  3. Εάν το έτος διαιρείται ακριβώς με το 400, μεταβείτε στο βήμα 4. Διαφορετικά, προχωρείστε το βήμα 5.
  4. Αυτό το έτος είναι δίσεκτο έτος (έχει 366 ημέρες).
  5. Αυτό το έτος δεν είναι δίσεκτο έτος (έχει 365 ημέρες).
Πρόγραμμα Δίσεκτο
μεταβλητές
 Ακέραιες: ετ
 Λογικές: δισ
Αρχή
 διάβασε ετ
 δισ <-- Ψευδής
 Αν ετ mod 4 = 0 τότε
 Αν ετ mod 100 = 0 τότε
 Αν ετ mod 400 = 0 τότε
 δισ <-- Αληθής
 Τέλος_αν
 αλλιώς
 δισ <-- Αληθής
 Τέλος_αν
 Τέλος_αν
 Γράψε δισ
Τέλος_Προγράμματος


Πρόγραμμα Δίσεκτο_2
μεταβλητές
 Ακέραιες: ετ 
 Λογικές: δισ
Αρχή
 Γράψε 'δώσε Έτος:'
 διάβασε ετ
 δισ <-- (ετ mod 4 = 0 και ετ mod 100 <> 0) ή ετ mod 400 = 0 
 Γράψε δισ
Τέλος_Προγράμματος

 

Share This