Να υλοποιηθεί πρόγραμμα που θα υπολογίζει το βάρος φόρτωσης ενός αυτοκινήτου κούριερ.
Το πρόγραμμα διαβάζει την συνολική χωρητικότητα του οχήματος. Διαβάζεις επαναληπτικά το βάρος δεμάτων και τα προσθέτεις στο αυτοκίνητο. Το αυτοκίνητο γεμίζει μόλις ξεπεραστεί το 90% της χωρητικότητας του. Δέματα που ξεπερνούν τη διαθέσιμη χωρητικότητα απορρίπτονται και διακόπτεται η φόρτωση. Στο τέλος εμφανίζεται το συνολικό βάρος των δεμάτων και το πλήθος των δεμάτων.

ΛΥΣΗ

ΠΡΌΓΡΑΜΜΑ courier
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Β, ΣΒ, ΠΛΗΘΟΣ, Χ

ΑΡΧΗ
ΠΛΗΘΟΣ ← 0   ! ΑΡΧΙΚΟΠΟΙΗΣΗ ΤΟΥ ΑΘΡΟΙΣΤΗ
ΣΒ ← 0   ! ΑΡΧΙΚΟΠΟΙΗΣΗ ΤΟΥ ΑΘΡΟΙΣΤΗ
ΔΙΑΒΑΣΕ Χ  ! ΧΩΡΗΤΙΚΟΤΗΤΑ
ΔΙΑΒΑΣΕ Β ! ΒΆΡΟΣ ΔΕΜΑΤΟΣ
Οσο Β + ΣΒ <= 0,9 * Χ ΕΠΑΝΑΛΑΒΕ
        ΣΒ ← ΣΒ + Β
        ΠΛΗΘΟΣ← ΠΛΗΘΟΣ + 1
        ΔΙΑΒΑΣΕ Β
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ΣΒ, ΠΛΗΘΟΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΛΥΣΗ με flag

ΠΡΌΓΡΑΜΜΑ courier
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Β, ΣΒ, ΠΛΗΘΟΣ, Χ
ΛΟΓΙΚΕΣ:ΤΕΛΟΣ_ΦΟΡΤΩΣΗΣ

ΑΡΧΗ
ΠΛΗΘΟΣ < 0   ! ΑΡΧΙΚΟΠΟΙΗΣΗ ΤΟΥ ΑΘΡΟΙΣΤΗ
ΣΒ < 0   ! ΑΡΧΙΚΟΠΟΙΗΣΗ ΤΟΥ ΑΘΡΟΙΣΤΗ
ΔΙΑΒΑΣΕ Χ  ! ΧΩΡΗΤΙΚΟΤΗΤΑ
ΔΙΑΒΑΣΕ Β ! ΒΆΡΟΣ ΔΕΜΑΤΟΣ
ΤΕΛΟΣ_ΦΟΡΤΩΣΗΣ<--ΨΕΥΔΗΣ

Οσο ΤΕΛΟΣ_ΦΟΡΤΩΣΗΣ=ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
    ΔΙΑΒΑΣΕ Β
    ΑΝ Β + ΣΒ <= 0,9 * Χ ΤΟΤΕ
        ΣΒ < ΣΒ + Β
        ΠΛΗΘΟΣ< ΠΛΗΘΟΣ + 1
    ΑΛΛΙΩΣ
        ΤΕΛΟΣ_ΦΟΡΤΩΣΗΣ=ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ ΣΒ, ΠΛΗΘΟΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This