Επιλογή Σελίδας

Οι μεταβλητές Χ1 και Χ2 περιέχουν ακέραιες τιμές. Να αντικαταστήσετε το παρακάτω τμήμα κώδικα, με αντίστοιχο τμήμα κώδικα, που δεν θα περιέχει κανέναν λογικό τελεστή και θα αποτελείται από μια απλή δομή επιλογής και μόνο. Το καινούριο τμήμα κώδικα θα πρέπει να εκτελεί την ίδια λειτουργία με το δοθέν τμήμα.

ΑΝ  (Χ1 mod 2 = 0 ΚΑΙ X2 mod 2 = 0) Ή (Χ1 mod 2 = 1 ΚΑΙ X2 mod 2 = 1) ΤΟΤΕ 

            Εντολές 

ΤΕΛΟΣ_ΑΝ

 (ΜΟΝΑΔΕΣ 5)

ΛΥΣΗ 

Αρκετά μαθηματικογενής άσκηση. Η πρόταση (Χ1 mod 2 = 0 ΚΑΙ X2 mod 2 = 0) Ή (Χ1 mod 2 = 1 ΚΑΙ X2 mod 2 = 1) εννοεί ότι οι 2 αριθμοί είναι οι 2 ζυγοί είτε θα είναι και οι 2 μονοί. Αυτό σημαίνει ότι το άθροισμα τους θα είναι επίσης ζυγό.

Συνεπώς:

ΑΝ (Χ1 + Χ2 mod 2 = 0) ΤΟΤΕ 

      Εντολές

ΤΕΛΟΣ_ΑΝ

Share This