! Να υλοποιηθεί αλγόριθμος που, θα διαβάζει επαναληπτικά θετικούς αριθμούς, θα τους εμφανίζει στην οθόνη, θα σταματά όταν δεχτεί την τιμή 100 ή αν δοθούν 20 αριθμοί.
! να υλοποιηθεί αλγόριθμος που:
! θα διαβάζει επαναληπτικά θετικούς αριθμούς,
! θα τους εμφανίζει στην οθόνη,
! θα σταματά όταν δεχτεί την τιμή 100
! ΠΡΟΕΚΤΑΣΗ: ή αν δοθούν 20 αριθμοί

Λύση

Πρόγραμμα τιμή_φρουρός1
μεταβλητές
ακέραιες: αρ
αρχή
πλήθος <-- 0     ! μετρητής που μετραει τους αρ που διαβάστηκαν
διάβασε αρ
όσο αρ <> 100  επανάλαβε 
    πλήθος <-- πλήθος + 1
    γράψε αρ
    διάβασε αρ  ! διάβασε τον επόμενο αριθμό
τέλος_επανάληψης
Γράψε πλήθος 
Τέλος_προγράμματος
Πρόγραμμα τιμή_φρουρός2_προέκταση
μεταβλητές
ακέραιες: αρ
αρχή
πλήθος <-- 0     ! μετρητής που μετρα τους αρ που διαβάστηκαν
διάβασε αρ
όσο αρ <> 100 και πλήθος <=20 επανάλαβε !2 σύνθηκες
    πλήθος <-- πλήθος + 1
    γράψε αρ
    διάβασε αρ  ! διάβασε τον επόμενο αριθμό
τέλος_επανάληψης
Γράψε πλήθος
Τέλος_προγράμματος
Share This