Να υλοποιηθεί πρόγραμμα που θα υπολογίζει τον αριθμό επισκεπτών μιας έκθεσης. Η έκθεση λειτουργεί καθημερινά για ένα διάστημα ημερών που διαβάζεται από τον χρήστη. Η έκθεση έχει 3 εισόδους. Το πρόγραμμα διαβάζει τους επισκέπτες κάθε ημέρας για κάθε είσοδο και υπολογίζει το σύνολο των επισκεπτών και το εμφανίζει το σύνολο ανά ημέρα. Στο τέλος εμφανίζει τον συνολικό αριθμό επισκεπτών.
Προέκταση: Η μία είσοδος είναι μόνο για έξοδο και οι άλλες 2 για είσοδο.

Λύση

ΠΡΟΓΡΑΜΜΑ ΕΚΘΕΣΗ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Ε1,Ε2, Ε3, ΣΕΗ, ΣΑΕ, Δ, i 
ΑΡΧΗ
ΣΑΕ<--0               ! ΑΡΧΙΚΟΠΟΙΗΣΗ
ΔΙΑΒΑΣΕ Δ             ! ΗΜΕΡΕΣ ΛΕΙΤΟΥΡΓΙΑΣ ΤΗΣ ΕΚΘΕΣΗΣ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Δ   ! ΓΙΑ ΚΑΘΕ ΜΕΡΑ ΛΕΙΤΟΥΡΓΙΑΣ
ΔΙΑΒΑΣΕ Ε1,Ε2,Ε3
ΣΕΗ ← Ε1+Ε2+Ε3        ! ΓΙΑ ΤΗΝ ΠΡΟΕΚΤΑΣΗ ΣΕΗ ← Ε1+Ε2
ΓΡΑΨΕ ΣΕΗ             ! ΣΥΝΟΛΟ ΕΠΙΣΚΕΠΤΩΝ ΗΜΈΡΑΣ
ΣΑΕ ← ΣΑΕ + ΣΕΗ       ! ΣΥΝΟΛΙΚΟΣ ΑΡΙΘΜΟΣ ΕΠΙΣΚΕΠΤΩΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ΣΑΕ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This