Επιλογή Σελίδας

Να γράψετε με βήματα αλγορίθμου και με διάγραμμα ροής τα παρακάτω:

1. Το μέσο όρο ηλικιών μίας ομάδας 100 ανθρώπων.
2. Το σύνολο βαθμολογίας όλων των ομάδων που έχουν πάρει περισσότερους από 100 βαθμούς σε ένα διαγωνισμό.

Λύση: 

1.
Αλγόριθμος Μέσος_Ορος
ATHR ← 0
Για i από 1 μέχρι 100
Διάβασε HLIKIA
ATHR ← ATHR+ HLIKIA
Τέλος_επανάληψης
MO ← ATHR/100
Αποτελέσματα // ΜO //
Τέλος Μέσος_Ορος

2.
Η άσκηση υλοποιείται µε δεδομένες τις βαθμολογίες 5 ομάδων.
Αλγόριθµος Οµάδες
ΑΤΗR ← 0
Για i από 1 μέχρι 5
Διάβασε VATHMOS
Αν VATHMOS>100 τότε
ATHR ← ΑΤΗR+VATHMOS
Τέλος_Αν
Τέλος_επανάληψης
Αποτελέσµατα // ATHR //
Τέλος Οµάδες

Share This