Επιλογή Σελίδας

Να σημειώσεις, στο τετράδιό σου, όλα τα βήματα για τον υπολογισμό του 4!, τόσο με τη χρήση επαναληπτικής διαδικασίας όσο και με τη χρήση αναδρομικής, σύμφωνα με τα προγράμματα που δίνονται στο βιβλίο σου.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ Υπολογισμός_Παραγοντικού
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Ν
ΑΡΧΗ
ΓΡΑΨΕ 'ΔΩΣΕ ΑΡΙΘΜΟ '
ΔΙΑΒΑΣΕ Ν
ΓΡΑΨΕ Ν, ' Παραγοντικό = ', Παραγοντικό(Ν)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

! Επαναληπτική Διαδικασία
ΣΥΝΑΡΤΗΣΗ Παραγοντικό(Αριθμός): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Αριθμός, Ι
ΑΡΧΗ
Παραγοντικό <-- 1 
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Αριθμός
    Παραγοντικό <-- Ι * Παραγοντικό
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
!Αναδρομική κλήση συνάρτησης (Η συνάρτηση καλεί τον εαυτό της - ΕΚΤΟΣ ΥΛΗΣ)
 ΣΥΝΑΡΤΗΣΗ Παραγοντικό2(Αριθμός): ΑΚΕΡΑΙΑ
 ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: Αριθμός
 ΑΡΧΗ
 ΑΝ Αριθμός = 1 ΤΟΤΕ
    Παραγοντικό <-- 1
 ΑΛΛΙΩΣ
    Παραγοντικό <-- Αριθμός * Παραγοντικό(Αριθμός - 1)
 ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
Share This