Επιλογή Σελίδας

Να γράψετε τις δηλώσεις των παρακάτω πινάκων, καθώς και τις εντολές με τις οποίες εκχωρούνται οι τιμές σε αυτά.

Α) Πίνακας 5 στοιχείων που κάθε στοιχείο έχει την τιμή του δείκτη του.

Β) Πίνακας που θα περιέχει τα ψηφία.

Γ) Πίνακας που περιέχει τα ονόματα των συμμαθητών σου.

Δ) Πίνακας με 10 στοιχεία, πρώτο στοιχείο τον αριθμό 500 και κάθε επόμενο στοιχείο να είναι το μισό του προηγούμενου, δηλαδή το δεύτερο 250, το τρίτο 125 κ.ο.κ.

ΛΥΣΗ

Α. 
ΑΚΕΡΑΙΕΣ:Α[5] 
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5 
 Α[Ι]←Ι 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
 
Β. 
ΑΚΕΡΑΙΕΣ:Α[10] 
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10 
 Α[Ι]←Ι-1 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
 
Γ. 
ΧΑΡΑΚΤΗΡΕΣ: Ονόµατα[20] 
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20 
 ∆ΙΑΒΑΣΕ Α[Ι] 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
 
∆. 
ΠΡΑΓΜΑΤΙΚΕΣ:Α[10] 
Κ←500 
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10 
 Α[Ι]←Κ 
 Κ←Κ/2 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Share This