Επιλογή Σελίδας

Σε μία κατασκήνωση υπάρχουν 300 παιδιά και καθένα από αυτά έχει μοναδικό αριθμό από το 1 έως και το 300 που του αντιστοιχεί. Για κάθε παιδί είναι γνωστή η ηλικία του. Να χρησιμοποιηθεί η δομή του πίνακα για να αποθηκεύονται οι ηλικίες των παιδιών και να βρεθεί ο κατάλληλος αλγόριθμος υπολογισμού του μικρότερου και μεγαλύτερου σε ηλικία παιδιού και να εκτυπώνεται τόσο η ηλικία όσο και ο κωδικός του μικρότερου και μεγαλύτερου παιδιού.

ΛΥΣΗ:

Θεωρούµε τον πίνακα table µε ακεραίους που αντιστοιχούν στις ηλικίες των παιδιών. Οι µεταβλητές min_age και max_age αρχικοποιούνται µε την τιµή της πρώτης θέσης του πίνακα, ενώ οι µεταβλητές min και max χρησιµοποιούνται για τη εύρεση της ταυτότητας των δύο παιδιών αντίστοιχα.

Αλγόριθμος Κατασκήνωση 
∆εδομένα // table// 
min_age ← table[1] 
max_age ← table[1] 
min ← 1 
max ← 1 
Για i από 2 μέχρι 300 
Αν table[i]<min_age τότε 
min_age ← table[i] 
min ← i 
Τέλος_αν 
Αν table[i]>max_age τότε 
max_age ← table[i] 
max ← i 
Τέλος_αν 
Τέλος_επανάληψης 
Εκτύπωσε min, min_age, max, max_age 
Τέλος Κατασκήνωση 
Share This