Επιλογή Σελίδας

Έστω ότι έχεις να επεκτείνεις το πρόβλημα της δενδροφύτευσης που δόθηκε στις δραστηριότητες για την τάξη (ΔΤ9). Να επεκτείνεις τον αλγόριθμο έτσι ώστε να διαβάζεις ένα σύνολο από 100 τιμές που αφορούν το είδος του δένδρου και να υπολογίζεις πόσα από τα δένδρα αυτά θα φυτευτούν στη Μακεδονία, πόσα στη Θράκη και πόσα στην Πελοπόννησο.

Λύση:

Αλγόριθµος Δενδροφύτευση
Δεδομένα // S1, S2, S3 //
S1<- 0
S2<- 0
S3<- 0
Για ί από 1 µέχρι 100
∆ιάβασε Ε
Αν Ε=1 τότε
S1 <- S1+1
αλλιώς_αν Ε=2 τότε
S2 <- S2+1
αλλιώς_αν Ε=3 τότε
S3 <- S3+1
Τέλος_αν
Τέλος_επανάληψης
Αποτελέσµατα // S1, S2, S3 //
Τέλος Δενδροφύτευση

Share This