Επιλογή Σελίδας

Να γραφεί ένα πρόγραμμα το οποίο να δέχεται έναν ακέραιο αριθμό και να τον αναλύει σε γινόμενο πρώτων παραγόντων.

Λύση:

Πρόγραμμα Γινόμενο_Πρώτων_Παραγόντων
 Μεταβλητές
 Ακέραιες: αριθμός, γινόμενο, παράγοντας, δύναμη, υπόλοιπο
 Αρχή
 ΓΡΑΨΕ 'Δώσε Ακέραιο Αριθμό:'
 ΔΙΑΒΑΣΕ αριθμός
 υπόλοιπο <-- αριθμός
 γινόμενο <-- 1
 παράγοντας <-- 1
 Όσο γινόμενο <> αριθμός επανάλαβε
     παράγοντας <-- παράγοντας + 1
     δύναμη <-- 0
     Όσο υπόλοιπο mod παράγοντας = 0 επανάλαβε
         υπόλοιπο <-- υπόλοιπο div παράγοντας   ! div αντί / λόγω ασυμβατότητας τύπων μεταβλητών
         δύναμη <-- δύναμη + 1
     Τέλος_Επανάληψης 
     Αν δύναμη > 0 τότε
        Γράψε παράγοντας, '^', δύναμη
        γινόμενο <-- γινόμενο * παράγοντας ^ δύναμη
     Τέλος_αν
Τέλος_επανάληψης
Τέλος_προγράμματος

 

Share This