Επιλογή Σελίδας

Δίνεται ένας πίνακας Α που περιέχει Ν τυχαίους ακεραίους αριθμούς. Να γραφεί πρόγραμμα το οποίο να διαβάζει έναν αριθμό και να ελέγχει αν ο αριθμός υπάρχει στον πίνακα. Για την αναζήτηση να χρησιμοποιηθεί ο αλγόριθμος της σειριακής αναζήτησης που παρουσιάστηκε στο κεφάλαιο 3.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ Σειριακή
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ: i, Α[10], αριθμός 
ΛΟΓΙΚΕΣ : βρέθηκε 
ΑΡΧΗ 
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10 
    ΓΡΑΨΕ 'ΔΩΣΕ ΣΤΟΙΧΕΙΟ ', i
    ΔΙΑΒΑΣΕ Α[i] 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΓΡΑΨΕ 'ΔΩΣΕ ΑΡΙΘΜΟ: '
ΔΙΑΒΑΣΕ αριθμός 
βρέθηκε <-- ΨΕΥΔΗΣ  
i <-- 1 
ΟΣΟ (βρέθηκε = ΨΕΥΔΗΣ) ΚΑΙ (i <= 10) ΕΠΑΝΑΛΑΒΕ 
     ΑΝ (Α[i] = αριθμός) ΤΟΤΕ 
         βρέθηκε <-- ΑΛΗΘΗΣ  
     ΑΛΛΙΩΣ 
         i <-- i + 1 
     ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΑΝ (βρέθηκε = ΑΛΗΘΗΣ) ΤΟΤΕ 
    ΓΡΑΨΕ 'Το στοιχείο βρέθηκε στον πίνακα' 
ΑΛΛΙΩΣ 
    ΓΡΑΨΕ 'Το στοιχείο δεν βρέθηκε στον πίνακα' 
ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

Share This