Επιλογή Σελίδας

Να γραφεί πρόγραμμα που να υπολογίζει το άθροισμα των κυρίων διαγωνίων τετραγωνικού πίνακα ΝxΝ.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ Άθροισμα_Διαγωνίων
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:i, j, Sum1, Sum2, Ν, Α[100,100]
ΑΡΧΗ
! Εισαγωγή Δεδομένων
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δώσε διάσταση τετραγωνικού πίνακα: (1-100)'
    ΔΙΑΒΑΣΕ Ν
ΜΕΧΡΙΣ_ΟΤΟΥ Ν>1 ΚΑΙ Ν<=100
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Ν
        ΓΡΑΨΕ 'ΔΩΣΕ ΣΤΟΙΧΕΙΟ [', i, ' , ',j,' ]'
        ΔΙΑΒΑΣΕ Α[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! Άθροισμα Κύριας
Sum1 <-- 0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν 
    Sum1 <-- Sum1 + Α[i,i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! Άθροισμα Δευτερεύουσας
Sum2 <-- 0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν
    Sum2 <-- Sum2 + Α[i, Ν+1-i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

!Αποτέλεσματα
ΓΡΑΨΕ 'ΑΘΡΟΙΣΜΑ ΚΥΡΙΑΣ: ', SUM1
ΓΡΑΨΕ 'ΑΘΡΟΙΣΜΑ ΔΕΥΤΕΡΕΥΟΥΣΑΣ: ', SUM2
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

Share This