Επιλογή Σελίδας

Να γραφεί πρόγραμμα το οποίο διαβάζει το όνομα ενός μαθητή, τους βαθμούς του σε τρία μαθήματα και υπολογίζει και τυπώνει το μέσο όρο. Το πρόγραμμα να σταματάει, όταν για όνομα δοθεί το κενό.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ ΜΟ_ΒΑΘΜΩΝ
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: ΒΑΘΜΟΣ, ΜΟ, SUM, i
ΧΑΡΑΚΤΗΡΕΣ: ΟΝΟΜΑ
ΑΡΧΗ
ΓΡΑΨΕ 'ΔΩΣΕ ΟΝΟΜΑ ΜΑΘΗΤΗ'
ΔΙΑΒΑΣΕ ΟΝΟΜΑ
ΟΣΟ ΟΝΟΜΑ <> ' ' ΕΠΑΝΑΛΑΒΕ
    SUM <-- 0 
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 3
        ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟ', i
        ΔΙΑΒΑΣΕ ΒΑΘΜΟΣ
        SUM <-- SUM + ΒΑΘΜΟΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΜΟ <-- SUM / 3
    ΓΡΑΨΕ 'Ο ΜΟ ΤΟΥ ΜΑΘΗΤΗ', ΟΝΟΜΑ, ' ΕΙΝΑΙ: ', ΜΟ
    ΓΡΑΨΕ 'ΔΩΣΕ ΟΝΟΜΑ ΜΑΘΗΤΗ'
    ΔΙΑΒΑΣΕ ΟΝΟΜΑ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This