Επιλογή Σελίδας

Να γραφεί πρόγραμμα το οποίο να δέχεται δύο τετραγωνικούς δισδιάστατους πίνακες και να υπολογίζει το άθροισμα και το γινόμενό τους.

Υπόδειξη: Αν a και b είναι οι αρχικοί πίνακες και c ο τελικός, τότε ισχύει:

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ Άθροισμα_Γινόμενο_Πινάκων
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ: Α[100, 100], Β[100, 100], PRODUCT[100, 100], SUM[100, 100], i, j, k
ΑΡΧΗ
! Αρχικοποίηση 
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 100
        SUM[i, j] <-- 0
        PRODUCT[i, j] <-- 0
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

!Εισαγωγή δεδομένων
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100 
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 100 
        ΔΙΑΒΑΣΕ Α[i, j], Β[i, j] 
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 

! Άθροισμα πινάκων
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100 
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 100 
        SUM[i, j] <-- Α[i, j] + Β[i, j] 
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! Γινόμενο πινάκων 
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100 
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 100 
        ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 100 
            PRODUCT[i, j] <-- PRODUCT[i, j] + Α[i, k] + Β[k, j] 
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 

! Αποτέλεσματα
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100 
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 100 
        ΓΡΑΨΕ 'SUM[',i,',',j,'] :' ,SUM[i, j],'  PRODUCT[', i,',', j,'] :',PRODUCT[i, j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

Share This