Επιλογή Σελίδας

Να γραφεί πρόγραμμα που να υπολογίζει τις ρίζες της δευτεροβάθμιας εξίσωσης αx2 + βx + γ = 0. Αν δεν υπάρχουν πραγματικές ρίζες, να εκτυπώνει αντίστοιχο μήνυμα.

ΛΥΣΗ

! ----------------------------------------------------
! Το πρόγραμμα ζητάει 3 πραγματικούς αριθμούς α, β, γ
! και λύνει την εξίσωση αx^2+βx+γ=0
! ----------------------------------------------------

ΠΡΟΓΡΑΜΜΑ Δευτεροβάθμια_εξίσωση
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ, Δ
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε το συντελεστή α:'
  ΔΙΑΒΑΣΕ α
  ΓΡΑΨΕ 'Δώσε το συντελεστή β:'
  ΔΙΑΒΑΣΕ β
  ΓΡΑΨΕ 'Δώσε το συντελεστή γ:'
  ΔΙΑΒΑΣΕ γ  
  ΑΝ α<>0 ΤΟΤΕ
    Δ <-- β^2-4*α*γ
    ΑΝ Δ<0 ΤΟΤΕ
      ΓΡΑΨΕ 'Η εξίσωση είναι ΑΔΥΝΑΤΗ'
    ΑΛΛΙΩΣ_ΑΝ Δ>0 ΤΟΤΕ
      ΓΡΑΨΕ 'Η εξίσωση έχει ΔΥΟ ΡΙΖΕΣ:'
      ΓΡΑΨΕ 'ρ1 =', (-β+Τ_Ρ(Δ))/(2*α)
      ΓΡΑΨΕ 'ρ2 =', (-β-Τ_Ρ(Δ))/(2*α)
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Η εξίσωση έχει ΜΙΑ ΔΙΠΛΗ ΡΙΖΑ:'
      ΓΡΑΨΕ 'ρ =', -β/(2*α)
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    ΑΝ β<>0 ΤΟΤΕ
      ΓΡΑΨΕ 'Η εξίσωση έχει ΜΙΑ ΡΙΖΑ:'
      ΓΡΑΨΕ 'ρ =', -γ/β
    ΑΛΛΙΩΣ
      ΑΝ γ<>0 ΤΟΤΕ
        ΓΡΑΨΕ 'Η εξίσωση είναι ΑΔΥΝΑΤΗ'
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'Η εξίσωση είναι ΑΟΡΙΣΤΗ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This