Επιλογή Σελίδας

Κατά τη διάρκεια ενός πρωταθλήματος μπάσκετ καταγράφεται ο αριθμός των πόντων που έχουν βάλει 5 παίκτες σε 5 διαφορετικά παιχνίδια. Να γραφεί αλγόριθμος που θα σε βοηθήσει να κρατήσεις σε ένα δισδιάστατο πίνακα αυτά τα στοιχεία και στη συνέχεια να υπολογίσεις τον παίκτη που έχει πετύχει το μεγαλύτερο αριθμό πόντων από όλα τα παιχνίδια.

ΛΥΣΗ:
Θα θεωρήσουµε ένα δισδιάστατο πίνακα scores µεγέθους 5×5, όπου κάθε γραµµή του πίνακα αντιστοιχεί σε ένα παίκτη, ενώ κάθε στήλη του πίνακα αντιστοιχεί σε έναν αγώνα. Τους συνολικούς πόντους που πέτυχαν οι παίκτες,τους αποθηκεύουµε σε ένα µονοδιάστατο πίνακα 5 θέσεων που ονοµάζεται sum. Η µεταβλητή first δηλώνει τον αθλητή που επέτυχε συνολικά τους περισσότερους πόντους (max).

Αλγόριθμος Στατιστικά 
Δεδομένα // scores // 
Για i από 1 μέχρι 5 
    sum[i] ← 0 
Τέλος_επανάληψης 
Για i από 1 μέχρι 5 
    Για j από 1 μέχρι 5 
        sum[i] ← sum[i]+ scores[i,j] 
    Τέλος_επανάληψης 
Τέλος_επανάληψης 
max ← sum[1] 
first ← 1 
Για i από 2 μέχρι 5 
    Αν sum[i] > max τότε 
       max ← sum[i] 
       first ← i 
    Τέλος_αν 
Τέλος_επανάληψης 
Αποτελέσματα // first // 
Τέλος Στατιστικά
Share This