Επιλογή Σελίδας

Να συμπληρώσετε το παράδειγμα 1 (εισπράξεις αεροπορικών εταιρειών), ώστε να τυπώνει και αυτές που έχουν εισπράξεις κάτω από το μέσο όρο, να βρίσκει και να τυπώνει την εταιρεία με τις λιγότερες και με τις περισσότερες εισπράξεις.

ΛΥΣΗ 

ΠΡΟΓΡΑΜΜΑ Αεροπορικές_εταιρείες 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ: Ν,Ι, Εισπράξεις[50], Σύνολο, max, min, θέση_max, θέση_min 
ΠΡΑΓΜΑΤΙΚΕΣ:ΜΟ 
ΧΑΡΑΚΤΗΡΕΣ: Εταιρεία[50] 
ΑΡΧΗ 
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΡΑΨΕ 'Αριθμός εταιρειών.. (μικρότερο από 50)'
 ΔΙΑΒΑΣΕ Ν
ΜΕΧΡΙΣ_ΟΤΟΥ Ν<=50
Σύνολο <-- 0
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
 ΓΡΑΨΕ 'Δώσε αεροπορική εταιρεία …'
 ΔΙΑΒΑΣΕ Εταιρεία[Ι]
 ΓΡΑΨΕ 'Δώσε εισπράξεις …'
 ΔΙΑΒΑΣΕ Εισπράξεις[Ι]
 Σύνολο <-- Σύνολο+Εισπράξεις[Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΜΟ <-- Σύνολο/Ν
ΓΡΑΨΕ 'Μεγαλύτερες από το μέσο όρο'
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΑΝ Εισπράξεις[Ι]> ΜΟ ΤΟΤΕ
      ΓΡΑΨΕ Εταιρεία[Ι]
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
max <-- Εισπράξεις[1]
θέση_max <-- 1
ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ Ν
    ΑΝ Εισπράξεις[Ι]>max ΤΟΤΕ
       max <-- Εισπράξεις[Ι]
       θέση_max <-- Ι
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
min <-- Εισπράξεις[1]
θέση_min <-- 1
ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ Ν
    ΑΝ Εισπράξεις[Ι]<min ΤΟΤΕ
       min <-- Εισπράξεις[Ι]
       θέση_min <-- Ι
 ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ 'Η Εταιρία ΜΕ ΤΙΣ ΜΕΓΑΛΥΤΕΡΕΣ Εισπράξεις :',Εταιρεία[θέση_max]
ΓΡΑΨΕ 'Η Εταιρία ΜΕ ΤΙΣ ΜΙΚΡΟΤΕΡΕΣ Εισπράξεις :', Εταιρεία[θέση_min]
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This