Επιλογή Σελίδας

Η φορολογία εισοδήματος φυσικών προσώπων υπολογίζεται από τις αρμόδιες υπηρεσίες του Υπουργείου των Οικονομικών κλιμακωτά, με τη βοήθεια του παρακάτω πίνακα.

Για κάθε φορολογούμενο δίνονται τα εξής στοιχεία: αριθμός φορολογικού μητρώου (ΑΦΜ), όνομα φορολογούμενου, φορολογητέο εισόδημα. Να γραφεί πρόγραμμα το οποίο: Να διαβάζει τα στοιχεία των φορολογουμένων, να υπολογίζει και να τυπώνει το φόρο που τους αντιστοιχεί. Το πρόγραμμα θα διαβάζει τα στοιχεία πολλών φορολογουμένων και θα τελειώνει όταν διαβάζει για ΑΦΜ τον αριθμό 0.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ ΥΠΟΛΟΓΙΣΜΟΣ_ΦΟΡΟΥ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: ΕΙΣΟΔΗΜΑ, ΑΦΜ
ΠΡΑΓΜΑΤΙΚΕΣ: ΦΟΡΟΣ
ΑΡΧΗ
ΓΡΑΨΕ 'ΔΩΣΕ ΑΦΜ:'
ΔΙΑΒΑΣΕ ΑΦΜ
ΟΣΟ ΑΦΜ <> 0 ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'ΔΩΣΕ ΕΙΣΟΔΗΜΑ:'
    ΔΙΑΒΑΣΕ ΕΙΣΟΔΗΜΑ
    ΑΝ ΕΙΣΟΔΗΜΑ <= 1055000 ΤΟΤΕ
       ΦΟΡΟΣ <-- 0
    ΑΛΛΙΩΣ_ΑΝ ΕΙΣΟΔΗΜΑ <= 263700 ΤΟΤΕ
              ΦΟΡΟΣ <-- (ΕΙΣΟΔΗΜΑ - 1055000) * 5 / 100
    ΑΛΛΙΩΣ_ΑΝ ΕΙΣΟΔΗΜΑ <= 420000 ΤΟΤΕ
              ΦΟΡΟΣ <-- 79125 + (ΕΙΣΟΔΗΜΑ - 2637500) * 15 / 100
    ΑΛΛΙΩΣ_ΑΝ ΕΙΣΟΔΗΜΑ <= 7385000 ΤΟΤΕ
              ΦΟΡΟΣ <-- 316500 + (ΕΙΣΟΔΗΜΑ - 2637500) * 30 / 100
    ΑΛΛΙΩΣ_ΑΝ ΕΙΣΟΔΗΜΑ <= 15825000 ΤΟΤΕ
              ΦΟΡΟΣ <-- 1266000 + (ΕΙΣΟΔΗΜΑ - 7385000) * 40 / 100 
    ΑΛΛΙΩΣ
      ΦΟΡΟΣ <-- 464200 + (ΕΙΣΟΔΗΜΑ - 15825000) * 45 / 100 
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ 'ΑΝΑΛΟΓΟΥΝ ΦΟΡΟΣ:' , ΦΟΡΟΣ
    ΓΡΑΨΕ 'ΔΩΣΕ ΑΦΜ:'
    ΔΙΑΒΑΣΕ ΑΦΜ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This