Επιλογή Σελίδας

Να γραφεί πρόγραμμα το οποίο να υπολογίζει τη συνολική χωρητικότητα πυκνωτών και τη συνολική αντίσταση αντιστάσεων. Η συνολική αντίσταση R και η συνολική χωρητικότητα C δίνεται από τους τύπους:

Το πρόγραμμα θα ελέγχεται από μενού επιλογής και θα τερματίζεται όταν ο χρήστης επιλέξει έξοδο.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ ΟΛΙΚΗ_R_C
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: ΕΠΙΛΟΓΗ, ΠΛΗΘΟΣ
ΠΡΑΓΜΑΤΙΚΕΣ: i, SUM, ΤΙΜΗ 
ΛΟΓΙΚΕΣ: ΈΞΟΔΟΣ
ΑΡΧΗ
ΈΞΟΔΟΣ <-- ΨΕΥΔΗΣ
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
   !Μενού Επιλογών
   ΓΡΑΨΕ '1. Αντιστάσεις σε Σειρά'
   ΓΡΑΨΕ '2. Αντιστάσεις Παράλληλα'
   ΓΡΑΨΕ '3. Πυκνωτές σε Σειρά'
   ΓΡΑΨΕ '4. Αντιστάσεις σε Σειρά'
   ΓΡΑΨΕ '5. Έξοδος'
   ΓΡΑΨΕ 'Επιλεξε υπολογισμό (1-5)'
   ΔΙΑΒΑΣΕ ΕΠΙΛΟΓΗ
   ΑΝ ΕΠΙΛΟΓΗ = 1 ΤΟΤΕ
   ΓΡΑΨΕ 'Δώσε πλήθος αντιστάσεων'
   ΔΙΑΒΑΣΕ ΠΛΗΘΟΣ
      SUM <-- 0
      ΓΙΑ i από 1 μέχρι ΠΛΗΘΟΣ
          ΓΡΑΨΕ 'Δώσε αντίσταση ', i
          ΔΙΑΒΑΣΕ ΤΙΜΗ
          SUM <-- SUM + ΤΙΜΗ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'Ολική αντίσταση: ', SUM
   ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛΟΓΗ=2 ΤΟΤΕ
          ΓΡΑΨΕ 'Δώσε πλήθος αντιστάσεων'
          ΔΙΑΒΑΣΕ ΠΛΗΘΟΣ
          SUM <-- 0
          ΓΙΑ i από 1 μέχρι ΠΛΗΘΟΣ
              ΓΡΑΨΕ 'Δώσε αντίσταση ', i
              ΔΙΑΒΑΣΕ ΤΙΜΗ
              SUM <-- SUM + 1/ΤΙΜΗ
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΡΑΨΕ 'Ολική αντίσταση: ', SUM
   ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛΟΓΗ = 3 ΤΟΤΕ
          ΓΡΑΨΕ 'Δώσε πλήθος πυκνωτών'
          ΔΙΑΒΑΣΕ ΠΛΗΘΟΣ
          SUM <-- 0
          ΓΙΑ i από 1 μέχρι ΠΛΗΘΟΣ
             ΓΡΑΨΕ 'Δώσε χωρητικότητα ', i
             ΔΙΑΒΑΣΕ ΤΙΜΗ
             SUM <-- SUM + ΤΙΜΗ
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΡΑΨΕ 'Ολική χωρητικότητα: ', SUM
   ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛΟΓΗ=4 ΤΟΤΕ
          ΓΡΑΨΕ 'Δώσε πλήθος πυκνωτών'
          ΔΙΑΒΑΣΕ ΠΛΗΘΟΣ
          SUM <-- 0
          ΓΙΑ i από 1 μέχρι ΠΛΗΘΟΣ
             ΓΡΑΨΕ 'Δώσε χωρητικότητα ', i
             ΔΙΑΒΑΣΕ ΤΙΜΗ
             SUM <-- SUM + 1/ΤΙΜΗ
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΡΑΨΕ 'Ολική χωρητικότητα: ', SUM
   ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛΟΓΗ=5 ΤΟΤΕ
          ΕΞΟΔΟΣ <-- ΑΛΗΘΗΣ
          ΓΡΑΨΕ 'ΕΞΟΔΟΣ'
! Προαιρετικά, έλεγχος εισόδου 
   ΑΛΛΙΩΣ                          
         ΓΡΑΨΕ 'Επίλεξε από 1 ως 5'
   ΤΕΛΟΣ_ΑΝ
ΜΕΧΡΙΣ_ΟΤΟΥ ΕΞΟΔΟΣ = ΑΛΗΘΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 
Share This