Επιλογή Σελίδας

Να γραφεί πρόγραμμα το οποίο θα εκτελεί κάποια από τις βασικές πράξεις πρόσθεση, αφαίρεση, πολλαπλασιασμό και διαίρεση ανάμεσα σε δύο ακέραιους αριθμούς και θα εμφανίζει το αποτέλεσμα στην οθόνη. Το πρόγραμμα θα ελέγχεται από το παρακάτω μενού επιλογής και θα σταματάει όταν ο χρήστης επιλέξει από το μενού την επιλογή έξοδο.

  1. Πρόσθεση
  2. Αφαίρεση
  3. Πολλαπλασιασμό
  4. Διαίρεση
  5. Έξοδος
    Δώσε επιλογή:__

ΛΥΣΗ:

ΠΡΟΓΡΑΜΜΑ ΑΡΙΘΜΟΜΗΧΑΝΗ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: M1,M2, P, ΕΠΙΛΟΓΗ
ΠΡΑΓΜΑΤΙΚΕΣ: ΑΠΟΤΕΛΕΣΜΑ
ΑΡΧΗ
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
!Μενού Επιλογών
   ΓΡΑΨΕ '1. Πρόσθεση'
   ΓΡΑΨΕ '2. Αφαίρεση'
   ΓΡΑΨΕ '3. Πολλαπλασιασμός'
   ΓΡΑΨΕ '4. Διαίρεση'
   ΓΡΑΨΕ '5. Έξοδος'
   ΓΡΑΨΕ 'Δώσε επιλογή (1-5):'
   ΔΙΑΒΑΣΕ ΕΠΙΛΟΓΗ
   ΑΝ ΕΠΙΛΟΓΗ <> 5 ΤΟΤΕ !Δεν είναι απαραίτητη η εισαγωγή σε περίπτωση εξόδου
      ΓΡΑΨΕ 'Δώσε 2 ακέραιους αριθμούς' 
      ΔΙΑΒΑΣΕ M1, M2
   ΤΕΛΟΣ_ΑΝ
   ΑΝ ΕΠΙΛΟΓΗ = 1 ΤΟΤΕ
      ΑΠΟΤΕΛΕΣΜΑ <-- M1 + M2
      ΓΡΑΨΕ 'Το άθροισμα τους είναι :', ΑΠΟΤΕΛΕΣΜΑ
   ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛΟΓΗ = 2 ΤΟΤΕ
ΑΠΟΤΕΛΕΣΜΑ <-- M1 - M2
      ΓΡΑΨΕ 'Η Διαφορά τους είναι :', ΑΠΟΤΕΛΕΣΜΑ
   ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛΟΓΗ = 3 ΤΟΤΕ
ΑΠΟΤΕΛΕΣΜΑ <-- M1 * M2
      ΓΡΑΨΕ 'Το γινόμενο τους είναι :', ΑΠΟΤΕΛΕΣΜΑ
   ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛΟΓΗ = 4 ΤΟΤΕ
    ΑΝ M2 <> 0 ΤΟΤΕ 
       ΑΠΟΤΕΛΕΣΜΑ <-- M1 / M2
       ΓΡΑΨΕ 'Το πηλίκο τους είναι :', ΑΠΟΤΕΛΕΣΜΑ
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Δε είναι δυνατή η διαίρεση με το 0'
    ΤΕΛΟΣ_ΑΝ
   ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛΟΓΗ = 5 ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΞΟΔΟΣ'
ΤΕΛΟΣ_ΑΝ
ΜΕΧΡΙΣ_ΟΤΟΥ ΕΠΙΛΟΓΗ=5 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This