Επιλογή Σελίδας

Να γράψεις πρόγραμμα το οποίο να εκτελεί τις τέσσερις πράξεις σε μιγαδικούς αριθμούς.

Το πρόγραμμα θα οδηγείται από μενού επιλογής όπου ο χρήστης θα επιλέγει το είδος της πράξης. Στην περίπτωση της διαίρεσης το γ και το δ πρέπει να είναι διάφορα του 0.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ Πράξεις_Μιγαδικών
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: επιλογή
ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ, δ, κ, λ 
ΛΟΓΙΚΕΣ: αδύνατη
ΑΡΧΗ
αδύνατη <-- ψευδής
ΓΡΑΨΕ '1.ΠΡΟΣΘΕΣΗ ΜΙΓΑΔΙΚΩΝ'
ΓΡΑΨΕ '2.ΑΦΑΙΡΕΣΗ ΜΙΓΑΔΙΚΩΝ'
ΓΡΑΨΕ '3.ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ ΜΙΓΑΔΙΚΩΝ'
ΓΡΑΨΕ '4.ΔΙΑΙΡΕΣΗ ΜΙΓΑΔΙΚΩΝ'
ΓΡΑΨΕ 'ΕΠΙΛΕΞΕ ΠΡΑΞΗ (1-4)'
ΔΙΑΒΑΣΕ επιλογή
ΚΑΛΕΣΕ εισαγωγή_δεδ(α, β, γ, δ)
ΑΝ επιλογή = 1 ΤΟΤΕ
   ΚΑΛΕΣΕ πρόσθεση_μιγ(α, β, γ, δ, κ, λ)
ΑΛΛΙΩΣ_ΑΝ επιλογή = 2 ΤΟΤΕ
       ΚΑΛΕΣΕ αφαίρεση_μιγ(α, β, γ, δ, κ, λ)
ΑΛΛΙΩΣ_ΑΝ επιλογή = 3 ΤΟΤΕ
       ΚΑΛΕΣΕ πολλαπλασιασμός_μιγ(α, β, γ, δ, κ, λ)
ΑΛΛΙΩΣ_ΑΝ επιλογή = 4 ΤΟΤΕ
       ΚΑΛΕΣΕ διαίρεση_μιγ(α, β, γ, δ, κ, λ, αδύνατη)
ΤΕΛΟΣ_ΑΝ
ΑΝ αδύνατη = ψευδής ΤΟΤΕ
   ΚΑΛΕΣΕ εμφάνιση_αποτ(κ, λ)
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ εισαγωγή_δεδ(α, β, γ, δ)
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ, δ
ΑΡΧΗ
ΓΡΑΨΕ 'Δώσε πραγματικό μέρος 1ου αριθμού'
ΔΙΑΒΑΣΕ α
ΓΡΑΨΕ 'Δώσε φανταστικό μέρος 1ου αριθμού'
ΔΙΑΒΑΣΕ β
ΓΡΑΨΕ 'Δώσε πραγματικό μέρος 2ου αριθμού' 
ΔΙΑΒΑΣΕ γ
ΓΡΑΨΕ 'Δώσε φανταστικό μέρος 2ου αριθμού '
ΔΙΑΒΑΣΕ δ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ εμφάνιση_αποτ(κ, λ)
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: κ, λ
ΑΡΧΗ
ΓΡΑΨΕ 'To αποτέλεσμα είναι ', κ, ' + ', λ, 'i'
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ πρόσθεση_μιγ(α, β, γ, δ, κ, λ)
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ, δ, κ, λ
ΑΡΧΗ
κ <-- α + γ
λ <-- β + δ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ αφαίρεση_μιγ(α, β, γ, δ, κ, λ)
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ, δ, κ, λ
ΑΡΧΗ
κ <-- α - γ
λ <-- β - δ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ πολλαπλασιασμός_μιγ(α, β, γ, δ, κ, λ)
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ, δ, κ, λ
ΑΡΧΗ
κ <-- α * γ - β * δ
λ <-- α * δ + β * γ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ διαίρεση_μιγ(α, β, γ, δ, κ, λ, αδύνατη)
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ, δ, κ, λ
ΛΟΓΙΚΕΣ: αδύνατη
ΑΡΧΗ
ΑΝ γ<>0 και δ<>0 ΤΟΤΕ
κ <-- α * γ + β * δ / (γ^2 + δ^2)
λ <-- α * δ - β * γ / (γ^2 + δ^2)
ΑΛΛΙΩΣ
     αδύνατη <-- αληθής
     ΓΡΑΨΕ 'Η διαίρεση αυτή είναι αδύνατη'
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
Share This