Επιλογή Σελίδας

Στο κεφάλαιο 2 του βιβλίου σου παρουσιάστηκε και συζητήθηκε αναλυτικά ο Πολλαπλασιασμός αλά Ρωσικά. Να γράψεις πρόγραμμα που να υλοποιεί τον αλγόριθμο αυτό. Το πρόγραμμα να εκτελεστεί για διάφορα ζεύγη τιμών.

ΛΥΣΗ 

ΠΡΟΓΡΑΜΜΑ Πολλαπλασιασμός_αλά_ρωσικά
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: M1,M2, P
Αρχή
Γράψε 'Δώσε 2 ακέραιους αριθμούς'
Διάβασε M1, M2
P <-- 0
Όσο M2 > 0 επανάλαβε
Αν M2 mod 2 = 1 τότε 
   P <-- P+M1
Τέλος_αν
M1 <-- M1*2
M2 <-- M2 div 2
Τέλος_επανάληψης
Γράψε 'Το γινόμενο τους είναι: ', P
Τέλος_Προγράμματος
Share This