Επιλογή Σελίδας

Να γράψεις πρόγραμμα το οποίο θα διαβάζει δύο αριθμούς, θα υπολογίζει το Μέγιστο Κοινό Διαιρέτη (ΜΚΔ) και το Ελάχιστο Κοινό Πολλαπλάσιο (ΕΚΠ) και τέλος θα τυπώνει τα αποτελέσματα.

Υπόδειξη: Για δύο αριθμούς x, y ισχύει: x∙y = ΜΚΔ(x,y) ∙ ΕΚΠ(x,y)

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ ΔΕ1_ΜΚΔ_ΕΚΠ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Α, Β
ΑΡΧΗ
ΓΡΑΨΕ 'ΔΩΣΕ 2 ΘΕΤΙΚΟΥΣ ΑΡΙΘΜΟΥΣ'
ΔΙΑΒΑΣΕ Α, Β
ΓΡΑΨΕ 'ΜΚΔ = ', ΜΚΔ(Α,Β)
ΓΡΑΨΕ 'ΕΚΠ = ', ΕΚΠ(Α,Β)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

! Υπολογιστικά
ΣΥΝΑΡΤΗΣΗ ΜΚΔ(x,y): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: x,y, temp, i
ΛΟΓΙΚΕΣ: βρέθηκε
ΑΡΧΗ
βρέθηκε<--ψευδής
ΑΝ x-y<0 ΤΟΤΕ
   temp <-- y
   y<-- x
   x <-- temp
ΤΕΛΟΣ_ΑΝ
i<-- y
ΟΣΟ (βρέθηκε = ψευδής) ΕΠΑΝΑΛΑΒΕ
    ΑΝ (x mod i = 0) ΚΑΙ (y mod i = 0)  ΤΟΤΕ
        ΜΚΔ <-- i
        βρέθηκε <-- αληθής
    ΤΕΛΟΣ_ΑΝ
    i<-- i - 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

! ΕΚΠ σε σχέση με το ΜΚΔ
! x * y = ΕΚΠ (x, y) * ΜΚΔ (x, y)
ΣΥΝΑΡΤΗΣΗ ΕΚΠ(x,y): ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: x,y
ΑΡΧΗ
ΕΚΠ <-- x*y / ΜΚΔ(x,y)
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
Share This