Να υλοποιηθεί πρόγραμμα που θα διαβάζει τα αυτοκίνητα που διασχίζουν μια διάβαση σε κάθε αλλαγή του σηματοδότη. Το πρόγραμμα σταματά όταν δοθεί τιμή 0 για αριθμό αυτοκινήτων.
Να υπολογίζει τον ΜΟ των οχημάτων (Ακέραιο μέρος) που διέρχονται σε κάθε φανάρι τη διάβαση.
Προέκταση: Το πρόγραμμα διαβάζει 3 αριθμούς που αντιστοιχούν σε διαφορετικές λωρίδες κυκλοφορίας. Στο τέλος υπολογίζεται ο συνολικός αριθμός αυτοκινήτων, ο αριθμός των εναλλαγών του φαναριού και τα αυτοκίνητα που κινήθηκαν σε κάθε λωρίδα. Το πρόγραμμα σταματά όταν δοθεί τιμή 0 για αριθμό αυτοκινήτων και στις 3 λωρίδες.

ΛΥΣΗ

ΠΡΌΓΡΑΜΜΑ ΔΙΑΒΑΣΗ_ΜΕΧΡΙΣΟΤΟΥ_ΚΑΙ_ΠΡΟΕΚΤΑΣΗ
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ:ΜΟ
ΑΚΕΡΑΙΕΣ: ΟΧΗΜΑΤΑ, SUM, ΠΛΗΘΟΣ, Λ1, Λ2, Λ3, ΠΛ1, ΠΛ2, ΠΛ3
ΑΡΧΗ
SUM<- 0
ΠΛΗΘΟΣ <- 0                   ! εναλλαγές φαναριών 
ΠΛ1 <- 0                      ! Πλήθος οχημάτων λωρίδας 1
ΠΛ2 <- 0
ΠΛ3 <- 0
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
   ΔΙΑΒΑΣΕ Λ1, Λ2, Λ3
   ΟΧΗΜΑΤΑ <- Λ1 + Λ2 + Λ3
   ΑΝ ΟΧΗΜΑΤΑ <> 0 ΤΟΤΕ       ! δεν θα επεξεργαστούμε την τιμή-φρουρό
      SUM <- SUM + ΟΧΗΜΑΤΑ
      ΠΛΗΘΟΣ <- ΠΛΗΘΟΣ + 1    
      ΠΛ1 <- ΠΛ1 + Λ1         
      ΠΛ2 <- ΠΛ2 + Λ2
      ΠΛ3 <- ΠΛ3 + Λ3
   ΤΕΛΟΣ_ΑΝ
ΜΕΧΡΙΣ_ΟΤΟΥ ΟΧΗΜΑΤΑ = 0
ΜΟ<- SUM / ΠΛΗΘΟΣ
ΓΡΑΨΕ Α_Μ(ΜΟ)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΛΥΣΗ

ΠΡΌΓΡΑΜΜΑ ΔΙΑΒΑΣΗ_ΜΕΧΡΙΣΟΤΟΥ
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ:ΜΟ
ΑΚΕΡΑΙΕΣ: ΟΧΗΜΑΤΑ, SUM, ΠΛΗΘΟΣ
ΑΡΧΗ
SUM<- 0
ΠΛΗΘΟΣ <- 0
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
  ΔΙΑΒΑΣΕ ΟΧΗΜΑΤΑ
  ΑΝ ΟΧΗΜΑΤΑ <> 0 ΤΟΤΕ   ! δεν θα επεξεργαστούμε την τιμή-φρουρό
     SUM <- SUM + ΟΧΗΜΑΤΑ
     ΠΛΗΘΟΣ <- ΠΛΗΘΟΣ + 1    ! εναλλαγές φαναριών 
  ΤΕΛΟΣ_ΑΝ
ΜΕΧΡΙΣ_ΟΤΟΥ ΟΧΗΜΑΤΑ = 0
ΜΟ<- SUM / ΠΛΗΘΟΣ
ΓΡΑΨΕ ΜΟ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

ΠΡΌΓΡΑΜΜΑ ΔΙΑΒΑΣΗ_ΟΣΟ
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ:ΜΟ
ΑΚΕΡΑΙΕΣ: ΟΧΗΜΑΤΑ, SUM, ΠΛΗΘΟΣ
ΑΡΧΗ
SUM<-0
ΠΛΗΘΟΣ<-0
ΔΙΑΒΑΣΕ ΟΧΗΜΑΤΑ   ! 1 ΔΙΑΒΑΣΜΑ ΕΞΩ ΑΠΟ ΤΗΝ ΕΠΑΝΑΛΗΨΗ
ΟΣΟ ΟΧΗΜΑΤΑ <> 0 ΕΠΑΝΑΛΑΒΕ
    SUM <- SUM + ΟΧΗΜΑΤΑ
    ΠΛΗΘΟΣ <- ΠΛΗΘΟΣ + 1    ! εναλλαγές φαναριών 
    ΔΙΑΒΑΣΕ ΟΧΗΜΑΤΑ   ! 1 ΔΙΑΒΑΣΜΑ ΣΤΟ ΤΕΛΟΣ ΤΗΣ ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
MO <- SUM/ΠΛΗΘΟΣ
ΓΡΑΨΕ ΜΟ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

ΠΡΌΓΡΑΜΜΑ ΔΙΑΒΑΣΗ_FLAG
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: MO
ΑΚΕΡΑΙΕΣ: ΟΧΗΜΑΤΑ, SUM, ΠΛΗΘΟΣ
ΛΟΓΙΚΕΣ: ΤΕΛΟΣ
ΑΡΧΗ
SUM<-0
ΠΛΗΘΟΣ<-0
ΤΕΛΟΣ <- ΨΕΥΔΗΣ
ΟΣΟ ΤΕΛΟΣ = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
    ΔΙΑΒΑΣΕ ΟΧΗΜΑΤΑ
    ΑΝ ΟΧΗΜΑΤΑ <> 0 ΤΟΤΕ
       SUM<- SUM+ΟΧΗΜΑΤΑ
       ΠΛΗΘΟΣ <- ΠΛΗΘΟΣ + 1    ! εναλλαγές φαναριών 
    ΑΛΛΙΩΣ
       ΤΕΛΟΣ <- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
MO<- SUM/ΠΛΗΘΟΣ
ΓΡΑΨΕ MO
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This