Επιλογή Σελίδας

Η Πολεμική Αεροπορία επιτελεί ένα πολύπλευρο έργο. Σε καιρό ειρήνης, λαμβάνει μέρος σε πληθώρα αποστολών έρευνας και διάσωσης, αεροδιακομιδών, αεροπυρόσβεσης και ειρηνευτικών αποστολών σε κάθε γωνιά του πλανήτη. Ο κύριος όμως ρόλος της, είναι η προάσπιση του Ελληνικού εναέριου χώρου από παραβιάσεις. Σχεδόν καθημερινά, Ελληνικά μαχητικά αεροσκάφη αναλαμβάνουν αποστολές αναγνώρισης και αναχαίτισης ξένων αεροσκαφών. Σε αρκετές περιπτώσεις οι αναχαιτίσεις εξελίσσονται σε εμπλοκές. Οι συνθήκες σε αυτές τις περιπτώσεις είναι ιδιαίτερα δυσμενείς για δύο κυρίως λόγους: Τα μαχητικά αεροσκάφη έχουν το ελάχιστο δυνατό εκπεμπόμενο σήμα (σε όλο το φάσμα των ραδιοσυχνοτήτων) για να μην αναγνωρίζονται εύκολα, και είναι γενικά του ιδίου τύπου με τα αντίπαλα αεροσκάφη. Η ασφάλεια των πτήσεων, καθιστά απαραίτητα συστήματα που βοηθούν στον έλεγχο και τη διαχείριση του εναέριου χώρου από τους αρμόδιους φορείς. Προς την κατεύθυνση  αυτή, το σημαντικότερο ρόλο παίζουν τα συστήματα παροχής αξιόπιστης και συγκεντρωτικής εικόνας της εναέριας κυκλοφορίας και τα συστήματα αναγνώρισης εγγυτέρου ίχνους, που αποσκοπούν στην έγκαιρη ενημέρωση των χειριστών σχετικά, με την κατάσταση του αεροπορικού χώρου δράσης τους. Τα συστήματα αυτά πρέπει να μπορούν να αναγνωρίζουν (βρίσκουν τις συντεταγμένες) το συντομότερο δυνατόν, των πλησιέστερων αεροσκαφών.

Πρόβλημα:

Να αναπτύξετε ένα πρόγραμμα σε Γλώσσα το οποίο, αφού διαβάσει τα δεδομένα της εξόδου ενός ψηφιακού ραντάρ, με τη μορφή τριάδας δεδομένων που αντιστοιχούν σε κάθε εντοπισθέν ίχνος, θα τα καταχωρεί σε έναν Πίνακα [20 Χ 3], θα εντοπίζει και θα επισημαίνει (άρα θα εμφανίζει τις συντεταγμένες) από τα ίχνη με τη μικρότερη μεταξύ τους απόσταση, άρα το μεγαλύτερο κίνδυνο σύγκρουσης.

Παρατηρήσεις:

  • Το μοναδικό κριτήριο εντοπισμού είναι η ελάχιστη απόσταση και όχι και άλλα όπως η ταυτότητα των αεροσκαφών.
  • Οι συντεταγμένες των ιχνών είναι της μορφής:
    • 10 -1 0 (10 εμπρός, -1 δεξιά, ίδιο επίπεδο πτήσης)
    • -2 2 1 (-2 πίσω, + 2 αριστερά, +1 επίπεδο πτήσης)
  • Το αεροσκάφος μας βρίσκεται πάντα στη θέση [0, 0, 0]

Μπορεί ταυτόχρονα περισσότερα από ένα αεροσκάφη να βρίσκονται στην εγγύτερη απόσταση οπότε θα εμφανίζονται περισσότερες από μία τριάδες αριθμών. ΕΠΥ, 21ος Π.Δ.Π. (2009) Β’ Φάση (Θέμα Γυμνασίου)

ΛΥΣΗ

! Απόσταση 2 σημείων σε 3 διαστάσεις
! Αλγόριθμος εντοπισμού εγγύτερου ζεύγους             

ΠΡΟΓΡΑΜΜΑ ΑΣΚ4_ΠΑΡ_Β_ΙΕΠ_ΠΙΝ_ΡΑΝΤΑΡ_ΑΕΡΟΠΛΑΝΟΥ
ΣΤΑΘΕΡΕΣ
  n=10
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:  i, j, data[n,3]
  ΠΡΑΓΜΑΤΙΚΕΣ:  distance[n,n-1], min
ΑΡΧΗ    
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ n
    ΓΡΑΨΕ 'Συντεταγμένες αεροπλάνου:', i
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 3
      ΔΙΑΒΑΣΕ data[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  min <-- 10101
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ n
    ΓΙΑ j ΑΠΟ i+1 ΜΕΧΡΙ n-1
      distance[i,j] <-- Τ_Ρ((data[j,1]-data[i,1])^2 + (data[j,2]-data[i,2])^2 + (data[j,3]-data[i,3])^2)
      ΑΝ distance[i,j] < min ΤΟΤΕ
        min <-- distance[i,j]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ! εμφάνιση των εγγύτερων αεροπλάνων
  ΓΡΑΨΕ 'θέσεις εγγύτερων αεροπλάνων:'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ n
    ΓΙΑ j ΑΠΟ i+1 ΜΕΧΡΙ n-1
      ΑΝ distance[i,j]=min ΤΟΤΕ
        ΓΡΑΨΕ i, j
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Σετ εισόδου - εξόδου (Ν=10, Ν=15, Ν=20)

100 2 0

10 3 0

50 6 0

70 7 0

90 8 0

110 9 0

130 10 0

150 11 0

150 12 0

1 3 2

1 1 1

1 1 2

1 2 3

1 2 4

1 2 5

1 3 6

1 3 7

1 4 8

1 4 9

1 5 11

1 5 13

1 6 15

1 6 17

1 7 18

1 7 20

-59 -84 -86

-85 62 -38

30 -6 -27

48 -81 -48

-39 -84 34

65 37 -96

-14 -87 -47

-80 52 -68

72 -58 54

-76 -11 47

19 -74 22

-14 32 -15

-22 -39 -90

-45 61 90

-10 97 -65

-17 36 75

61 33 -4

63 -96 65

64 100 -58

41 47 62

8 9 1 2

3 4

4 5

6 7

8 9

2 8



					
Share This