Επιλογή Σελίδας

Επιλογές (Άλυτες – Παράρτημα A – ΙΕΠ)

1. Να δημιουργήσετε τον πίνακα τιμών ΠΡΟΓΡΑΜΜΑ Α1
των μεταβλητών του δίπλα προγράμ- ΜΕΤΑΒΛΗΤΕΣ
ματος. ΑΚΕΡΑΙΕΣ: Α, Β, Γ, χ, ψ
ΑΡΧΗ
χ ←100
ψ ← 200
Α ← x+1
Β ← 3 * χ
Γ ← Α+Β
ΑΝ C>400 ΤΟΤΕ
Α ← Β
Β ← χ
ΑΛΛΙΩΣ
ΑΝ Β>200 ΤΟΤΕ
Β ← Α
Α ← 20
ΑΛΛΙΩΣ
Α ← Γ
Β ← Α
ΤΕΛΟΣ ΑΝ
ΤΕΛΟΣ ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Α1

 

  1. Τι θα εμφανίσουν τα παρακάτω προγράμματα αν σαν είσοδο δοθούν οι τιμές 5 και 10, στις μεταβλητές χ και ψ αντίστοιχα;
ΠΡΟΓΡΑΜΜΑ Π1 ΠΡΟΓΡΑΜΜΑ Π2
ΜΕΤΑΒΛΗΤΕΣ ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: χ, ψ ΑΚΕΡΑΙΕΣ: χ, ψ
ΑΡΧΗ ΛΟΓΙΚΕΣ: f
ΓΡΑΨΕ ’Δώσε τιμή για χ και ψ:’ ΑΡΧΗ
ΔΙΑΒΑΣΕ χ, ψ ΓΡΑΨΕ ’Δώσε 2 ακέραιες τιμές:’
χ ← χ div 2 ΔΙΑΒΑΣΕ χ, ψ
ψ ← ψ mod 3 χ ← χ ^ 2+1
ΑΝ χ =ψ ΤΟΤΕ ψ ← 2 * ψ+χ ^ 2
χ ← χ ^ 2+1 f ← (χ mod 2=0) ΚΑΙ (ψ mod 2=0)
ψ ← 2 * ψ-4 ^ 2 AΝ f =ΑΛΗΘΗΣ ΤΟΤΕ
ΑΛΛΙΩΣ ΓΡΑΨΕ ’Άρτιοι:’, χ, ψ
χ ← χ mod 2 ΤΕΛΟΣ_ΑΝ
ψ ← ψ div 3 ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Π2
ΤΕΛΟΣ_ΑΝ
ΓΡΑΨΕ χ =’, χ, ’ψ=’, ψ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Π1
  1. Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει από το πληκτρολόγιο τρεις ακέραιους αριθ­μούς. Στη συνέχεια υπολογίζει και εμφανίζει τον αριθμό που είναι ανάμεσα στους άλλους δύο. Δηλαδή, αν δώσω τους αριθμούς 107,53,42 τότε να εμφανιστεί ο 53, γιατί 107>53>42 ή 42<53<107.
  2. Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει το όνομα ενός υπαλλήλου, τις ώρες εργα­σίας και το ωρομίσθιο του. Οι κρατήσεις που γίνονται στον υπάλληλο είναι 15% αν ο μισθός του είναι μέχρι 1.000 €, διαφορετικά είναι 20%. Σε περίπτωση που ο υπάλληλος έχει λιγότερο από 15 ώρες εργασίας τότε οι παραπάνω κρατήσεις μειώνονται κατά 2%.

Ο μισθός κάθε υπαλλήλου υπολογίζεται από τον τύπο:  Ώρες X Ωρομίσθιο – Κρατήσεις

Και οι κρατήσεις από τον τύπο: Κρατήσεις=(Ώρες X Ωρομίσθιο) Χ Ποσοστό/100

  1. Σε κάποιο σχολείο η φοίτηση ενός μαθητή χαρακτηρίζεται ’επαρκής’ εάν το σύνολο όλων των απου­ σιών του δεν ξεπερνά τις 100, εκ των οποίων οι 60 είναι δικαιολογημένες ή το σύνολο των απουσιών του δεν ξεπερνά τις 160 και οι 120 είναι δικαιολογημένες και ο Μέσος όρος τους μεγαλύτερος του 15. Διαφορετικά η φοίτηση είναι ΄ανεπαρκής’

Να γίνει το πρόγραμμα σε ΓΛΩΣΣΑ, που:

  • Να διαβάζει από το πληκτρολόγιο το Μέσο Όρο του μαθητή, το σύνολο Δικαιολογημένων και το σύνολο Αδικαιολόγητων απουσιών του.
  • Να εμφανίζει το μήνυμα ’Φοίτηση επαρκής’ ή ’Φοίτηση ανεπαρκής’, ανάλογα με τις απουσίες του.
  1. Το Υπουργείο Οικονομικών φορολογεί τους Ελεύθερους Επαγγελματίες σύμφωνα με τον παρακάτω
    πίνακα:
Από 1€ μέχρι 20.000€ 22%
Από 20.001€ μέχρι 30.000€ 29%
Από 30.001€ μέχρι 40.000€ 37%
Από 40.001€ και άνω 45%

Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει το εισόδημα ενός ελεύθερου επαγγελμα­τία και στη συνέχεια να υπολογίζει και να εμφανίζει το φόρο που του αναλογεί. Ο υπολογισμός φόρου γίνεται σύμφωνα με τον παραπάνω πίνακα, κλιμακωτά.

  1. Με το σύστημα πληρωμής των διοδίων, οι οδηγοί των τροχοφόρων έχουν τη δυνατότητα να πληρώ­νουν το αντίτιμο των διοδίων με ειδική μαγνητική κάρτα. Υποθέστε ότι υπάρχει μηχάνημα το οποίο διαθέτει είσοδο για την κάρτα και φωτοκύτταρο. Το μηχάνημα διαβάζει από την κάρτα το υπόλοιπο των χρημάτων και το αποθηκεύει σε μια μεταβλητή Υ και με το φωτοκύτταρο αναγνωρίζει τον τύπο του τροχοφόρου και το αποθηκεύει σε μια μεταβλητή Τ. Υπάρχουν τρεις τύποι τροχοφόρων : δίκυκλα (Δ), επιβατικά (Ε) και φορτηγά (Φ), με αντίτιμο διοδίων 1.20€, 2.40€ και 3.50€ αντίστοιχα. Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο:
  • Να ελέγχει τον τύπο του τροχοφόρου και εκχωρεί στη μεταβλητή Α το αντίτιμο των διοδίων, ανάλο­γα με τον τύπο του τροχοφόρου.
  • Να ελέγχει την πληρωμή των διοδίων με τον παρακάτω τρόπο:
    • Αν το υπόλοιπο της κάρτας επαρκεί για την πληρωμή του αντιτίμου των διοδίων, αφαιρεί το ποσό αυτό από την κάρτα.
    • Αν η κάρτα δεν έχει υπόλοιπο, το μηχάνημα ειδοποιεί με μήνυμα για το ποσό που πρέπει να πληρωθεί.
    • Αν το υπόλοιπο δεν επαρκεί, μηδενίζεται η κάρτα και δίνεται με μήνυμα το ποσό που απομένει να πληρωθεί.
  1. Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να δίνει από το πληκτρολόγιο έναν ακέραιο αριθμό και να ελέγχει εάν είναι διψήφιος και θετικός. Στη περίπτωση που ισχύει να τυπώνεται το μήνυμα ’Θε-τικός, Διψήφιος αριθμός’, ενώ διαφορετικά να τυπώνονται για κάθε περίπτωση ’Μόνο θετικός’ ή ’Μόνο διψήφιος’ ή ’Ούτε θετικός, ούτε διψήφιος’.
  2. Ένα μαγαζί με ηλεκτρονικά παιχνίδια χρεώνει τους πελάτες του κλιμακωτά, με το πόση ώρα χρησιμο­ποιούν τα παιχνίδια, σύμφωνα με τον παρακάτω πίνακα:
Χρόνος σε λεπτά Χρέωση ανά λεπτό
60 0,15€
90 0,22€
120 0,37€
180 0,42€
>180 0,55€

Να γραφεί το πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει το χρόνο χρήσης του ηλεκτρονικού παιχνιδιού και στη συνέχεια να υπολογίζει και να εμφανίζει το ποσό χρέωσης, σύμφωνα με τον πα­ραπάνω πίνακα.

  1. Ένα ταξιδιωτικό γραφείο οργανώνει εκδρομές 3ήμερες και 5ήμερες στην Κρήτη, Ρόδο και Μύκονο με αεροπλάνο ή πλοίο. Οι τιμές για κάθε περίπτωση, βρίσκονται στον παρακάτω πίνακα.
Προορισμός 3ήμερη 5ήμερη 3ήμερη 5ήμερη
Κρήτη 400€ 600€ 550€ 750€
Ρόδος 500€ 700€ 700€ 900€
Μύκονος 550€ 650€ 650€ 850€

Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει τον προορισμό, το μέσο μεταφοράς (Π=-πλοίο ή Α=Αεροπλάνο), τις ημέρες διαμονής (3 ή 5) και το πλήθος των ατόμων. Στη συνέχεια υπολο­γίζει και εμφανίζει το κόστος της εκδρομής

Share This