Επιλογή Σελίδας

Προτεινόμενα Θέματα Πανελληνίων, aepp.gr

Η λέξη ‘προτεινόμενα’ δεν σημαίνει απαραίτητα και αναμενόμενα θέματα των εξετάσεων. Το επίπεδο των ασκήσεων κινείται από το απλό ως το αρκετά απαιτητικό χωρίς να είναι στόχος η διαβάθμιση ένός τελικού διαγώνισματος, αλλά η επαφή με αλγοριθμικές προσεγγίσεις που θα μετασχηματιστούν διαφορετικά από τον κάθε αναγνώστη. Τα προαιρετικά ερωτήματα έχουν μεγαλύτερο βαθμό δυσκολίας και αποτελούν προτάσεις περαιτέρω διευρεύνησης.

2016-2017

ΘΕΜΑ Δ, Ψηφοφορία Διαγωνισμού Eurovision

Στη τελική φάση του διαγωνισμού της Eurovision του 2017, συμμετέχουν 26 χώρες, ενώ ψηφίζονται και από τις 42 που συμμετέχουν. Η κάθε χώρα βαθμολογεί 10 χώρες από τις 26 του τελικού, με 1 ως 8, 10 και 12 (10 βαθμολογίες). Να υλοποιήσετε πρόγραμμα που:

Δ1. Περιέχει τμήμα δηλώσεων.
Δ2. Θα διαβάζει τα ονόματα των χωρών που θα συμμετέχουν στον τελικό, σε αλφαβητική σειρά, και θα τα καταχωρεί στις πρώτες θέσεις του πίνακα ΟΝ[42].
Στις επόμενες θέσεις του ΟΝ, θα καταχωρεί αλφαβητικά τις χώρες που αποκλείστηκαν κατά την ημιτελική φάση.
Δ3. Θα διαβάζει τη χώρα που ψηφίζει, έλέγχοντας ότι η χώρα συμμετέχει στο διαγωνισμό και ότι δεν έχει ήδη ψηφίσει. Η διαδικασία της ψηφοφορίας τερματίζεται όταν ψηφίσουν και οι 42 χώρες.
Δ4. Για κάθε χώρα που ψηφίζει, θα διαβάζει τις χώρες που δίνει τους βαθμούς και θα τις καταχωρεί στον πίνακα ΨΗΦ[10]. Ο πίνακας ΨΗΦ είναι τύπου χαρακτήρα, και περιέχει τα ονόματα των χωρών που λαμβάνουν βαθμούς. Οι χώρες στις θέσεις από 1 ως 8 παίρνουν ανάλογους βαθμούς, η θέση 9 αποδίδει 10 βαθμούς, ενώ η θέση 10, το 12άρι!
Δ5. Με κατάλληλο υποπρόγραμμα, για κάθε χώρα που ψηφίζει, θα καταχωρεί τη βαθμολογία της χώρας,  στη συνολική βαθμολογία των χωρών του τελικού, στον πίνακα ΒΑΘ[26] Δ6. Όταν ολοκληρωθεί η ψηφοφορία, θα εμφανίζει τις 5 χώρες με τους περισσότερους βαθμούς. Σε περίπτωση ισοβαθμίας στην 5η θέση, θα εμφανίζει και τους ισόβαθμους.

Προαιρετικά:
Δ7. Θα εμφανίζει τις χώρες που έλαβαν τα περισσότερα 12άρια, στο τέλος της ψηφοφορίας.
Δ8. Θα εμφανίζει τις χώρες που δεν έλαβαν καμία ψήφο. Αν δεν υπάρχει τέτοια χώρα, να εμφανίζεται κατάλληλο μήνυμα.
Δ9. Θα μετρά τις εναλλαγές χωρών στην πρώτη θέση και θα τις εμφανίζει στην οθόνη, στο τέλος της ψηφοφορίας.
Δ10.Στο ερώτημα Δ4, θα καλείται υποπρόγραμμα όπου, επιπλέον, για κάθε ψήφο, θα γίνεται έλεγχος για το ότι η χώρα δεν ψηφίζει τον εαυτό της ή κάποια από τις αποκλεισμένες χώρες.

ΘΕΜΑ Γ, Ζωγραφίζοντας με αριθμούς

Γ1. Να υλοποιηθεί πρόγραμμα που θα διαβάζει τον πίνακα ΠΙΞΕΛ[6,11], ο οποίος έχει στοιχεία τελείες ( . ) και αστέρια ( * ) και κατόπιν θα σχηματίζει τον πίνακα ΚΡΥΠ. Ο πίνακας ΚΡΥΠ έχει στοιχεία τους αριθμούς των στήλων του ΠΙΞΕΛ, όπου γίνεται αλλαγή στοιχείου, είτε από τελεία σε αστέρι ή το αντίθετο. (Θεωρούμε ως προεπιλογή την τελεία. Αν, δηλαδή, το πρώτο στοιχείο μιας γραμμής του ΠΙΞΕΛ είναι αστέρι, θεωρείται αλλαγή στοιχείου, οπότε και το πρώτο στοιχείο που θα καταχωρούσαμε στην αντίστοιχη γραμμή ΚΡΥΠ, θα ήταν 1.)

Στο παρακάτω παράδειγμα σχηματίζεται το γράμμα Α με αστέρια ενώ δίνεται ο πίνακας ΚΡΥΠ που πρέπει να δημιουργηθεί:

ΠΙΞΕΛ[6,11]           ΚΡΥΠ[6,11]
 .....*..... | 6,7,0,0,0,0,0,0,0,0,0,0 |
 ....*.*.... | 5,6,7,8,0,0,0,0,0,0,0,0 |
 ...*...*... | 4,5,8,9,0,0,0,0,0,0,0,0 |
 ..*******.. | 3,10,0, 0,0,0,0,0,0,0,0 |
 .*.......*. | 2,3,10,11,0,0,0,0,0,0,0 |
 *.........* | 1,2,11, 0,0,0,0,0,0,0,0 |

Γ2. Προαιρετικά (η αντίστροφη διαδικασία):

Να υλοποιηθεί πρόγραμμα που θα σχηματίζει στον πίνακα ΠΙΞΕΛ[5,11], ένα σχήμα, με . και *, διαβάζοντας τον πίνακα ΚΡΥΠ. Ο πίνακας έχει στοιχεία τις στήλες όπου γίνεται αλλαγή στοιχείου, είτε από τελεία σε αστέρι ή το αντίθετο.

ΘΕΜΑ Β, Λύση γραμμικού συστήματος 2 εξισώσεων

Να υλοποιηθεί αλγόριθμος που:
θα διαβάζει τις παραμέτρους α, β, γ, 2 γραμμικών εξισώσεων,  θα διαβάζει την αρχή και το τέλος του πεδίου τιμών του x και θα βρίσκει υπολογίζει, αν υπάρχει, η λύση του συστήματος, στο δοσμένο πεδίο τιμών. Θεωρήστε ότι οι παράμετροι είναι <> 0.

 

ΕΝΔΕΙΚΤΙΚΕΣ ΛΥΣΕΙΣ

ΘΕΜΑ Δ | ΘΕΜΑ Γ | ΘΕΜΑ Β

ΘΕΜΑ Δ

ΠΡΟΓΡΑΜΜΑ  ΘΕΜΑ_Δ_ΠΡΟΤΑΣΗ_AEPP_GR_2017
! Στη τελική φάση του διαγωνισμού της Eurovision του 2017, συμμετέχουν 26 χώρες, ενώ ψηφίζονται και από τις 42 που συμμετέχουν.
! Η κάθε χώρα βαθμολογεί 10 χώρες από τις 26 του τελικού, με 1 ως 8, 10 και 12 (10 βαθμολογίες).
! Να υλοποιήσετε πρόγραμμα που:
! Δ1. Περιέχει τμήμα δηλώσεων.
! Δ2. Θα διαβάζει τα ονόματα των χωρών που θα συμμετέχουν στον τελικό, σε αλφαβητική σειρά,
!     και θα τα καταχωρεί στις πρώτες θέσεις του πίνακα ΟΝ[42].
!     Στις επόμενες θέσεις του ΟΝ, θα καταχωρεί αλφαβητικά τις χώρες που αποκλείστηκαν κατά την ημιτελική φάση.
! Δ3. Θα διαβάζει τη χώρα που ψηφίζει, έλέγχοντας ότι η χώρα συμμετέχει στο διαγωνισμό και ότι δεν έχει ήδη ψηφίσει.
!     Η διαδικασία της ψηφοφορίας τερματίζεται όταν ψηφίσουν και οι 42 χώρες.
! Δ4. Για κάθε χώρα που ψηφίζει, θα διαβάζει τις χώρες που δίνει τους βαθμούς και θα τις καταχωρεί στον πίνακα ΨΗΦ[10].
!     Ο πίνακας ΨΗΦ είναι τύπου χαρακτήρα, και περιέχει τα ονόματα των χωρών που λαμβάνουν βαθμούς.
!     Οι χώρες στις θέσεις από 1 ως 8 παίρνουν ανάλογους βαθμούς, η θέση 9 αποδίδει 10 βαθμούς, ενώ η θέση 10, το 12άρι!
! Δ5. Με κατάλληλο υποπρόγραμμα, για κάθε χώρα που ψηφίζει, θα καταχωρεί τη βαθμολογία της χώρας,
!     στη συνολική βαθμολογία των χωρών του τελικού, στον πίνακα ΒΑΘ[26]
! Δ6. Όταν ολοκληρωθεί η ψηφοφορία, θα εμφανίζει τις 5 χώρες με τους περισσότερους βαθμούς.
!     Σε περίπτωση ισοβαθμίας στην 5η θέση, θα εμφανίζει και τους ισόβαθμους.

! Προαιρετικά:
! Δ7. Θα εμφανίζει τις χώρες που έλαβαν τα περισσότερα 12άρια, στο τέλος της ψηφοφορίας.
! Δ8. Θα εμφανίζει τις χώρες που δεν έλαβαν καμία ψήφο. Αν δεν υπάρχει τέτοια χώρα, να εμφανίζεται κατάλληλο μήνυμα.
! Δ9. Θα μετρά τις εναλλαγές χωρών στην πρώτη θέση και θα τις εμφανίζει στην οθόνη, στο τέλος της ψηφοφορίας.
! Δ10.Στο ερώτημα Δ4, θα καλείται υποπρόγραμμα όπου, επιπλέον, για κάθε ψήφο,
! θα γίνεται έλεγχος για το ότι η χώρα δεν ψηφίζει τον εαυτό της ή κάποια από τις αποκλεισμένες χώρες.

ΣΤΑΘΕΡΕΣ
  Ν=42 ! ΠΛΗΘΟΣ ΧΩΡΩΝ
  Τ=26 ! ΠΛΗΘΟΣ ΧΩΡΩΝ ΤΕΛΙΚΟΥ
  Κ=16 ! ΠΛΗΘΟΣ ΑΠΟΚΛΕΙΣΜΕΝΩΝ ΧΩΡΩΝ
  Ψ=10 ! Πλήθος ΨΉΦΩΝ

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i, j, θέση, count, temp, ΒΑΘ[Τ]
  ΧΑΡΑΚΤΗΡΕΣ: ΟΝ[Ν], ΧΩΡΑ, ΨΗΦ[Ψ], temp2
  ΛΟΓΙΚΕΣ: ΨΗΦΙΣΕ[Ν], βρέθηκε, δεν_ξαναψηφίσε
ΑΡΧΗ
!Δ2
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Τ
    ΔΙΑΒΑΣΕ ΟΝ[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Κ
    ΔΙΑΒΑΣΕ ΟΝ[Τ+i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  !Δημιουργούμε έναν πίνακα ΨΗΦΙΣΕ[Ν], παράλληλο στον ΟΝ[Ν]
  !για τον έλεγχο του αν έχει καταμετρηθεί ήδη η ψήφος μιας χώρας

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΨΗΦΙΣΕ[i] <-- ΨΕΥΔΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Τ
    ΒΑΘ[i] <-- 0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  count <-- 0

  ΟΣΟ (count<Ν) ΕΠΑΝΑΛΑΒΕ ! Όταν ο count γίνεται Ν, έχουν ψηφίσει ήδη τόσες χώρες.

    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      δεν_ξαναψηφίσε <-- ΨΕΥΔΗΣ

      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ 'ΔΩΣΤΕ ΧΩΡΑ:'
        ΔΙΑΒΑΣΕ ΧΩΡΑ
        βρέθηκε <-- ΨΕΥΔΗΣ
        θέση <-- 0
        i <-- 1
        ΟΣΟ (i<=Ν και βρέθηκε=ΨΕΥΔΗΣ) ΕΠΑΝΑΛΑΒΕ
          ΑΝ ΧΩΡΑ = ΟΝ[i] ΤΟΤΕ
            βρέθηκε <-- Αληθής
            θέση <-- i
            ΓΡΑΨΕ 'ΕΓΚΥΡΗ ΧΩΡΑ'
          ΑΛΛΙΩΣ
            i <-- i+1
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΑΝ βρέθηκε=ψευδής ΤΟΤΕ
          ΓΡΑΨΕ 'Άγνωστη χώρα'
        ΤΕΛΟΣ_ΑΝ

      ΜΕΧΡΙΣ_ΟΤΟΥ βρέθηκε=ΑΛΗΘΗΣ

      ΑΝ ΨΗΦΙΣΕ[θέση] = ΨΕΥΔΗΣ ΤΟΤΕ
        δεν_ξαναψηφίσε <-- ΑΛΗΘΗΣ
        ΨΗΦΙΣΕ[θέση]   <-- ΑΛΗΘΗΣ
        count <-- count + 1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'Η ΨΗΦΟΣ ΤΗΣ ΧΩΡΑΣ ΕΧΕΙ ΚΑΤΑΜΕΤΡΗΘΕΙ'
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ δεν_ξαναψηφίσε=ΑΛΗΘΗΣ

    ! Δ4
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ψ
      ΔΙΑΒΑΣΕ ΨΗΦ[i]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    !Δ5
    ΚΑΛΕΣΕ Καταμέτρηση(ΨΗΦ, ΒΑΘ, ΟΝ)

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ Τ  ! Ταξινόμηση μέχρι τη θέση των χωρών του τελικού
    ΓΙΑ j ΑΠΟ Τ ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
      ΑΝ ΒΑΘ[j-1] < ΒΑΘ[j] ΤΟΤΕ
        temp <-- ΒΑΘ[j-1]
        ΒΑΘ[j-1] <-- ΒΑΘ[j]
        ΒΑΘ[j] <-- temp

        temp2 <-- ΟΝ[j-1]
        ΟΝ[j-1] <-- ΟΝ[j]
        ΟΝ[j] <-- temp2
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Τελική κατάταξη'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 2
    ΓΡΑΨΕ ΟΝ[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  i <-- 1
  ΟΣΟ ΒΑΘ[i]=ΒΑΘ[5] ΚΑΙ i<Τ ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ ΟΝ[i]
      i <-- i+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΔΙΑΔΙΚΑΣΙΑ Καταμέτρηση(ψήφοι, βαθμοί, χώρες)
ΣΤΑΘΕΡΕΣ
  Ν=42 ! ΠΛΗΘΟΣ ΧΩΡΩΝ
  Τ=26 ! ΠΛΗΘΟΣ ΧΩΡΩΝ ΤΕΛΙΚΟΥ
  Ψ=10  ! Πλήθος ΨΉΦΩΝ

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: βαθμοί[Τ], i, j , θέση, βαθμός
  ΧΑΡΑΚΤΗΡΕΣ: ψήφοι[Ψ], χώρες[Ν]
  ΛΟΓΙΚΕΣ: βρέθηκε
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ψ

    j <-- 1
    βρέθηκε <-- ΨΕΥΔΗΣ
    θέση <-- 0
    ΟΣΟ j<=Τ ΚΑΙ βρέθηκε = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
      ΑΝ ΨΗΦΟΙ[i]=χώρες[j] ΤΟΤΕ
        θέση <-- j
        βαθμός <-- i
        βρέθηκε <-- ΑΛΗΘΗΣ
      ΑΛΛΙΩΣ
        j <-- j+1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΑΝ Βρέθηκε = ΑΛΗΘΗΣ ΤΟΤΕ
      ΑΝ θέση <=8 ΤΟΤΕ
        βαθμοί[θέση] <-- βαθμοί[θέση] + βαθμός
      ΑΛΛΙΩΣ_ΑΝ θέση = 9 ΤΟΤΕ
        βαθμοί[θέση] <-- βαθμοί[θέση] + 10
      ΑΛΛΙΩΣ_ΑΝ θέση = 10 ΤΟΤΕ
        βαθμοί[θέση] <-- βαθμοί[θέση] + 12
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΘΕΜΑ Γ

! Γ1

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Γ1_ΠΡΟΤΕΙΝ_AEPPGR_2017
! Να υλοποιηθεί πρόγραμμα που θα διαβάζει τον πίνακα ΠΙΞΕΛ[6x11], 
! που έχει στοιχεία τελείες ( . ) και αστέρια (*) και κατόπιν θα σχηματίζει τον πίνακα ΚΡΥΠ. 
! Ο πίνακας ΚΡΥΠ έχει στοιχεία τους αριθμούς των στήλων του ΠΙΞΕΛ, όπου γίνεται αλλαγή στοιχείου, 
! είτε από τελεία σε αστέρι ή το αντίθετο. (Θεωρούμε ότι κάθε γραμμή ξεκινά από τελεία. 
! Αν, δηλαδή, το πρώτο στοιχείο μιας γραμμής του ΠΙΞΕΛ ήταν αστέρι, 
!το πρώτο στοιχείο που θα καταχωρούσαμε στην αντίστοιχη γραμμή ΚΡΥΠ, θα ήταν 1.)
!
! ΠΙΞΕΛ[6,11]           ΚΡΥΠ[6,11]
! .....*..... | 6,7,0,0,0,0,0,0,0,0,0,0 |
! ....*.*.... | 5,6,7,8,0,0,0,0,0,0,0,0 |
! ...*...*... | 4,5,8,9,0,0,0,0,0,0,0,0 |
! ..*******.. | 3,10,0, 0,0,0,0,0,0,0,0 |
! .*.......*. | 2,3,10,11,0,0,0,0,0,0,0 |
! *.........* | 1,2,11, 0,0,0,0,0,0,0,0 |

ΣΤΑΘΕΡΕΣ
  ΤΕΛΕΙΑ='.'
  ΑΣΤΕΡΙ='*'

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΚΡΥΠ[6,11], i, j, k
  ΧΑΡΑΚΤΗΡΕΣ: ΠΙΞΕΛ[5,11]
  ΛΟΓΙΚΕΣ: asteria
ΑΡΧΗ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 11
      ΔΙΑΒΑΣΕ ΠΙΞΕΛ[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ! Αρχικοποιούμε σε ΤΕΛΕΙΑ όλον τον πίνακα
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 11
      ΚΡΥΠ[i,j] <-- 0
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
    k <-- 1
    asteria <-- ΨΕΥΔΗΣ
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 11
        ΑΝ ΠΙΞΕΛ[i,j] = ΑΣΤΕΡΙ ΚΑΙ asteria = ΨΕΥΔΗΣ ΤΟΤΕ
           ΚΡΥΠ[i,k] <-- j
           asteria <-- ΑΛΗΘΗΣ
           k <-- k+1
      ΑΛΛΙΩΣ_ΑΝ ΠΙΞΕΛ[i,j] = ΤΕΛΕΙΑ ΚΑΙ asteria = ΑΛΗΘΗΣ ΤΟΤΕ
           ΚΡΥΠ[i,k] <-- j
           asteria <-- ΨΕΥΔΗΣ
           k <-- k+1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
    ΓΡΑΨΕ ΚΡΥΠ[i,1],ΚΡΥΠ[i,2],ΚΡΥΠ[i,3],ΚΡΥΠ[i,4],ΚΡΥΠ[i,5],ΚΡΥΠ[i,6],ΚΡΥΠ[i,7],ΚΡΥΠ[i,8],ΚΡΥΠ[i,9],ΚΡΥΠ[i,10],ΚΡΥΠ[i,11]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

!Γ2
ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Γ2_ΠΡΟΤΑΣΗ_AEPP_GR_2017_Προαιρετική
ΣΤΑΘΕΡΕΣ
  ΤΕΛΕΙΑ='.'
  ΑΣΤΕΡΙ='*'

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΚΡΥΠ[6,11], i, j, k, arxi, telos
  ΧΑΡΑΚΤΗΡΕΣ: pixel[5,11]
  ΛΟΓΙΚΕΣ: asteria
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 11
      ΔΙΑΒΑΣΕ ΚΡΥΠ[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ! Αρχικοποιούμε σε ΤΕΛΕΙΑ όλο τον πίνακα
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 11
      pixel[i,j] <-- ΤΕΛΕΙΑ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
    k <-- 1
    asteria <-- ΑΛΗΘΗΣ
    ΟΣΟ ΚΡΥΠ[i,k] <> 0 ΚΑΙ k <= 10 ΕΠΑΝΑΛΑΒΕ
      arxi <-- ΚΡΥΠ[i,k]
      telos <-- ΚΡΥΠ[i,k+1]-1
      ΓΙΑ j ΑΠΟ arxi ΜΕΧΡΙ telos
        ΑΝ asteria = ΑΛΗΘΗΣ ΤΟΤΕ
          pixel[i,j] <-- ΑΣΤΕΡΙ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

      ΑΝ asteria = ΨΕΥΔΗΣ ΤΟΤΕ
        asteria <-- ΑΛΗΘΗΣ
      ΑΛΛΙΩΣ
        asteria <-- ΨΕΥΔΗΣ
      ΤΕΛΟΣ_ΑΝ

      k <-- k+1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
    ΓΡΑΨΕ pixel[i,1],pixel[i,2],pixel[i,3],pixel[i,4],pixel[i,5],pixel[i,6],pixel[i,7],pixel[i,8],pixel[i,9],pixel[i,10],pixel[i,11]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΘΕΜΑ Β

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Β_ΠΡΟΤΑΣΗ_AEPP_GR_2017
! Να υλοποιηθεί αλγόριθμος που 
! θα διαβάζει τις παραμέτρους α, β, γ, 2 γραμμικών εξισώσεων, 
! θα διαβάζει την αρχή και το τέλος του πεδίου τιμών του x 
! και θα βρίσκει υπολογίζει, αν υπάρχει, τη κοινή λύση τους στο δοσμένο πεδίο τιμών.

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α1, β1, γ1, α2, β2, γ2, x, p1,p2
  ΠΡΑΓΜΑΤΙΚΕΣ: y
  ΛΟΓΙΚΕΣ: βρέθηκε
ΑΡΧΗ
  ΔΙΑΒΑΣΕ α1, β1, γ1
  ΔΙΑΒΑΣΕ α2, β2, γ2
  ΔΙΑΒΑΣΕ p1, p2
  x <-- p1
  βρέθηκε <-- ΨΕΥΔΗΣ
  ΟΣΟ x<=p2 ΚΑΙ βρέθηκε = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
    y <-- ( α1* x + γ1 ) / β1
    ΑΝ α2 * x + β2 * y + γ2 = 0 ΤΟΤΕ
      βρέθηκε <-- ΑΛΗΘΗΣ
      ΓΡΑΨΕ 'ΚΟΙΝΗ ΛΥΣΗ (Χ,Υ)=', x, y
    ΑΛΛΙΩΣ
      x <-- x+1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This