Επιλογή Σελίδας

Λύσεις – Πανελλαδικές Επαναληπτικές Εξετάσεις, Ημερήσια Λύκεια, 2016, Νέο Σύστημα (ΑΕΠΠ)

Θέμα Α, Ερώτημα 1

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και, δίπλα, τη λέξη ΣΩΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η λογική έκφραση (Α > Β) Ή   ΟΧΙ(Α > Β) είναι πάντα αληθής για οποιεσδήποτε τιμές των αριθμητικών μεταβλητών Α και Β.
  2. Στη ΓΛΩΣΣΑ ο χαρακτήρας είναι ένας τύπος δεδομένων.
  3. Το κύριο χαρακτηριστικό των δένδρων   είναι ότι από έναν κόμβο υπάρχει μόνο ένας επόμενος κόμβος.
  4. Έστω ο πίνακας ακεραίων Α[10]. Η εντολή Σ <- Α[10] εκχωρεί στη μεταβλητή Σ το άθροισμα όλων των στοιχείων του πίνακα Α.
  5. Στη στοίβα, ο ίδιος δείκτης μάς δίνει, τόσο τη θέση του στοιχείου που μπορεί να εξαχθεί, όσο και τη θέση εκείνου που εισήλθε τελευταίο.

Μονάδες 10

ΛΥΣΗ

  1. Σωστό         2. Σωστό         3. Λάθος          4. Λάθος          5. Σωστό

 

Θέμα Α, Ερώτημα 2

Σε ποιες περιπτώσεις ένας αλγόριθμος Α χαρακτηρίζεται αποδοτικότερος από ένα αλγόριθμο Β; Να θεωρήσετε ότι η σύγκριση γίνεται κάτω από τις ίδιες ακριβώς συνθήκες (ίδια δεδομένα, ίδιος υπολογιστής, ίδια γλώσσα προγραμματισμού).

Μονάδες 6

Απάντηση

από την παράγραφο 5.1.4 Αποδοτικότητα αλγορίθμων 

«Αν η επίλυση ενός προβλήματος επιτυγχάνεται με τη χρήση δύο ή περισσοτέρων αλγορίθμων, χρειάζεται να γίνει η επιλογή του καταλληλότερου με βάση την αποδοτικότητά τους. Έτσι, αν ο αλγόριθμος Β έχει το ίδιο αποτέλεσμα με τον αλγόριθμο Α, αλλά δίνει τα αποτελέσματα σε λιγότερο χρόνο, τότε είναι αποδοτικότερος του Α. Με παρόμοιο τρόπο όταν ο αλγόριθμος Β έχει το ίδιο αποτέλεσμα με έναν αλγόριθμο Α, αλλά έχει τα αποτελέσματα με χρήση λιγότερης μνήμης, τότε είναι αποδοτικότερος του Α. Βέβαια όταν συγκρίνονται δύο αλγόριθμοι, θα πρέπει να συγκρίνονται με χρήση των ίδιων δεδομένων και κάτω από τις ίδιες συνθήκες. Γενικά, ο χρόνος εκτέλεσης κάθε αλγορίθμου εξαρτάται από ένα σύνολο παραγόντων που μπορούν να συνοψισθούν στους εξής:
Τύπος ηλεκτρονικού υπολογιστή που θα εκτελέσει το πρόγραμμα του αλγορίθμου,
Γλώσσα προγραμματισμού που θα χρησιμοποιηθεί,
Δομή προγράμματος και δομές δεδομένων που χρησιμοποιούνται,
Χρόνος για πρόσβαση στο δίσκο και στις ενέργειες εισόδου-εξόδου,
Είδος συστήματος, ενός χρήστη ή πολλών χρηστών.
Επομένως, για να έχει έννοια κάθε σύγκριση μεταξύ δύο προγραμμάτων αλγορίθμων, θα πρέπει να ικανοποιούνται οι παρακάτω προϋποθέσεις:
και τα δύο προγράμματα να έχουν συνταχθεί στην ίδια γλώσσα προγραμματισμού,
να έχει χρησιμοποιηθεί ο ίδιος μεταφραστής της γλώσσας προγραμματισμού,
να χρησιμοποιείται η ίδια υπολογιστική πλατφόρμα,
ακριβώς τα ίδια δεδομένα να αποτελούν είσοδο κατά τον έλεγχο των δύο αλγορίθμων.»

 

Θέμα Α, Ερώτημα 3

Δίνεται ο παρακάτω πίνακας

Εντολή Επανάληψης Καταλληλότητα Χρήσης
1.    Όσο … επανάλαβε

Τέλος_επανάληψης

α.   Γνωστός αριθμός επαναλήψεων
2.     Για … από … μέχρι … με βήμα …

Τέλος_επανάληψης

β.   Άγνωστος   αριθμός επαναλήψεων
3. Αρχή   επανάληψης …

μέχρις ότου …

γ. Άγνωστος   αριθμός επαναλήψεων, αλλά τουλάχιστον μία επανάληψη

Να   γράψετε στο τετράδιό σας τους αριθμούς της πρώτης στήλη και, δίπλα, το γράμμα της δεύτερης στήλης που αντιστοιχεί σωστά.

Μονάδες 6

ΛΥΣΗ

  1. β
  2. α
  3. γ

 

Θέμα Α, Ερώτημα 4

Δίνονται τα παρακάτω τμήματα αλγορίθμων.

1.
Ι <- 0
Όσο Ι <= 9 επανάλαβε
    J <- I
    Όσο J <= 9 επανάλαβε
        Γράψε 'Α' 
        J <- J + 1 
    Τέλος_επανάληψης 
 Ι <- Ι + 1 
 Τέλος_επανάληψης

2.
Ι <- 0
Όσο Ι < 10 επανάλαβε
    Γράψε 'Α' 
Τέλος_επανάληψης

3.
Ι <- 0
Όσο Ι > 0 επανάλαβε
    Γράψε 'Α'
    Ι <- Ι + 1 
Τέλος_επανάληψης

4.
Για Ι από 0 μέχρι 4
    Γράψε 'Α'
    Για J από 0 μέχρι 6
        Γράψε 'Α' 
    Τέλος_επανάληψης 
Τέλος_επανάληψης

Για καθένα από τα τμήματα αλγορίθμων, να γράψετε στο τετράδιό σας τον αριθμό του (1 έως 4) και, δίπλα, πόσες φορές θα εμφανιστεί το γράμμα Α κατά την εκτέλεσή του.
Μονάδες 8

ΛΥΣΗ

  1. Το γράμμα A θα εμφανιστεί 55 φορές
  2. Το γράμμα A θα εμφανίζεται επ’ άπειρον (ατέρμων βρόχος)
  3. Το γράμμα A δε θα εμφανιστεί καμία φορά
  4. Το γράμμα A θα εμφανιστεί 40 φορές

 

Θέμα Α, Ερώτημα 5

Σε μια κενή στοίβα πρόκειται να εισαχθούν τα στοιχεία Μ, Δ, Κ, με αυτή τη σειρά. Δίνονται οι ακόλουθες σειρές διαδοχικών πράξεων (να θεωρήσετε ότι η λειτουργία της ώθησης παριστάνεται με το γράμμα ω και η λειτουργία της απώθησης παριστάνεται με το γράμμα α):

  1. ω, ω, ω, α, α, α
  2. ω, α, ω, α, ω, α
  3. ω, ω, α, α, ω, α
  4. ω, ω, α, ω, α, α
  5. ω, α, ω, ω, α, α

Για καθεμιά από τις παραπάνω σειρές πράξεων να γράψετε στο τετράδιό σας τον αριθμό της (1 έως 5) και, δίπλα, μόνο τα στοιχεία που θα απωθηθούν με τη σειρά απώθησής τους.

Μονάδες 10

ΛΥΣΗ

  1. Κ, Δ, Μ
  2. Μ, Δ, Κ
  3. Δ, Μ, Κ
  4. Δ, Κ, Μ
  5. Μ, Κ, Δ

 

Θέμα B, Ερώτημα 1

Δίνεται μια λίστα η οποία αποτελείται από 5 κόμβους. Το πρώτο πεδίο του κάθε κόμβου είναι ένα γράμμα και το δεύτερο πεδίο είναι η διεύθυνση του επόμενου κόμβου, όπως φαίνεται στο παρακάτω διάγραμμα, που σχηματίζει τη λέξη ΔΕΚΤΗ:
rg1thv2016imerneo-1

Η λίστα αυτή απεικονίζεται στη μνήμη με τη μορφή που φαίνεται στο παρακάτω σχήμα.

rg1thv2016imerneo-2

α. Να σχεδιάσετε στο τετράδιό σας την απεικόνιση της μνήμης μετά από τη διαγραφή του κατάλληλου κόμβου από την αρχική λίστα, ώστε να σχηματιστεί η λέξη ΔΕΤΗ. (μονάδες 2)

β. Να σχεδιάσετε στο τετράδιό σας την απεικόνιση της μνήμης μετά από την εισαγωγή, στην αρχική λίστα, του κόμβου με πρώτο πεδίο το γράμμα Α στη θέση 21, ώστε να σχηματιστεί η λέξη ΔΕΚΑΤΗ. (μονάδες 4)

Μονάδες 6

 

ΛΥΣΗ

 

Θέμα B, Ερώτημα 2

Δίνεται το παρακάτω τμήμα προγράμματος, το οποίο μετατρέπει έναν ακέραιο αριθμό από το δεκαδικό σύστημα στο δυαδικό.

Π <- 1 
Ι <- 0
ΔΙΑΒΑΣΕ Α 
ΟΣΟ Π <> 0 ΕΠΑΝΑΛΑΒΕ
    Ι <- Ι + 1
    Π <- A DIV 2
    Y<- A MOD 2
    Δ[I] <- Y
    A <- Π 
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Κ ΑΠΟ Ι ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ -1
     ΓΡΑΨΕ Δ[Κ] 
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

α. Για την τιμή Α = 11 :
i) Να συμπληρώσετε τον παρακάτω πίνακα τιμών.

Π Υ Α Ι

(Μονάδες 5)

ii) Να γράψετε τον αριθμό Α και δίπλα του, διαδοχικά, τις τιμές που εμφανίζει το τμήμα του προγράμματος (οι αριθμοί αυτοί αποτελούν τη δυαδική αναπαράσταση του αριθμού Α).  (μονάδες 2)

βΝα επαναλάβετε τα ανωτέρω i) και ii) βήματα για την τιμή Α = 8. (μονάδες 5 + 2)

Μονάδες 14

 

ΛΥΣΗ 

α.    i)

Π Υ Α Ι
1 11 0
5 1 5 1
2 1 2 2
1 0 1 3
0 1 0 4

ii)   Για A = 11,  1 0 1 1 

β.     i)

Π Υ Α Ι
1 8 0
4 0 4 1
2 0 2 2
1 0 1 3
0 1 0 4

ii)   Για A = 8,   1 0 0 0

ΘΕΜΑ Γ

Στο πλαίσιο μιας μελέτης, ένας φιλόλογος θέλει να ελέγξει τη χρήση ενός δείγματος εκατό (100) ναυτικών λέξεων σε σύγχρονα νεοελληνικά κείμενα. Για τον σκοπό αυτό:

Γ1.    Να κατασκευάσετε υποπρόγραμμα, με όνομα ΑΝΑΖΗΤΗΣΗ, το οποίο να δέχεται

  • ένα μονοδιάστατο πίνακα χαρακτήρων Π[100],
  • μια ακέραια μεταβλητή Ν,
  • μια αλφαριθμητική μεταβλητή Χ και να επιστρέφει
  • μια λογική μεταβλητή ΒΡΕΘΗΚΕ και
  • μια ακέραια μεταβλητή ΘΕΣΗ.

Το υποπρόγραμμα να αναζητά μια λέξη, την τιμή της μεταβλητής Χ στις θέσεις 1 έως Ν του πίνακα Π. Αν βρεθεί η λέξη, το υποπρόγραμμα να επιστρέφει την τιμή ΑΛΗΘΗΣ και τη θέση που βρέθηκε. Αν δεν βρεθεί, να επιστρέφει την τιμή ΨΕΥΔΗΣ και την τιμή 0.

Μονάδες 5

Στη συνέχεια να κατασκευάσετε κύριο πρόγραμμα το οποίο:

Γ2. Να ζητά 100 ναυτικές λέξεις και να τις καταχωρίζει σε πίνακα ΛΕΞΕΙΣ[100]. Κάθε λέξη που δίνεται να τη δέχεται, μόνο εφόσον ελέγξει ότι δεν έχει ήδη καταχωριστεί στον πίνακα. Ο έλεγχος να γίνεται με τη χρήση του υποπρογράμματος ΑΝΑΖΗΤΗΣΗ.

Μονάδες 5

Γ3. Να ζητά, με τη σειρά, τις λέξεις ενός νεοελληνικού κειμένου. Η εισαγωγή να τερματίζεται όταν δοθεί ως λέξη η ακολουθία χαρακτήρων «ΤΕΛΟΣ_ΚΕΙΜΕΝΟΥ».

Μονάδες 2

Γ4. Να εμφανίζει τις σπανιότερες ναυτικές λέξεις του δείγματος που υπάρχουν στο νεοελληνικό κείμενο, δηλαδή τις λέξεις με τη μικρότερη συχνότητα εμφάνισης, χρησιμοποιώντας κατάλληλα το υποπρόγραμμα ΑΝΑΖΗΤΗΣΗ.

Μονάδες 8

 

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Γ
 ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: Ι,Ν, ΘΕΣΗ, ΣΥΧΝΟΤΗΤΑ[100], Min, ΟΡΙΟ, Πλήθος_Λέξεων
 ΧΑΡΑΚΤΗΡΕΣ: ΛΕΞΕΙΣ[100], ΛΕΞΗ
 ΛΟΓΙΚΕΣ: ΒΡΕΘΗΚΕ, βρέθηκεMin
 ΑΡΧΗ
 ! Γ2
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
     ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΔΙΑΒΑΣΕ ΛΕΞΕΙΣ[Ι]
        ΟΡΙΟ <-- Ι - 1
        ΚΑΛΕΣΕ ΑΝΑΖΗΤΗΣΗ(ΛΕΞΕΙΣ, ΟΡΙΟ, ΛΕΞΕΙΣ[Ι], ΒΡΕΘΗΚΕ, ΘΕΣΗ)
     ΜΕΧΡΙΣ_ΟΤΟΥ ΒΡΕΘΗΚΕ = ΨΕΥΔΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
 ! Γ3
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
     ΣΥΧΝΟΤΗΤΑ[Ι]  <-- 0 
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΔΙΑΒΑΣΕ ΛΕΞΗ
 Ν  <-- 100
 πλήθος_Λέξεων  <-- 0          !δεν προσμετράται το ΤΕΛΟΣ_ΚΕΙΜΕΝΟΥ
 ΟΣΟ ΛΕΞΗ <> 'ΤΕΛΟΣ_ΚΕΙΜΕΝΟΥ' ΕΠΑΝΑΛΑΒΕ
     Πλήθος_Λέξεων  <-- πλήθος_Λέξεων + 1
     ΚΑΛΕΣΕ ΑΝΑΖΗΤΗΣΗ(ΛΕΞΕΙΣ, Ν, ΛΕΞΗ, ΒΡΕΘΗΚΕ, ΘΕΣΗ)
     ΑΝ ΒΡΕΘΗΚΕ = ΑΛΗΘΗΣ ΤΟΤΕ
        ΣΥΧΝΟΤΗΤΑ[ΘΕΣΗ]  <-- ΣΥΧΝΟΤΗΤΑ[ΘΕΣΗ] + 1
     ΤΕΛΟΣ_ΑΝ
     ΔΙΑΒΑΣΕ ΛΕΞΗ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! Γ4
 Min  <-- Πλήθος_Λέξεων + 1
 βρέθηκεMin <-- ΨΕΥΔΗΣ
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
     ΑΝ ΣΥΧΝΟΤΗΤΑ[Ι] > 0 ΚΑΙ ΣΥΧΝΟΤΗΤΑ[Ι] < Min ΤΟΤΕ  
        Min  <-- ΣΥΧΝΟΤΗΤΑ[Ι]
        βρέθηκεMin  <-- ΑΛΗΘΗΣ
     ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΑΝ βρέθηκεMin = ΑΛΗΘΗΣ ΤΟΤΕ
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
       ΑΝ ΣΥΧΝΟΤΗΤΑ[Ι] = Min ΤΟΤΕ
          ΓΡΑΨΕ 'Λέξη με την μικρότερη συχνότητα εμφάνισης: ', Ι, '. ', ΛΕΞΕΙΣ[Ι]
       ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΛΛΙΩΣ
   ΓΡΑΨΕ 'Καμία λέξη δε βρέθηκε στο κείμενο'  
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 ! Γ1
 ΔΙΑΔΙΚΑΣΙΑ ΑΝΑΖΗΤΗΣΗ(Π, Ν, Χ, ΒΡΕΘΗΚΕ, ΘΕΣΗ)
 ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: Ν, ΘΕΣΗ, Ι
 ΧΑΡΑΚΤΗΡΕΣ: Π[100], Χ
 ΛΟΓΙΚΕΣ: ΒΡΕΘΗΚΕ
 ΑΡΧΗ
 ΘΕΣΗ <-- 0
 ΒΡΕΘΗΚΕ <-- ΨΕΥΔΗΣ
 Ι <-- 1
 ΟΣΟ Ι <= Ν ΚΑΙ ΒΡΕΘΗΚΕ = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ ! Καλύπτεται και η περίπτωση Ν=0
     ΑΝ Π[Ι] = Χ ΤΟΤΕ
        ΘΕΣΗ <-- Ι
        ΒΡΕΘΗΚΕ  <-- ΑΛΗΘΗΣ
     ΤΕΛΟΣ_ΑΝ
     Ι  <-- Ι + 1
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Κατεβάστε ένα δοκιμαστικό αρχείο δεδομένων: arxeio100naytikonoron-3

 

ΘΕΜΑ Δ

Στον αρχαιολογικό χώρο της Πύλου διασώθηκαν θραύσματα κεραμικών πινακίδων στα οποία είχαν καταγραφεί σε γραμμές βασικά αγαθά με τις ποσότητες τους, τα οποία είχε συλλέξει η πόλη κατά τη διάρκεια καλλιεργητικών περιόδων. Σε κάθε θραύσμα, αναφέρονται τα πλήρη στοιχεία (όνομα αγαθού, περίοδος, ποσότητα) για ένα ή περισσότερα αγαθά. Βρέθηκαν στοιχεία για δεκαπέντε (15) βασικά αγαθά και πέντε (5) καλλιεργητικές περιόδους. Όλα τα αγαθά υπάρχουν και στις πέντε περιόδους

Σε κάθε γραμμή οι πρώτοι δέκα χαρακτήρες αντιστοιχούν στο όνομα του αγαθού, ο ενδέκατος στην καλλιεργητική περίοδο και ο δωδέκατος στην ποσότητα που συλλέχτηκε. Οι πέντε καλλιεργητικές περίοδοι αναπαρίστανται από τους χαρακτήρες Α, Β, Γ, Δ και Ε. Η ποσότητα που συλλέχτηκε αναπαρίσταται από τους χαρακτήρες Ι, Κ, Λ, Μ, Ν, Ξ και Ο. Έχει βρεθεί ότι η ποσότητα που αντιστοιχεί σε αυτούς είναι: Ι = 10, Κ = 50, Λ = 100, Μ = 500, Ν  =  1.000,  Ξ  =  5.000  και   Ο  =  10.000.

Συνολικά τα στοιχεία των θραυσμάτων μπορούν να αναπαρασταθούν με ένα δισδιάστατο πίνακα Π[75,12]. Κάθε γραμμή του πίνακα περιέχει τα στοιχεία των αγαθών (όνομα αγαθού, καλλιεργητική περίοδος, ποσότητα). Κάθε στοιχείο του πίνακα περιέχει ένα μόνο χαρακτήρα.

Να γράψετε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:

Δ1.  α. Να περιλαμβάνει κατάλληλο τμήμα δηλώσεων. (μονάδα 1)

β. Να εισάγει σε πίνακα χαρακτήρων Π[75,12] τα στοιχεία των αγαθών που βρέθηκαν στα θραύσματα των πινακίδων. (μονάδες 2)

Μονάδες 3

Δ2. Να ταξινομεί κατά αύξουσα σειρά τον πίνακα Π, με βάση την καλλιεργητική περίοδο, και, για την ίδια καλλιεργητική περίοδο, να ταξινομεί τα αγαθά, με βάση τον πρώτο χαρακτήρα κάθε αγαθού. (Θεωρήστε ότι ο πρώτος χαρακτήρας κάθε αγαθού είναι μοναδικός).

Μονάδες 6

Δ3. α. Να δημιουργεί έναν πίνακα ακεραίων Α[75]. Κάθε στοιχείο του πίνακα Α αντιστοιχεί σε μια γραμμή του ταξινομημένου πίνακα Π και περιέχει την αντίστοιχη ποσότητα του αγαθού που συλλέχτηκε. Η μετατροπή της ποσότητας από χαρακτήρα σε αριθμό να γίνει με βάση την αντιστοιχία που δόθηκε παραπάνω.  (μονάδες 2)

β. Να βρίσκει και να εμφανίζει για κάθε αγαθό το πρώτο γράμμα του ονόματός του και την καλλιεργητική του περίοδο με τη μέγιστη ποσότητα που συλλέχτηκε. (Θεωρήστε ότι η μέγιστη ποσότητα κάθε αγαθού είναι μοναδική).  (μονάδες 4)

Μονάδες 6

Δ4. Να δημιουργεί έναν πίνακα ακεραίων Σ[15]. Κάθε στοιχείο του πίνακα Σ αντιστοιχεί σε ένα αγαθό (όπως αυτό εμφανίζεται στις δεκαπέντε πρώτες σειρές του πίνακα Π) και περιέχει την συνολική ποσότητα του αγαθού που συλλέχτηκε στις πέντε καλλιεργητικές περιόδους.

Μονάδες 5

 

ΛΥΣΗ


ΠΡΟΓΡΑΜΜΑ Θέμα_4
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: i, j, k, Α[75], max_ποσότητα, Σ[15]
 ΧΑΡΑΚΤΗΡΕΣ: Π[75, 12], tmp, max_περίοδος
 ΛΟΓΙΚΕΣ: ΒΡΕΘΗΚΕ
ΑΡΧΗ
 ! Δ.1
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 75
     ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12
         ΔΙΑΒΑΣΕ Π[i, j]
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
 ! Δ.2
 ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 75
     ΓΙΑ j ΑΠΟ 75 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
         ΑΝ Π[j, 11] < Π[j - 1, 11] Η (Π[j, 11] = Π[j - 1, 11] ΚΑΙ Π[j, 1] < Π[j - 1, 1]) ΤΟΤΕ
            ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 12
                tmp <-- Π[j - 1, k]
                Π[j - 1, k] <-- Π[j, k]
                Π[j, k] <-- tmp
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
         ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
 ! Δ.3.α
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 75
     ΑΝ Π[j, 12] = 'Ι' ΤΟΤΕ
        Α[i] <-- 10
     ΑΛΛΙΩΣ_ΑΝ Π[j, 12] = 'Κ' ΤΟΤΕ
        Α[i] <-- 50
     ΑΛΛΙΩΣ_ΑΝ Π[j, 12] = 'Λ' ΤΟΤΕ
        Α[i] <-- 100
     ΑΛΛΙΩΣ_ΑΝ Π[j, 12] = 'Μ' ΤΟΤΕ
        Α[i] <-- 500
     ΑΛΛΙΩΣ_ΑΝ Π[j, 12] = 'Ν' ΤΟΤΕ
        Α[i] <-- 1000
     ΑΛΛΙΩΣ_ΑΝ Π[j, 12] = 'Ξ' ΤΟΤΕ
        Α[i] <-- 5000
     ΑΛΛΙΩΣ
        Α[i] <-- 10000
     ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
 ! Δ.3.β
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 15
     max_ποσότητα <-- Α[i]
     max_περίοδος <-- Π[i, 11]
     ΓΙΑ j ΑΠΟ i ΜΕΧΡΙ 75 ΜΕ ΒΗΜΑ 15
         ΑΝ Α[j] > max_ποσότητα ΤΟΤΕ
            max_ποσότητα <-- Α[j]
            max_περίοδος <-- Π[j, 11]
         ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΓΡΑΨΕ '1ο Γράμμα προϊόντος: ', Π[i, 1]
     ΓΡΑΨΕ 'Καλύτερη Καλλιεργητική περίοδος: ', max_περίοδος
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
 ! Δ.4
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 15
     Σ[i] <-- 0
     ΓΙΑ j ΑΠΟ i ΜΕΧΡΙ 75 ΜΕ ΒΗΜΑ 15
         Σ[i] <-- Σ[i] + Α[j]
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΓΡΑΨΕ 'Αθροισμα περιόδων για το προϊόν, ', i, ' : ', Σ[i]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ (PDF)
Share This