Επιλογή Σελίδας
Δίνεται το παρακάτω τμήμα αλγορίθμου.
 
 Χ <-- 1
 Όσο Χ<5 επανάλαβε
 Α <-- Χ+2
 Β <-- 3*Α-4
 C <-- Β-Α+4
 Αν Α > Β τότε
    Αν Α > C τότε 
       MAX <-- A
    αλλιώς
       MAX <-- C
    Τέλος_αν 
 αλλιώς
    Αν Β > C τότε 
       MAX <-- Β
    αλλιώς
       MAX <-- C
    Τέλος_αν 
 Τέλος_αν
 Εμφάνισε Χ, Α, Β, C, MAX
 Χ <-- Χ+2
 Τέλος_επανάληψης

 Ποιες είναι οι τιμές των μεταβλητών Χ, Α, Β, C, MAX που θα εμφανιστούν κατά την εκτέλεση του παραπάνω τμήματος αλγορίθμου;

Μονάδες 20

Σημείωση: Αντί του συμβόλου (<-) μπορεί ισοδύναμα να χρησιμοποιηθεί το σύμβολο (: =) ή το (=). Επίσης αντί του Όσο … επανάλαβε … Τέλος επανάληψης μπορεί ισοδύναμα να χρησιμοποιηθεί όσο … κάνε … τέλοςόσο και αντί του Τέλος_αν μπορεί ισοδύναμα να χρησιμοποιηθεί το τέλοςαν.

ΛΥΣΗ:

Οι τιμές που θα εμφανιστούν είναι :

X Α Β C MAX
1η επανάληψη 1 3 5 6 6
2η επανάληψη 3 5 11 10 11

Θέματα σε pdf, 2001, Ημερήσια, Μαΐου-Ιουνίου

Share This