Επιλογή Σελίδας

Θέμα B, Eρώτημα 1, 2015, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, όπου η μεταβλητή x έχει θετική ακέραια τιμή:

Αν x > 1 τότε 
   y <-- x
   Αρχή_επανάληψης 
      y <-- y-2 
      Εμφάνισε y 
   Μέχρις_ότου y ≤ 0 
Τέλος_αν

α. Να σχεδιάσετε στο τετράδιό σας το ισοδύναμο διάγραμμα ροής. (μονάδες 6)
β. Να ξαναγράψετε το τμήμα αυτό στο τετράδιό σας, χρησιμοποιώντας την εντολή Για αντί της εντολής Μέχρις_ότου. (μονάδες 8)
Μονάδες 14

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

Β1α.

Β1β.

Αν x>1 τότε 
   Για y από x-2 μέχρι -1 με βήμα –2 
       Εμφάνισε y
   Τέλος_επανάληψης
Τέλος_αν

β' τρόπος
Αν x>1 τότε 
  Για y από x µέχρι 1 µε_βήµα -2 
      Εµφάνισε y-2 
  Τέλος_επανάληψης 
Τέλος_αν

 

 

Θέμα B, Eρώτημα 2, 2015, Ημερήσια

Το παρακάτω ημιτελές τμήμα αλγορίθμου εισάγει αριθμητικές τιμές σε πίνακα 100 θέσεων ώστε:
α. οι τιμές να είναι διαφορετικές μεταξύ τους,
β. οι τιμές να εισάγονται σε αύξουσα σειρά.
Εάν κάποια εισαγόμενη τιμή δεν ικανοποιεί τις συνθήκες (α) και (β), επανεισάγεται.

Διάβασε Π[ ...(1)...] 
 Για i από ...(2)... μέχρι ...(3)...
     Αρχή_επανάληψης 
         Διάβασε Π[i]
     Μέχρις_ότου Π[ ...(4)...] ...(5)... Π[ ...(6)...]
 Τέλος_επανάληψης

Να γράψετε στο τετράδιό σας τους αριθμούς (1) έως (6), που αντιστοιχούν στα κενά του αλγορίθμου και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε το τμήμα αλγορίθμου να επιτελεί τη λειτουργία που περιγράφεται.

Μονάδες 6

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

(1) 1 , (2) 2, (3) 100 , (4) i , (5) > , (6) i-1

Θέμα A, Ερώτημα 5, 2014, Ημερήσια

Δίνεται το παρακάτω ημιτελές τμήμα αλγορίθμου:

Α <- …
Β <- …
Αρχή_επανάληψης
Β <- …
Α <- …
Μέχρις_ότου Α>200
Εμφάνισε Β

Να ξαναγράψετε στο τετράδιό σας το παραπάνω τμήμα αλγορίθμου με τα κενά συμπληρωμένα, έτσι ώστε να υπολογίζει και να εμφανίζει το άθροισμα των περιττών ακεραίων από το 100 έως το 200.

Μονάδες 8

Τα θέματα σε pdf, 2014, Μαΐου-Ιουνίου, Ημερήσια

Θέμα A, Ερώτημα 4, 2012, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, το οποίο εμφανίζει τα τετράγωνα των περιττών αριθμών από το 99 μέχρι το 1 με φθίνουσα σειρά.

Για i από 99 μέχρι 1 μεβήμα -2
x <- i ^2
εμφάνισε x
Τέλος
επανάληψης

α. Να ξαναγράψετε στο τετράδιό σας το παραπάνω τμήμα αλγορίθμου με αποκλειστική χρήση της δομής επανάληψης «Όσο … επανάλαβε».

(μονάδες 5)

β. Να ξαναγράψετε στο τετράδιό σας το παραπάνω τμήμα αλγορίθμου με αποκλειστική χρήση της δομής επανάληψης «Αρχήεπανάληψης … Μέχριςότου».

(μονάδες 5)

Μονάδες 10

Τα θέματα σε pdf, 2012, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Α, Ερώτημα 1, 2013, Μαΐου-Ιουνίου, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-6 και δίπλα τη λέξη ΣΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η τιμή μιας μεταβλητής και ο τύπος της μπορούν να αλλάζουν κατά την εκτέλεση ενός προγράμματος.
  2. Όταν υπάρχουν δυο βρόχοι, ο ένας εμφωλευμένος μέσα στον άλλο, αυτός που ξεκινάει τελευταίος πρέπει να ολοκληρώνεται πρώτος.
  3. Μια διαφορά της εντολής Όσο σε σχέση με την εντολή Μέχρις_ότου οφείλεται στη θέση της λογικής συνθήκης στη ροή εκτέλεσης των εντολών.
  4. Αν Α=2, Β=3, Γ=4 και Δ=ΑΛΗΘΗΣ, τότε η τιμή της έκφρασης (Β*Γ>Α+Β) ΚΑΙ (ΟΧΙ(Δ)) είναι ΑΛΗΘΗΣ.
  5. Κατά την εκτέλεση της εντολής ΔΙΑΒΑΣΕ, το πρόγραμμα διακόπτει την εκτέλεσή του και περιμένει την εισαγωγή τιμών από το πληκτρολόγιο.
  6. Οι πίνακες δεν μπορούν να έχουν περισσότερες από δύο διαστάσεις.

Μονάδες 6

Θέμα Α, Ερώτημα 4, 2001, Ημερήσια, Επαναληπτικές

Δίνεται το παρακάτω τμήμα αλγορίθμου:
Χ <- Α
Αρχήεπανάληψης
Χ<-Χ+2
τύπωσε το Χ
μέχριςότου Χ >= Μ
α. Να δώσετε τη δομή επανάληψης “Για … από … μέχρι … βήμα” η οποία τυπώνει ακριβώς τις ίδιες τιμές με το πιο πάνω τμήμα αλγορίθμου.
Μονάδες 7
β. Τι θα τυπωθεί, αν Α = 4 και Μ = 9;
Μονάδες 3
γ. Τι θα τυπωθεί, αν Α = -5 και Μ = 0 ;
Μονάδες 3

ΛΥΣΗ: (περισσότερα…)