Επιλογή Σελίδας

Λύσεις – Πανελλαδικές Εξετάσεις, Μαΐου, Ημερήσια Λύκεια, 2001 (ΑΕΠΠ)

Θέμα Α, Ερώτημα 1
Να μεταφέρετε στο τετράδιό σας και να συμπληρώσετε τον παρακάτω πίνακα αλήθειας Δύο προτάσεων Α, Β και των τριών λογικών πράξεων.

Πρόταση Α Πρόταση Β Α ή Β

(Διάζευξη)

Α και Β

(Σύζευξη)

όχι Α

(Άρνηση)

Ψευδής Ψευδής
Ψευδής Αληθής
Αληθής Ψευδής
Αληθής Αληθής

Μονάδες 6

ΛΥΣΗ

παράγραφος 2.4.4 Εμφωλευμένες διαδικασίες, Πίνακας Αληθείας

Πρόταση Α Πρόταση Β Α ή Β

(Διάζευξη)

Α και Β

(Σύζευξη)

όχι Α

(Άρνηση)

Ψευδής Ψευδής Ψευδής Ψευδής  Αληθής
Ψευδής Αληθής  Αληθής Ψευδής  Αληθής
Αληθής Ψευδής  Αληθής Ψευδής Ψευδής
Αληθής Αληθής  Αληθής  Αληθής Ψευδής

 

Θέμα Α, Ερώτημα 2

Δίνεται η δομή επανάληψης.

Για i από τιμή1 μέχρι τιμή2 με_βήμα β

Εντολές

Τέλος_επανάληψης

Να μετατρέψετε την παραπάνω δομή σε ισοδύναμη δομή επανάληψης Όσο … επανάλαβε.

Σημείωση: Αντί του Όσο … επανάλαβε μπορεί ισοδύναμα να χρησιμοποιηθεί όσο … κάνε. Επίσης αντί του:

Για i από τιμή1 μέχρι τιμή2 με_βήμα β

Εντολές

Τέλος_επανάληψης

μπορεί ισοδύναμα να χρησιμοποιηθεί το:

για i:= τιμή1 μέχρι τιμή2 μεταβολή β κάνε

Εντολές

τέλοςγια

Μονάδες 9

ΛΥΣΗ:

i <-- τιμή1
Όσο i <= τιμή2 επανάλαβε
    Εντολές
    i<-- i + β
Τέλος επανάληψης

 

Θέμα Α, Ερώτημα 3

Δίνονται οι παρακάτω έννοιες:

  1. Λογικός τύπος δεδομένων
  2. Επιλύσιμο
  3. Ακέραιος τύπος δεδομένων
  4. Περατότητα
  5. Μεταβλητή
  6. Ημιδομημένο
  7. Πραγματικός τύπος δεδομένων
  8. Σταθερά
  9. Αδόμητο
  10. Καθοριστικότητα
  11. Άλυτο
  12. Ανοικτό

Να γράψετε στο τετράδιό σας ποιες από τις παραπάνω έννοιες:

α.   είναι στοιχεία μιας γλώσσας προγραμματισμού;  Μονάδες 5

β.   ανήκουν σε κατηγορίες προβλημάτων;  Μονάδες 5

ΛΥΣΗ:

α : 1, 3, 5, 7, 8

β : 2, 6, 9, 11, 12

Θέματα σε pdf, 2001, Ημερήσια, Μαΐου-Ιουνίου

Θέμα Α, Ερώτημα 4

Δίνεται μονοδιάστατος πίνακας Π, Ν στοιχείων, που είναι ακέραιοι αριθμοί. Να αναπτύξετε αλγόριθμο, ο οποίος να ταξινομεί με τη μέθοδο της φυσαλίδας τα στοιχεία του πίνακα Π.

Μονάδες 15

ΛΥΣΗ: 

Ταξινόμηση ευθείας ανταλλαγής (φυσαλίδα) , Παράδειγμα, παράγραφος 3.7 Ταξινόμηση, Βιβλίο Μαθητή

Θέμα Β

Δίνεται το παρακάτω τμήμα αλγορίθμου.
 
 Χ <-- 1
 Όσο Χ<5 επανάλαβε
 Α <-- Χ+2
 Β <-- 3*Α-4
 C <-- Β-Α+4
 Αν Α > Β τότε
    Αν Α > C τότε 
       MAX <-- A
    αλλιώς
       MAX <-- C
    Τέλος_αν 
 αλλιώς
    Αν Β > C τότε 
       MAX <-- Β
    αλλιώς
       MAX <-- C
    Τέλος_αν 
 Τέλος_αν
 Εμφάνισε Χ, Α, Β, C, MAX
 Χ <-- Χ+2
 Τέλος_επανάληψης

 Ποιες είναι οι τιμές των μεταβλητών Χ, Α, Β, C, MAX που θα εμφανιστούν κατά την εκτέλεση του παραπάνω τμήματος αλγορίθμου;

Μονάδες 20

Σημείωση: Αντί του συμβόλου (<-) μπορεί ισοδύναμα να χρησιμοποιηθεί το σύμβολο (: =) ή το (=). Επίσης αντί του Όσο … επανάλαβε … Τέλος επανάληψης μπορεί ισοδύναμα να χρησιμοποιηθεί όσο … κάνε … τέλοςόσο και αντί του Τέλος_αν μπορεί ισοδύναμα να χρησιμοποιηθεί το τέλοςαν.

ΛΥΣΗ:

Οι τιμές που θα εμφανιστούν είναι :

X Α Β C MAX
1η επανάληψη 1 3 5 6 6
2η επανάληψη 3 5 11 10 11

 

Θέμα Γ

Δίνεται πίνακας Π δύο διαστάσεων, που τα στοιχεία του είναι ακέραιοι αριθμοί µε Ν γραμμές και Μ στήλες. Να αναπτύξετε αλγόριθμο που να υπολογίζει το ελάχιστο στοιχείο του πίνακα.

Μονάδες 20

ΛΥΣΗ: 

Αλγόριθμος ΕλάχιστοΠίνακα
Δεδομένα // Π, Ν, Μ //
min<– Π[1,1]
Για i από 1 μέχρι Ν
      Για j από 1 μέχρι Μ
           Αν Π[i,j] < min τότε
min <– Π[i,j]
          Τέλος
αν
      Τέλοςεπανάληψης
Τέλος
επανάληψης
Τέλος Ελάχιστο_Πίνακα

 

Θέμα Δ

Σε ένα πρόγραμμα περιβαλλοντικής εκπαίδευσης συμμετέχουν 20 σχολεία. Στα πλαίσια αυτού του προγράμματος, εθελοντές μαθητές των σχολείων, που συμμετέχουν στο πρόγραμμα, μαζεύουν ποσότητες τριών υλικών (γυαλί, χαρτί και αλουμίνιο).

Να αναπτύξετε έναν αλγόριθμο, ο οποίος:
α.   να διαβάζει τις ποσότητες σε κιλά των παραπάνω υλικών που μάζεψαν οι μαθητές σε κάθε σχολείο
Μονάδες 4

β.    να υπολογίζει τη συνολική ποσότητα σε κιλά του κάθε υλικού που μάζεψαν οι μαθητές σε όλα τα σχολεία
Μονάδες 8

γ. αν η συνολική ποσότητα του χαρτιού που μαζεύτηκε από όλα τα σχολεία είναι λιγότερη των 1000 κιλών, να εμφανίζεται το μήνυμα «Συγχαρητήρια». Αν η ποσότητα είναι από 1000 κιλά και πάνω, αλλά λιγότερο από 2000, να εμφανίζεται το μήνυμα «Δίνεται έπαινος» και τέλος αν η ποσότητα είναι από 2000 κιλά και πάνω να εμφανίζεται το μήνυμα «Δίνεται βραβείο».
Μονάδες 8

Παρατήρηση: Να θεωρήσετε ότι όλες οι ποσότητες είναι θετικοί αριθμοί.

ΛΥΣΗ:

Αλγόριθμος Περιβαλλοντική
 ΣΓ <-- 0             ! Σύνολο γυαλιού
 ΣΧ <-- 0             ! Σύνολο χαρτιού
 ΣΑ <-- 0             ! Σύνολο αλουμίνιου
 Για i από 1 μέχρι 20
      Διάβασε Γ, Χ, Α
      ΣΓ <-- ΣΓ + Γ
      ΣΧ <-- ΣΧ + X
      ΣΑ <-- ΣΑ + A
 Τέλος_επανάληψης
 Αν ΣΧ < 1000 τότε
     Εμφάνισε 'Συγχαρητήρια'
 αλλιώς_αν ΣΧ < 2000 τότε
     Εμφάνισε 'Δίνεται έπαινος'
 αλλιώς
     Εμφάνισε 'Δίνεται βραβείο'
 Τέλος_αν
 Τέλος Περιβαλλοντική
Share This