Επιλογή Σελίδας

Να γράψεις το πρόγραμμα ΔΕ5 του κεφαλαίου 8 που υπολογίζει τη συνολική χωρητικότητα πυκνωτών και τη συνολική αντίσταση αντιστάσεων με τη χρήση υποπρογραμμάτων.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ ΟΛΙΚΗ_R_C
 ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: ΕΠΙΛΟΓΗ, ΠΛΗΘΟΣ
 ΠΡΑΓΜΑΤΙΚΕΣ: ΟΛΙΚΗ, ΜΕΓΕΘΟΣ[100] ! άθροιση μέχρι 100 στοιχείων
 ΛΟΓΙΚΕΣ: Άθροισμα_Αντιστρόφων
 ΑΡΧΗ
 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
     ΚΑΛΕΣΕ Μενού(ΕΠΙΛΟΓΗ)
     ΑΝ ΕΠΙΛΟΓΗ = 5 ΤΟΤΕ 
        ΓΡΑΨΕ 'ΕΞΟΔΟΣ'
     ΑΛΛΙΩΣ
        ΚΑΛΕΣΕ Εισαγωγή_Δεδ(ΜΕΓΕΘΟΣ, ΠΛΗΘΟΣ)
        ΑΝ ΕΠΙΛΟΓΗ = 1 ΤΟΤΕ                  ! αντιστάσεις σε σειρά
           Αθροισμα_Αντιστρόφων <-- ΨΕΥΔΗΣ
        ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛΟΓΗ=2 ΤΟΤΕ             ! αντιστάσεις παράλληλα
           Άθροισμα_Αντιστρόφων <-- ΑΛΗΘΗΣ
        ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛΟΓΗ = 3 ΤΟΤΕ           ! πυκνωτές σε σειρά
           Άθροισμα_Αντιστρόφων <-- ΑΛΗΘΗΣ
        ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛΟΓΗ=4 ΤΟΤΕ             ! πυκνωτές παράλληλα
           Άθροισμα_Αντιστρόφων <-- ΨΕΥΔΗΣ
        ! Προαιρετικά, έλεγχος εισόδου.
        ΑΛΛΙΩΣ
           ΓΡΑΨΕ 'Επίλεξε από 1 ως 5'
        ΤΕΛΟΣ_ΑΝ
        ΟΛΙΚΗ<-- Ολ_Μέγεθος(Άθροισμα_Αντιστρόφων, ΜΕΓΕΘΟΣ, ΠΛΗΘΟΣ)
        ΚΑΛΕΣΕ Εμφάνιση_αποτ(ΕΠΙΛΟΓΗ,ΟΛΙΚΗ)
     ΤΕΛΟΣ_ΑΝ
 ΜΕΧΡΙΣ_ΟΤΟΥ ΕΠΙΛΟΓΗ = 5
 ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ Μενού(επιλογή)
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:επιλογή
ΑΡΧΗ
  ΓΡΑΨΕ '1. Αντιστάσεις σε Σειρά'
  ΓΡΑΨΕ '2. Αντιστάσεις Παράλληλα'
  ΓΡΑΨΕ '3. Πυκνωτές σε Σειρά'
  ΓΡΑΨΕ '4. Αντιστάσεις σε Σειρά'
  ΓΡΑΨΕ '5. Έξοδος'
  ΓΡΑΨΕ 'Επίλεξε υπολογισμό (1-5)'
  ΔΙΑΒΑΣΕ επιλογή
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ Εισαγωγή_δεδ(στοιχείο, πλήθος)
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:πλήθος, i 
ΠΡΑΓΜΑΤΙΚΕΣ:στοιχείο[100]
ΑΡΧΗ
ΓΡΑΨΕ 'Δώσε πλήθος στοιχείων'
 ΔΙΑΒΑΣΕ πλήθος
 ΓΙΑ i από 1 μέχρι πλήθος
  ΓΡΑΨΕ 'Δώσε μέγεθος στοιχείου: ', i
  ΔΙΑΒΑΣΕ στοιχείο[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
ΔΙΑΔΙΚΑΣΙΑ Εμφάνιση_αποτ(επιλογή, τιμή)
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: τιμή
ΑΚΕΡΑΙΕΣ: επιλογή
ΑΡΧΗ
ΑΝ ΕΠΙΛΟΓΗ = 1 Ή ΕΠΙΛΟΓΗ = 2 ΤΟΤΕ
   ΓΡΑΨΕ 'ΣΥΝΟΛΙΚΗ ΑΝΤΙΣΤΑΣΗ = ', τιμή
ΤΕΛΟΣ_ΑΝ
ΑΝ ΕΠΙΛΟΓΗ = 3 Ή ΕΠΙΛΟΓΗ = 4 ΤΟΤΕ
   ΓΡΑΨΕ 'ΣΥΝΟΛΙΚΗ ΧΩΡΗΤΙΚΟΤΗΤΑ= ', τιμή
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΣΥΝΑΡΤΗΣΗ Ολ_Μέγεθος(Αντίστροφοι, στοιχείο, πλήθος): ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: πλήθος, i
ΠΡΑΓΜΑΤΙΚΕΣ: στοιχείο[100], Sum
ΛΟΓΙΚΕΣ: Αντίστροφοι
ΑΡΧΗ
Sum<--0
ΑΝ Αντίστροφοι = ΨΕΥΔΗΣ ΤΟΤΕ 
   ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ πλήθος
       Sum <-- Sum + στοιχείο[i]
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΛΛΙΩΣ
   ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ πλήθος
       Sum <-- Sum + 1 / στοιχείο[i]
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΑΝ

Ολ_Μέγεθος <-- Sum
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

 

Share This