Επιλογή Σελίδας

Θέμα Γ, 2008, Μαΐου-Ιουνίου, Ημερήσια

Μία εταιρεία ενοικίασης αυτοκινήτων έχει νοικιάσει 30 αυτοκίνητα τα οποία κατηγοριοποιούνται σε οικολογικά και συμβατικά. Η πολιτική χρέωσης για την ενοικίαση ανά κατηγορία και ανά ημέρα δίνεται στον παρακάτω πίνακα.

ΗΜΕΡΕΣ ΟΙΚΟΛΟΓΙΚΑ ΣΥΜΒΑΤΙΚΑ
1-7 30€ ανά ημέρα 40€ ανά ημέρα
8-16 20€ ανά ημέρα 30€ ανά ημέρα
από 17 και άνω 10€ ανά ημέρα 20€ ανά ημέρα
  1. Να αναπτύξετε πρόγραμμα το οποίο:

α.   Περιλαμβάνει τμήμα δηλώσεων μεταβλητών.

Μονάδες 2

β. Για κάθε αυτοκίνητο το οποίο έχει ενοικιαστεί:

  1. Διαβάζει την κατηγορία του («ΟΙΚΟΛΟΓΙΚΑ» ή «ΣΥΜΒΑΤΙΚΑ») και τις ημέρες ενοικίασης.

Μονάδες 2

  1. Καλεί υποπρόγραμμα με είσοδο την κατηγορία του αυτοκινήτου και τις ημέρες ενοικίασης και υπολογίζει με βάση τον παραπάνω πίνακα τη χρέωση.

Μονάδες 2

iii.   Εμφανίζει το μήνυμα “χρέωση” και τη χρέωση που υπολογίσατε.

Μονάδες 2

γ.    Υπολογίζει και εμφανίζει το πλήθος των οικολογικών και των συμβατικών αυτοκινήτων.

Μονάδες 4

  1. Να κατασκευάσετε το κατάλληλο υποπρόγραμμα του ερωτήματος 1.β.ii .

Μονάδες 8

ΣΗΜΕΙΩΣΗ: 1)Δεν απαιτείται έλεγχος εγκυρότητας για τα δεδομένα εισόδου και

2) Ο υπολογισμός της χρέωσης δεν πρέπει να γίνει κλιμακωτά.

ΛΥΣΗ

(περισσότερα…)

Θέμα Δ, 2008, Μαΐου-Ιουνίου, Ημερήσια

Στο ευρωπαϊκό πρωτάθλημα ποδοσφαίρου συμμετέχουν 16 ομάδες. Κάθε ομάδα συμμετέχει σε 30 αγώνες. Να γράψετε αλγόριθμο ο οποίος:

α. Διαβάζει σε μονοδιάστατο πίνακα ΟΝ[16] τα ονόματα των ομάδων.

Μονάδες 2

β. Διαβάζει σε δισδιάστατο πίνακα ΑΠ[16,30] τα αποτελέσματα σε κάθε αγώνα ως εξής:

Τον χαρακτήρα «Ν» για ΝΙΚΗ

Τον χαρακτήρα «Ι» για ΙΣΟΠΑΛΙΑ

Τον χαρακτήρα «Η» για ΗΤΤΑ

και κάνει τον απαραίτητο έλεγχο εγκυρότητας των δεδομένων.

Μονάδες 4

γ. Για κάθε ομάδα υπολογίζει και καταχωρεί σε δισδιάστατο πίνακα ΠΛ[16,3] το πλήθος των νικών στην πρώτη   στήλη,   το   πλήθος  των   ισοπαλιών   στη   δεύτερη

στήλη, και το πλήθος των ηττών στην τρίτη στήλη του πίνακα. Ο πίνακας αυτός πρέπει προηγουμένως να έχει μηδενισθεί.

Μονάδες 6

δ. Με βάση τα στοιχεία του πίνακα ΠΛ[16,3] υπολογίζει και καταχωρεί σε νέο πίνακα ΒΑΘ[16] τη συνολική βαθμολογία κάθε ομάδας, δεδομένου ότι για κάθε νίκη η ομάδα παίρνει τρεις βαθμούς, για κάθε ισοπαλία έναν βαθμό και για κάθε ήττα κανέναν βαθμό.

Μονάδες 3

ε.    Εμφανίζει τα ονόματα και τη βαθμολογία των ομάδων ταξινομημένα σε φθίνουσα σειρά με βάση τη βαθμολογία.

Μονάδες 5

Τα θέματα σε pdf, 2008, Μαΐου-Ιουνίου, Ημερήσια

 ΛΥΣΗ

(περισσότερα…)

Θέμα B, 2008, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω πρόγραμμα σε γλώσσα:

ΠΡΟΓΡΑΜΜΑ Α
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: x, n, m, pow, z
ΑΡΧΗ
ΔΙΑΒΑΣΕ x,n
m <- n
pow <- 1
z <- x
ΟΣΟ m > 0 ΕΠΑΝΑΛΑΒΕ
         ΟΣΟ ( m MOD 2) = 0 ΕΠΑΝΑΛΑΒΕ
m <- m DIV 2
z <- z * z
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
m <- m-1
         ΓΡΑΨΕ pow
pow <- pow*z
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ pow
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Α

α.   Να κατασκευάσετε το ισοδύναμο διάγραμμα ροής του προγράμματος Α.

Μονάδες 8

β.    Να γράψετε στο τετράδιό σας τις τιμές της μεταβλητής pow που θα εμφανιστούν κατά την εκτέλεση του προγράμματος Α, αν ως τιμές εισόδου δοθούν οι αριθμοί: x = 2, n = 3.

Μονάδες 12

Τα θέματα σε pdf, 2008, Μαΐου-Ιουνίου, Ημερήσια

Ερώτημα 4, Θέμα A, 2008, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα κειμένου:

Οι λόγοι που αναθέτουμε την επίλυση ενός προβλήματος σε υπολογιστή σχετίζονται με:

  • την…………. 1………… των υπολογισμών.
  • την…………. 2………… των διαδικασιών.
  • την ταχύτητα εκτέλεσης των………………….. 3……………
  • το μεγάλο πλήθος των……………….. 4……………

Δίνονται οι παρακάτω λέξεις:
α. πολυπλοκότητα
β. δεδομένων
γ. ζητουμένων
δ. αληθοφάνεια
ε. πράξεων
στ. επαναληπτικότητα
Να γράψετε στο τετράδιό σας τους αριθμούς 1,2,3,4, που βρίσκονται στα κενά διαστήματα και δίπλα να γράψετε το γράμμα α, β, γ, δ, ε, στ, που αντιστοιχεί στη σωστή λέξη. Δύο λέξεις δεν χρησιμοποιούνται.

Μονάδες 8

Τα θέματα σε pdf, 2008, Μαΐου-Ιουνίου, Ημερήσια

Ερώτημα 3.2, Θέμα A, 2008, Μαΐου-Ιουνίου, Ημερήσια

Στο παρακάτω τμήμα προγράμματος να μετατρέψετε την αλγοριθμική δομή της πολλαπλής επιλογής σε ισοδύναμη αλγοριθμική δομή ΕΠΙΛΕΞΕ.

ΓΡΑΨΕ “Δώσε αριθμό από 0 έως και 5”
ΔΙΑΒΑΣΕ Χ
ΑΝ Χ=0 ΤΟΤΕ
ΓΡΑΨΕ “μηδέν”
ΑΛΛΙΩΣΑΝ (Χ=1) ή (Χ=3) ή (Χ=5) ΤΟΤΕ
ΓΡΑΨΕ “περιττός αριθμός”
ΑΛΛΙΩΣ
ΑΝ (Χ=2) ή (Χ=4) ΤΟΤΕ
ΓΡΑΨΕ “άρτιος αριθμός”
ΑΛΛΙΩΣ
ΓΡΑΨΕ “έδωσες λάθος αριθμό”
ΤΕΛΟΣ_ΑΝ

Μονάδες 6

Τα θέματα σε pdf, 2008, Μαΐου-Ιουνίου, Ημερήσια

Ερώτημα 3.1, Θέμα A, 2008, Μαΐου-Ιουνίου, Ημερήσια

Να γράψετε στο τετράδιό σας τους αριθμούς 1,2,3,4, από τη Στήλη Α και δίπλα το γράμμα α,β, της Στήλης Β που δίνει το σωστό χαρακτηρισμό.

Στήλη Α Στήλη Β
1.  Εύστοχη χρήση ορολογίας α. Σαφήνεια διατύπωσης προβλήματος
2.   Τήρηση λεξικολογικών και συντακτικών κανόνων β. Καθορισμός απαιτήσεων
3.   Επακριβής προσδιορισμός δεδομένων
4.  Λεπτομερειακή καταγραφή ζητουμένων

Μονάδες 4

Ερώτημα 2, Θέμα A, 2008, Μαΐου-Ιουνίου, Ημερήσια

  1. Να αναφέρετε τις τυποποιημένες κατηγορίες τεχνικών-μεθόδων σχεδίασης αλγορίθμων.

Μονάδες 6

  1. Ποια η διαφορά μεταξύ διερμηνευτή και μεταγλωττιστή;

Μονάδες 6

Τα θέματα σε pdf, 2008, Μαΐου-Ιουνίου, Ημερήσια