Επιλογή Σελίδας

Θέμα Β, 2006, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω πρόγραμμα και υποπρογράμματα:

ΠΡΟΓΡΑΜΜΑ Κλήση_Υποπρογραμμάτων

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: α, β, χ

ΑΡΧΗ

α <-1

β <- 2

ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

ΑΝ α<= 4 ΤΟΤΕ

ΚΑΛΕΣΕ Διαδ1(α, β,χ)

ΑΛΛΙΩΣ

χ <- Συν1(α, β)

ΤΕΛΟΣ_ΑΝ

ΓΡΑΨΕ α, β, χ

ΜΕΧΡΙΣ_ΟΤΟΥ χ>11

ΓΡΑΨΕ χ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ Διαδ1 (λ, κ, μ)

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: κ, λ, μ

ΑΡΧΗ

κ<-κ+1

λ<-λ+3

μ<-κ+λ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΣΥΝΑΡΤΗΣΗ Συν1(ε, ζ): ΑΚΕΡΑΙΑ

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: ε, ζ

ΑΡΧΗ

ζ<-ζ+2

ε<-ε*2

Συν1<-ε+ζ

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανιστούν κατά την εκτέλεση του προγράμματος.

Μονάδες 20

Τα θέματα σε pdf, 2006, Επαναληπτικές, Ημερήσια

Θέμα Γ, 2006, Επαναληπτικές, Ημερήσια

Σε ένα πάρκινγκ η χρέωση γίνεται κλιμακωτά, όπως φαίνεται στον παρακάτω πίνακα:

ΔΙΑΡΚΕΙΑ ΣΤΑΘΜΕΥΣΗΣ ΚΟΣΤΟΣ ΑΝΑ ΩΡΑ
Μέχρι και 3 ώρες 2
Πάνω από 3 έως και 5 ώρες 1,5
Πάνω από 5 ώρες 1,3

Ι.   Να κατασκευάσετε πρόγραμμα το οποίο:

α) περιλαμβάνει τμήμα δηλώσεων.

Μονάδες 2

 

β)   για κάθε αυτοκίνητο που στάθμευσε στο πάρκινγκ:

i. διαβάζει τον αριθμό κυκλοφορίας μέχρι να δοθεί το 0. Να θεωρήσετε ότι ο αριθμός κυκλοφορίας μπορεί να περιέχει τόσο γράμματα όσο και αριθμούς.

Μονάδες 2

ii. διαβάζει τη διάρκεια στάθμευσης σε ώρες και τη δέχεται μόνο εφ’ όσον είναι μεγαλύτερη από το 0.

Μονάδες 3

iii. καλεί υποπρόγραμμα για τον υπολογισμό του ποσού που πρέπει να πληρώσει ο κάτοχός του.

Μονάδες 2

iv. εμφανίζει τον αριθμό κυκλοφορίας και το ποσό που αναλογεί.

Μονάδες 2

γ)   εμφανίζει το πλήθος των αυτοκινήτων που έμειναν στο πάρκινγκ μέχρι και δύο ώρες.

Μονάδες 4

ΙΙ.  Να κατασκευάσετε το υποπρόγραμμα που καλείται στο ερώτημα β) iii.

Μονάδες 5

ΛΥΣΗ

(περισσότερα…)

Ερώτημα 4, Θέμα Α, 2006, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου.

Για x από 1 μέχρι Κ

Εμφάνισε x

Τέλος_επανάληψης

Να μετατραπεί σε ισοδύναμο τμήμα αλγορίθμου χρησιμοποιώντας την εντολή Αρχή_Επανάληψης … Μέχρις_ Ότου

Μονάδες 10

Τα θέματα σε pdf, 2006, Επαναληπτικές, Ημερήσια

Ερώτημα 2, Θέμα Α, 2006, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου

ΑΝ ποσότητα <= 50 TOTE

Κόστος <- Ποσότητα * 580

ΑΛΛΙΩΣ_ΑΝ Ποσότητα > 50 ΚΑΙ Ποσότητα <= 100 ΤΟΤΕ

Κόστος <- Ποσότητα * 520

 

ΑΛΛΙΩΣ_ΑΝ Ποσότητα > 100 ΚΑΙ Ποσότητα <= 200 ΤΟΤΕ

Κόστος <- Ποσότητα * 470

ΑΛΛΙΩΣ

Κόστος <- Ποσότητα * 440

ΤΕΛΟΣ_ΑΝ

Στο παραπάνω τμήμα αλγορίθμου, για το οποίο θεωρούμε ότι η ποσότητα είναι θετικός αριθμός, περιλαμβάνονται περιττοί έλεγχοι.

Να το ξαναγράψετε παραλείποντας τους περιττούς ελέγχους.

Μονάδες 4

Τα θέματα σε pdf, 2006, Επαναληπτικές, Ημερήσια

Ερώτημα 1, Θέμα Α, 2006, Επαναληπτικές, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη Λάθος, αν είναι λανθασμένη.

  1. Η ταξινόμηση φυσαλίδας είναι ο πιο απλός και ταυτόχρονα ο πιο γρήγορος αλγόριθμος ταξινόμησης.
  2. Ενώ η τιμή μίας μεταβλητής μπορεί να αλλάζει κατά την εκτέλεση του προγράμματος, αυτό που μένει υποχρεωτικά αναλλοίωτο είναι ο τύπος της.
  3. Το πρόγραμμα που παράγεται από το μεταγλωττιστή λέγεται εκτελέσιμο.
  4. Σε μία εντολή εκχώρησης του αποτελέσματος μίας έκφρασης σε μία μεταβλητή, η μεταβλητή και η έκφραση πρέπει να είναι του ίδιου τύπου.
  5. Όταν ένας βρόχος είναι εμφωλευμένος σε άλλο, ο βρόχος που ξεκινάει τελευταίος πρέπει να ολοκληρώνεται πρώτος.

Μονάδες 10

Τα θέματα σε pdf, 2006, Επαναληπτικές, Ημερήσια