Επιλογή Σελίδας

Θέμα Β, Ερώτημα 2, 2016, Ημερήσια, Νέο

Κατά την είσοδό τους σε μια τράπεζα οι πελάτες παίρνουν διαδοχικούς αριθμούς προτεραιότητας 1, 2, 3… που καθορίζουν τη σειρά τους στην ουρά του μοναδικού ταμείου.

Κάθε 2 λεπτά της ώρας προσέρχεται ένας νέος πελάτης και προστίθεται στην ουρά. Ο ταμίας εξυπηρετεί κάθε φορά τον πρώτο πελάτη στην ουρά και η εξυπηρέτησή του διαρκεί 3 λεπτά ακριβώς. Μετά την εξυπηρέτησή του ο πελάτης αποχωρεί από την ουρά.

Κατά την αρχή της διαδικασίας (χρόνος 0) στην ουρά υπάρχει μόνο ο πελάτης με αριθμό προτεραιότητας 1.

Να γράψετε διαδοχικά, σε ξεχωριστές γραμμές, με τη σωστή σειρά, τους αριθμούς προτεραιότητας των πελατών που βρίσκονται στην ουρά του ταμείου αμέσως μετά το 1ο , 2ο , 3ο , 4ο , 5ο και 6ο λεπτό.

Μονάδες 10

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

ΛΥΣΗ

(περισσότερα…)

Θέμα Β, Ερώτημα 2, 2011, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται τo παρακάτω πρόγραμμα και ένα υποπρόγραμμα:

Πρόγραμμα ΘέμαΒ Διαδικασία Διαδ(w,z)
Μεταβλητές Μεταβλητές
Ακέραιες: z,w Ακέραιες: z,w
Αρχή Αρχή
z <- 1 w <- w+z
w <- 3 z <- z+2
Όσο z<=35 επανάλαβε Γράψε z
Κάλεσε Διαδ(z,w) Τέλος_Διαδικασίας
Γράψε z
Τέλος_επανάληψης
Tέλος_Προγράμματος

Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανιστούν κατά την εκτέλεση του προγράμματος με τη σειρά που θα εμφανιστούν.

Μονάδες 10

 Τα θέματα σε pdf, 2011, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, Ερώτημα 1, 2016, Ημερήσια, Νέο

Ο αριθμός π εκφράζει το πηλίκο της περιμέτρου ενός κύκλου προς τη διάμετρό του. Η τιμή του μπορεί να υπολογιστεί, κατά προσέγγιση, από την παρακάτω παράσταση:
er1the-v-aepp-2016-imerisia-neo
Ο υπολογισμός της τιμής της παράστασης, για 100 όρους του αθροίσματος, γίνεται από το παρακάτω τμήμα αλγορίθμου που περιλαμβάνει 5 κενά.

παρονομαστής < (1)   
 Σ< 0
 πρόσημο < 1
 Για i από 1 μέχρι 100
       όρος < 1/παρονομαστής
       όρος<  (2)  * πρόσημο
       (3)   < Σ + όρος
       πρόσημο < πρόσημο * ( (4) )
       παρονομαστής < παρονομαστής + 2 
 Τέλος_Επανάληψης
 π <- (5) * Σ

Να γράψετε στο τετράδιό σας τους αριθμούς 1 έως 5, που αντιστοιχούν στα κενά του αλγορίθμου, και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε ο αλγόριθμος να υπολογίζει την τιμή του π όπως περιγράφηκε.
Μονάδες 10

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

ΛΥΣΗ (περισσότερα…)

Θέμα Β, Ερώτημα 1, 2014, Ημερήσια

Για την ταξινόμηση, σε φθίνουσα σειρά, των στοιχείων ενός μονοδιάστατου πίνακα αριθμών Π[30] μπορεί να ακολουθηθεί η παρακάτω διαδικασία: Αρχικά, ο πίνακας σαρώνεται από την αρχή μέχρι το τέλος του, προκειμένου να βρεθεί το μεγαλύτερο στοιχείο του. Αυτό το στοιχείο τοποθετείται στην αρχή του πίνακα, ανταλλάσσοντας θέσεις με το στοιχείο της πρώτης θέσης του πίνακα. Η σάρωση του πίνακα επαναλαμβάνεται, ξεκινώντας τώρα από το δεύτερο στοιχείο του πίνακα. Το μεγαλύτερο από τα στοιχεία που απέμειναν ανταλλάσσει θέσεις με το στοιχείο της δεύτερης θέσης του πίνακα. Η σάρωση επαναλαμβάνεται, ξεκινώντας από το τρίτο στοιχείο του πίνακα, μετά από το τέταρτο στοιχείο του πίνακα κ.ο.κ.

Το παρακάτω ημιτελές τμήμα αλγορίθμου κωδικοποιεί την παραπάνω διαδικασία:

Για k από 1 μέχρι 29

θ <- .(1.).

Για i από k μέχρι 30

Αν Π[i] … Π[θ] τότε
θ<- .(3..)

Τέλος_αν

Τέλοςεπανάληψης
αντιμετάθεσε .(4.). , .(5..)
Τέλος
επανάληψης
Να γράψετε στο τετράδιό σας τους αριθμούς (1) έως (5), που αντιστοιχούν στα κενά του αλγορίθμου και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε να γίνεται σωστά η ταξινόμηση.
Μονάδες 10

Τα θέματα σε pdf, 2014, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, Ερώτημα 1, 2012, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου:

Κ<- 1
Χ<- -1
i<- 0
Όσο Χ<7 επανάλαβε
i<- i + 1
Κ<-Κ∗Χ
Εμφάνισε Κ, Χ
Αν i mod 2=0  τότε
X<- X+1
Αλλιώς
X<- X+2
ΤέλοςΑν
Τέλος
επανάληψης

Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανίσει το τμήμα αλγορίθμου κατά την εκτέλεσή του με τη σειρά που θα εμφανιστούν.

Μονάδες 10

Τα θέματα σε pdf, 2012, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, Ερώτημα 1, 2011, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου σε μορφή διαγράμματος ροής:

aepp_2011_imerisia

Να κατασκευάσετε ισοδύναμο τμήμα αλγορίθμου σε ψευδογλώσσα.

Μονάδες 10

Τα θέματα σε pdf, 2011, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, 2010, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι γραμμές:

  1. j<-1
  2. i<-2
  3. Αρχή_επανάληψης
  4. i<-i + j
  5. j<-i – j
  6. Εμφάνισε i
  7. Μέχρις_ότου i ≥ 5

Επίσης δίνεται το ακόλουθο υπόδειγμα πίνακα τιμών:

αριθμός γραμμής συνθήκη έξοδος i j

Στη στήλη με τίτλο «αριθμός γραμμής» καταγράφεται ο αριθμός γραμμής της εντολής που εκτελείται.
Στη στήλη με τίτλο «συνθήκη» καταγράφεται η λογική τιμή ΑΛΗΘΗΣ ή ΨΕΥΔΗΣ,   εφόσον η εντολή που εκτελείται περιλαμβάνει συνθήκη.
Στη στήλη με τίτλο «έξοδος» καταγράφεται η τιμή εξόδου, εφόσον η εντολή που εκτελείται είναι εντολή εξόδου.
Στη συνέχεια του πίνακα υπάρχει μια στήλη για κάθε μεταβλητή του αλγόριθμου.
Να  μεταφέρετε  τον  πίνακα  στο  τετράδιό σας και να τον συμπληρώσετε     εκτελώντας τις εντολές του τμήματος αλγορίθμου ως εξής:
Για κάθε εντολή που εκτελείται να γράψετε σε νέα γραμμή του πίνακα τον αριθμό της γραμμής της και το αποτέλεσμά της στην αντίστοιχη στήλη.
Σημείωση: Η εντολή της γραμμής 3 δεν χρειάζεται να αποτυπωθεί στον πίνακα.

Μονάδες 20

ΛΥΣΗ (περισσότερα…)

Ερώτημα 3, Θέμα B, 2009, Μαΐου-Ιουνίου, Ημερήσια

Να γράψετε τμήμα αλγορίθμου, που θα έχει το ίδιο αποτέλεσμα με το παρακάτω τμήμα:
δ<-α mod 10
Όσο δ>0 επανάλαβε
        δ<-δ-1
γ<-γ+β
Τέλος_επανάληψης
χρησιμοποιώντας αντί της εντολής Όσο την εντολή Για. Στο νέο τμήμα αλγορίθμου να χρησιμοποιήσετε μόνο τις μεταβλητές α,β,γ,δ, που χρησιμοποιεί το αρχικό τμήμα.

Μονάδες 5

Τα θέματα σε pdf, 2009, Μαΐου-Ιουνίου, Ημερήσια

Θέμα B, Eρώτημα 2, 2015, Ημερήσια

Το παρακάτω ημιτελές τμήμα αλγορίθμου εισάγει αριθμητικές τιμές σε πίνακα 100 θέσεων ώστε:
α. οι τιμές να είναι διαφορετικές μεταξύ τους,
β. οι τιμές να εισάγονται σε αύξουσα σειρά.
Εάν κάποια εισαγόμενη τιμή δεν ικανοποιεί τις συνθήκες (α) και (β), επανεισάγεται.

Διάβασε Π[ ...(1)...] 
 Για i από ...(2)... μέχρι ...(3)...
     Αρχή_επανάληψης 
         Διάβασε Π[i]
     Μέχρις_ότου Π[ ...(4)...] ...(5)... Π[ ...(6)...]
 Τέλος_επανάληψης

Να γράψετε στο τετράδιό σας τους αριθμούς (1) έως (6), που αντιστοιχούν στα κενά του αλγορίθμου και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε το τμήμα αλγορίθμου να επιτελεί τη λειτουργία που περιγράφεται.

Μονάδες 6

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

(1) 1 , (2) 2, (3) 100 , (4) i , (5) > , (6) i-1

Θέμα B, Eρώτημα 1, 2015, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, όπου η μεταβλητή x έχει θετική ακέραια τιμή:

Αν x > 1 τότε 
   y <-- x
   Αρχή_επανάληψης 
      y <-- y-2 
      Εμφάνισε y 
   Μέχρις_ότου y ≤ 0 
Τέλος_αν

α. Να σχεδιάσετε στο τετράδιό σας το ισοδύναμο διάγραμμα ροής. (μονάδες 6)
β. Να ξαναγράψετε το τμήμα αυτό στο τετράδιό σας, χρησιμοποιώντας την εντολή Για αντί της εντολής Μέχρις_ότου. (μονάδες 8)
Μονάδες 14

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

Β1α.

Β1β.

Αν x>1 τότε 
   Για y από x-2 μέχρι -1 με βήμα –2 
       Εμφάνισε y
   Τέλος_επανάληψης
Τέλος_αν

β' τρόπος
Αν x>1 τότε 
  Για y από x µέχρι 1 µε_βήµα -2 
      Εµφάνισε y-2 
  Τέλος_επανάληψης 
Τέλος_αν

 

 

Θέμα B, 2008, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω πρόγραμμα σε γλώσσα:

ΠΡΟΓΡΑΜΜΑ Α
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: x, n, m, pow, z
ΑΡΧΗ
ΔΙΑΒΑΣΕ x,n
m <- n
pow <- 1
z <- x
ΟΣΟ m > 0 ΕΠΑΝΑΛΑΒΕ
         ΟΣΟ ( m MOD 2) = 0 ΕΠΑΝΑΛΑΒΕ
m <- m DIV 2
z <- z * z
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
m <- m-1
         ΓΡΑΨΕ pow
pow <- pow*z
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ pow
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Α

α.   Να κατασκευάσετε το ισοδύναμο διάγραμμα ροής του προγράμματος Α.

Μονάδες 8

β.    Να γράψετε στο τετράδιό σας τις τιμές της μεταβλητής pow που θα εμφανιστούν κατά την εκτέλεση του προγράμματος Α, αν ως τιμές εισόδου δοθούν οι αριθμοί: x = 2, n = 3.

Μονάδες 12

Τα θέματα σε pdf, 2008, Μαΐου-Ιουνίου, Ημερήσια

Ερώτημα 2, Θέμα B, 2009, Μαΐου-Ιουνίου, Ημερήσια

Να γράψετε τμήμα αλγορίθμου, που θα έχει το ίδιο αποτέλεσμα με την εντολή:

Αν α>β τότε αντιμετάθεσε α, β χωρίς να χρησιμοποιήσετε την εντολή αντιμετάθεσε.

Μονάδες 5

Τα θέματα σε pdf, 2009, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, Ερώτημα 2, 2016, Ημερήσια, Παλαιό

Δίνεται ο πίνακας αριθμών Χ[50], ταξινομημένος κατά φθίνουσα σειρά, και ο πίνακας Υ[100], ταξινομημένος κατά αύξουσα σειρά. Να θεωρήσετε ότι οι τιμές κάθε πίνακα είναι διαφορετικές μεταξύ τους και ότι οι δύο πίνακες δεν έχουν κοινές τιμές.

Το παρακάτω ημιτελές τμήμα αλγορίθμου δημιουργεί ένα νέο πίνακα Ζ[10], ταξινομημένο σε φθίνουσα σειρά, με τις δέκα μεγαλύτερες τιμές από τις εκατόν πενήντα (150) τιμές των δύο πινάκων.

i <--(1)
j <-- (2)
Για k από 1 μέχρι 10
      Αν Χ[ i ] (3) Υ[ j ] τότε 
            Ζ[ k ] <-- Χ[ i ] 
            i <-- i (4) 1 
     Αλλιώς
            Ζ[ k ] <-- Υ[ j ] 
             j <-- j (5) 1 
    Τέλος_αν
Τέλος_επανάληψης

Να γράψετε στο τετράδιό σας τους αριθμούς (1) έως (5), που αντιστοιχούν στα κενά του αλγορίθμου, και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε το τμήμα αλγορίθμου να επιτελεί τη λειτουργία που περιγράφεται.

Μονάδες 10

ΛΥΣΗ (περισσότερα…)

Θέμα Β, Ερώτημα 1, 2016, Ημερήσια, Παλαιό

Δίνεται το παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι εντολές εκχώρησης και εξόδου.
01 ΔΙΑΒΑΣΕ X
02 ΠΛ<– 0
03 ΑΡ <– 1
04 ΔΕ <– 12
05 Β <– ΨΕΥΔΗΣ
ΟΣΟ Β = ΨΕΥΔΗΣ ΚΑΙ ΑΡ <= ΔΕ ΕΠΑΝΑΛΑΒΕ
06 Μ <– (ΑΡ + ΔΕ) DIV 2
AN A[M] = X TOTE
07 B <– ΑΛΗΘΗΣ
ΑΛΛΙΩΣ_ΑΝ Α[Μ] < Χ ΤΟΤΕ
08 ΑΡ <– Μ + 1
ΑΛΛΙΩΣ
09 ΔΕ <– Μ – 1
ΤΕΛΟΣ  ΑΝ
10 ΠΛ <– ΠΛ + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ Β = ΑΛΗΘΗΣ ΤΟΤΕ
11 ΕΜΦΑΝΙΣΕ Μ
ΑΛΛΙΩΣ
12 ΕΜΦΑΝΙΣΕ “ΔΕΝ ΒΡΕΘΗΚΕ”, ΠΛ
ΤΕΛΟΣ_ΑΝ

Για την παρακολούθηση της εκτέλεσης του τμήματος αλγορίθμου με τιμή εισόδου Χ = 35 και με δεδομένο τον πίνακα

1 2 3 4 5 6 7 8 9 10 11 12
Α 3 10 18 20 26 32 35 48 55 60 75 90
δίνεται το παρακάτω υπόδειγμα πίνακα τιμών,συμπληρωμένο ως εξής:
  • Στη στήλη με τίτλο «Αρ. Γρ.» καταγράφεται ο αριθμός γραμμής της εντολής που εκτελείται.
  • Στη στήλη με τίτλο «Έξοδος» καταγράφεται η τιμή εξόδουεφόσον η εντολή που εκτελείται είναι εντολή εξόδου.
  • Οι  υπόλοιπες στήλες του πίνακα τμήματος του αλγορίθμου αντιστοιχούν στις μεταβλητές του τμήματος του αλγορίθμου.
Αρ.Γρ. Χ ΠΛ ΑΡ ΔΕ Β Μ Έξοδος
01 35
02 0
03 1
04 12
05 ΨΕΥΔΗΣ
……

Να μεταφέρετε τον πίνακα τιμών στο τετράδιό σας και να προσθέσετε τις γραμμές που χρειάζονται, συνεχίζοντας την εκτέλεση του τμήματος αλγορίθμου ως εξής: για κάθε αριθμημένη εντολή που εκτελείται, να γράψετε τον αριθμό της γραμμής της εντολής σε νέα γραμμή του πίνακα και το αποτέλεσμα της εκτέλεσης της εντολής στην αντίστοιχη στήλη.

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

Μονάδες 10

ΛΥΣΗ (περισσότερα…)

Θέμα Β, Ερώτημα 2, 2013, Μαΐου-Ιουνίου, Ημερήσια

Έστω μονοδιάστατος πίνακας Π[100], του οποίου τα στοιχεία περιέχουν τις λογικές τιμές ΑΛΗΘΗΣ και ΨΕΥΔΗΣ. Να γραφεί τμήμα αλγορίθμου που χωρίς τη χρήση «αλγορίθμων ταξινόμησης» να τοποθετεί στις πρώτες θέσεις του πίνακα την τιμή ΑΛΗΘΗΣ και στις τελευταίες την τιμή ΨΕΥΔΗΣ.

Μονάδες 10

2012, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, Ερώτημα 2,2012, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται τo παρακάτω τμήμα αλγορίθμου σε μορφή διαγράμματος ροής:

er2th2-aepp_2012_imerisia

Να κατασκευάσετε ισοδύναμο τμήμα αλγορίθμου σε ψευδογλώσσα.

Μονάδες 10

Τα θέματα σε pdf, 2012, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, Ερώτημα 1, 2013, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος:

Αλγόριθμος Παράγοντες
Διάβασε
α k<- 2
Όσο α>1 επανάλαβε
Αν
α mod k = 0 τότε
Εμφάνισε
k
α<-α div k
Αλλιώς

k<-k+1
Τέλος_αν
Τέλος
_επανάληψης
Τέλος
Παράγοντες

Να σχεδιάσετε στο τετράδιό σας το αντίστοιχο διάγραμμα ροής.

Μονάδες 10