Επιλογή Σελίδας

Θέμα Β, 2015, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου ΤΑ_1:

Αν x>10 τότε
   Αν x<30 τότε 
      Κ <-- 3*x
   Αλλιώς
      Κ <-- 5*x
   Τέλος_αν
Κ<-- Κ/2
Αλλιώς
   Κ <-- x
   Αν x<5 τότε 
      Κ <-- 2*Κ
   Τέλος_αν 
 Τέλος_αν

Β1. Να σχεδιάσετε στο τετράδιό σας το αντίστοιχο διάγραμμα ροής.
Μονάδες 8

Β2. Χρησιμοποιώντας μόνο μία εντολή πολλαπλής επιλογής και μόνο απλές συνθήκες, να γράψετε στο τετράδιό σας τμήμα αλγορίθμου το οποίο θα παράγει το ίδιο αποτέλεσμα με το ΤΑ_1.
Μονάδες 12

Τα θέματα σε pdf, 2015, Επαναληπτικές, Ημερήσια

ΛΥΣΗ

(περισσότερα…)

Θέμα Β, 2014, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω πρόγραμμα:

01  Πρόγραμμα Κλήση_Υποπρογραμμάτων
02  Μεταβλητές
03  Ακέραιες: α, β, γ, π
04  Αρχή
05 Διάβασε α
06 Β<-3
07 γ<-Φ(α,β)
08 α<-α+γ
09 Αν α>20 τότε
10                    γ<-Φ(β,α)
11        Αλλιώς
12                    γ<-Φ(γ,α)
13 Τέλος_αν
14 Π<-0
15 Όσο γ mod 10=0 επανάλαβε
16 π<-π+1
17 γ<-γ div 10
18 Τέλος_επανάληψης
19 Γράψε γ,π
20  Τέλος_προγράμματος

21 Συνάρτηση Φ(μ, λ): Ακέραια
22 Μεταβλητές
23        Ακέραιες: κ, λ, μ
24  Αρχή
25 κ<- λ+μ
26 Φ<-κ^μ
27  Τέλος_συνάρτησης

Για την παρακολούθηση της εκτέλεσης του προγράμματος με τιμή εισόδου α=2, δίνεται το παρακάτω υπόδειγμα πίνακα τιμών, μερικώς συμπληρωμένο ως εξής:

  • Στη στήλη με τίτλο «αριθμός γραμμής» καταγράφεται ο αριθμός γραμμής της εντολής που εκτελείται.
  • Στη στήλη με τίτλο «έξοδος» καταγράφεται η τιμή εξόδου, εφόσον η εντολή που εκτελείται είναι εντολή εξόδου.
  • Στη στήλη με τίτλο «συνθήκη» καταγράφεται η λογική τιμή ΑΛΗΘΗΣ ή ΨΕΥΔΗΣ, εφόσον η εντολή που εκτελείται περιλαμβάνει συνθήκη.
  • Οι υπόλοιπες στήλες του πίνακα αντιστοιχούν στις μεταβλητές του κυρίου προγράμματος.
  • Σε όποια σημεία καλείται υποπρόγραμμα και κατά τη διάρκεια της εκτέλεσής του, ο πίνακας επεκτείνεται με μια στήλη για κάθε μεταβλητή του υποπρογράμματος.
Αριθμός γραμμής Έξοδος Συνθήκη α β γ π
05 2
06 3
07 Φ κ λ μ
3 2
25 5
26 25
07 25
……. …….. …….. ….

Να μεταφέρετε τον πίνακα στο τετράδιό σας και να προσθέσετε τις γραμμές που χρειάζονται, συνεχίζοντας την εκτέλεση του προγράμματος, ως εξής: Για κάθε εντολή που εκτελείται, να γράψετε τον αριθμό της γραμμής της εντολής σε νέα γραμμή του πίνακα και το αποτέλεσμα της εκτέλεσης της εντολής στην αντίστοιχη στήλη.

Μονάδες 20

Τα θέματα σε pdf, 2014, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, 2013, Επαναληπτικές, Ημερήσια

Να μετατραπεί το παρακάτω διάγραμμα ροής σε ισοδύναμο αλγόριθμο με ψευδογλώσσα.

themav2013epanhmer

Μονάδες 11

Β2. Να σχεδιάσετε στο τετράδιό σας τον πίνακα Π μαζί με τις τιμές, που θα έχει μετά την εκτέλεση του παραπάνω αλγορίθμου.

Μονάδες 9

Τα θέματα σε pdf, 2013, Επαναληπτικές, Ημερήσια

Θέμα Β, 2010, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι γραμμές. Θεωρήστε ότι οι τιμές που εισάγονται είναι ακέραιες και μεγαλύτερες του μηδενός.

  1. ΔΙΑΒΑΣΕ x, y
  2. ΑΝ x < y ΤΟΤΕ
  3. z <- x
  4. ΑΛΛΙΩΣ
  5. z <- y
  6. ΤΕΛΟΣ_ΑΝ
  7. ΟΣΟ z <> 0 ΕΠΑΝΑΛΑΒΕ
  8. z <- x MOD y
  9. x <- y
  10. y <- z
  11. ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Β1.  Να αναπαραστήσετε τμήμα αλγορίθμου με διάγραμμα ροής το παραπάνω

Μονάδες 6

Δίνεται το ακόλουθο υπόδειγμα πίνακα τιμών:

αριθμός γραμμής x y z
1 150 35

Στη   στήλη   με   τίτλο   «αριθμός   γραμμής»   καταγράφεται   ο αριθμός γραμμής της εντολής που εκτελείται. Στη   συνέχεια   του   πίνακα   υπάρχει   μια   στήλη   για   κάθε μεταβλητή του αλγορίθμου.

Να μεταφέρετε τον πίνακα στο τετράδιό σας και να τον συμπληρώσετε, εκτελώντας τις εντολές του τμήματος αλγορίθμου για x = 150 και y = 35 ως εξής:

Για κάθε εντολή που εκτελείται να γράψετε σε μία νέα γραμμή του πίνακα τον αριθμό της γραμμής της και το αποτέλεσμα της εκτέλεσης της εντολής.

Σημείωση:   Στον πίνακα τιμών έχει συμπληρωθεί η εκτέλεση της πρώτης εντολής του αλγορίθμου.

Μονάδες 10

Β3. Να μετατραπεί η δομή ΟΣΟ… ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ του παραπάνω αλγορίθμου σε ισοδύναμη με τη χρήση της δομής ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ… ΜΕΧΡΙΣ_ΟΤΟΥ.

Μονάδες 4

Τα θέματα σε pdf, 2010, Επαναληπτικές, Ημερήσια

Θέμα B, Ερώτημα 2, 2016, Επαναληπτικές, Νέο

Δίνεται το παρακάτω τμήμα προγράμματος, το οποίο μετατρέπει έναν ακέραιο αριθμό από το δεκαδικό σύστημα στο δυαδικό.

Π <- 1 
Ι <- 0
ΔΙΑΒΑΣΕ Α 
ΟΣΟ Π <> 0 ΕΠΑΝΑΛΑΒΕ
    Ι <- Ι + 1
    Π <- A DIV 2
    Y<- A MOD 2
    Δ[I] <- Y
    A <- Π 
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Κ ΑΠΟ Ι ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ -1
     ΓΡΑΨΕ Δ[Κ] 
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

α. Για την τιμή Α = 11 :
i) Να συμπληρώσετε τον παρακάτω πίνακα τιμών.

Π Υ Α Ι

(Μονάδες 5)

ii) Να γράψετε τον αριθμό Α και δίπλα του, διαδοχικά, τις τιμές που εμφανίζει το τμήμα του προγράμματος (οι αριθμοί αυτοί αποτελούν τη δυαδική αναπαράσταση του αριθμού Α).  (μονάδες 2)

βΝα επαναλάβετε τα ανωτέρω i) και ii) βήματα για την τιμή Α = 8. (μονάδες 5 + 2)

Μονάδες 14

 

ΛΥΣΗ  (περισσότερα…)

Θέμα B, Ερώτημα 1, 2016, Επαναληπτικές, Νέο

Δίνεται μια λίστα η οποία αποτελείται από 5 κόμβους. Το πρώτο πεδίο του κάθε κόμβου είναι ένα γράμμα και το δεύτερο πεδίο είναι η διεύθυνση του επόμενου κόμβου, όπως φαίνεται στο παρακάτω διάγραμμα, που σχηματίζει τη λέξη ΔΕΚΤΗ:
rg1thv2016imerneo-1

Η λίστα αυτή απεικονίζεται στη μνήμη με τη μορφή που φαίνεται στο παρακάτω σχήμα.

rg1thv2016imerneo-2

α. Να σχεδιάσετε στο τετράδιό σας την απεικόνιση της μνήμης μετά από τη διαγραφή του κατάλληλου κόμβου από την αρχική λίστα, ώστε να σχηματιστεί η λέξη ΔΕΤΗ. (μονάδες 2)

β. Να σχεδιάσετε στο τετράδιό σας την απεικόνιση της μνήμης μετά από την εισαγωγή, στην αρχική λίστα, του κόμβου με πρώτο πεδίο το γράμμα Α στη θέση 21, ώστε να σχηματιστεί η λέξη ΔΕΚΑΤΗ. (μονάδες 4)

Μονάδες 6

ΛΥΣΗ

Θέμα Β, 2009, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι γραμμές του:
1         Διάβασε Χ
2         Όσο X>1 επανάλαβε
3                 Aν Χ mod 2=0  τότε
4                        Χ<-Χ div 2
5                 αλλιώς
6                         Χ<-3*Χ+1
7                 Τέλος_αν
8       Τέλος_επανάληψης
Επίσης   δίνεται   το   παρακάτω   υπόδειγμα   πίνακα   (πίνακας τιμών), με συμπληρωμένη την αρχική τιμή της μεταβλητής Χ.

Αριθμός Εντολής Χ Χ>1 Χ mod 2=0
1 5

Να μεταφέρετε στο τετράδιό σας τον πίνακα και να τον συμπληρώσετε, εκτελώντας τον αλγόριθμο με αρχική τιμή Χ=5 (που ήδη φαίνεται στον πίνακα).

Α.   Για   κάθε   εντολή   που   εκτελείται   να   γράψετε   σε   νέα γραμμή του πίνακα τα εξής:

  1. Τον αριθμό της εντολής που εκτελείται (στην πρώτη στήλη).
  2. Αν η γραμμή περιέχει εντολή εκχώρησης, τη νέα τιμή της μεταβλητής στην αντίστοιχη στήλη. Αν η γραμμή περιέχει έλεγχο συνθήκης, την τιμή της συνθήκης (Αληθής, Ψευδής) στην αντίστοιχη στήλη.

Μονάδες 16

Β.   Να κάνετε τη διαγραμματική αναπαράσταση του ανωτέρω τμήματος αλγορίθμου (διάγραμμα ροής).

Μονάδες 4

Τα θέματα σε pdf, 2009, Επαναληπτικές, Ημερήσια

Θέμα Β, 2008, Επαναληπτικές, Ημερήσια

Α.   Δίνεται το παρακάτω πρόγραμμα σε «ΓΛΩΣΣΑ»

1.ΠΡΟΓΡΑΜΜΑ ΕΙΝΑΙ-ΠΡΩΤΟΣ

2.ΜΕΤΑΒΛΗΤΕΣ

3.ΑΚΕΡΑΙΕΣ: Χ, i

4.ΧΑΡΑΚΤΗΡΕΣ: ΜΗΝΥΜΑ

5. ΑΡΧΗ

6.ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

7.ΔΙΑΒΑΣΕ Χ

8. ΜΕΧΡΙΣ_ΟΤΟΥ Χ>0

9.C<- 0

10.ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Χ ΕΠΑΝΑΛΑΒΕ

11. AN (Χ MOD i) = 0 TOTE

12. C<- C + 1  

13. ΤΕΛΟΣ_ΑΝ

14.ΤΕΛΟΣ_ΓΙΑ

15.ΑΝ C=2 TOTE

16. MHNYMA<- ‘ EINAI ΠΡΩΤΟΣ’

17.ΑΛΛΙΩΣ

18.ΜΗΝΥΜΑ <- ‘ΔΕΝ ΕΙΝΑΙ ΠΡΩΤΟΣ’ 

19.ΤΕΛΟΣ

20.ΓΡΑΨΕ ΜΗΝΥΜΑ

21.ΤΕΛΟΣ_ΑΛΓΟΡΙΘΜΟΥ

Β.

Να γράψετε στο τετράδιό σας τον αριθμό κάθε γραμμής του προγράμματος, στην οποία εντοπίζετε συντακτικό λάθος και να περιγράψετε το λάθος αυτό.

Μονάδες 12

Να  μεταφέρετε στο τετράδιό σας συμπληρωμένο τον παρακάτω πίνακα αληθείας.

Α Β (ΟΧΙ Α) ΚΑΙ (ΟΧΙ Β) ((ΟΧΙ Α) ΚΑΙ Β) Ή (Α ΚΑΙ (ΟΧΙ Β))
Ψευδής Ψευδής
Ψευδής Αληθής
Αληθής Ψευδής
Αληθής Αληθής

Μονάδες 8

Τα θέματα σε pdf, 2008, Επαναληπτικές, Ημερήσια

Θέμα Β, Ερώτημα 2, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Δίνεται μονοδιάστατος πίνακας Α[40] και το παρακάτω ημιτελές τμήμα αλγορίθμου, το οποίο αντιγράφει όλα τα στοιχεία του Α σε ένα δισδιάστατο πίνακα Β[8,5] κατά γραμμή. Δηλαδή, τα 5 πρώτα στοιχεία του μονοδιάστατου πίνακα τοποθετούνται στην πρώτη γραμμή του πίνακα Β, τα επόμενα 5 στη δεύτερη γραμμή κ.ο.κ.

I <-- 1 
K <-- 1
Για M από 1 μέχρι …(1)…
             B[I, K] <-- A[…(2)…]
              …(3)... <-- …(4)…+ 1
             Αν …(5)… > …(6)… τότε
                        I <-- I + …(7)…
                        K <-- …(8)…
             Τέλος_αν 
Τέλος_επανάληψης

Να γράψετε στο τετράδιό σας τους αριθμούς (1) έως (8), που αντιστοιχούν στα κενά του αλγορίθμου, και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε το τμήμα αλγορίθμου να επιτελεί τη λειτουργία που περιγράφεται.

Μονάδες 8

Τα θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ

I <-- 1 
K <-- 1 
Για M από 1 μέχρι  40  
    B[I, K] <-- A[ Μ ] 
    Κ  <--  Κ  + 1 
Αν  Κ  >  5  τότε 
I ← I +  1  
K ←  1  
Τέλος_αν 
Τέλος_επανάληψης

Θέμα Β, Ερώτημα 1, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Δίνεται ο παρακάτω αλγόριθμος:

Αλγόριθμος θέμα_Β1
                ΠΛ <-- 0
                Σ  <-- 0
                Για Ι από 100 μέχρι 10 με_βήμα -3 
                       Αν Ι mod 2 <> 0 τότε
                             Σ <-- Σ + Ι 
                       Αλλιώς
                             ΠΛ <-- ΠΛ + 1 
                       Τέλος_αν 
                Τέλος_επανάληψης 
                Εμφάνισε Σ, ΠΛ 
Τέλος θέμα_Β1

Να  σχεδιάσετε στο τετράδιό σας το αντίστοιχο διάγραμμα ροής.

Μονάδες 12

Τα θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ (περισσότερα…)

Ερώτημα 2, Θέμα Β, 2011, Επαναληπτικές, Ημερήσια

Δίνεται ο πίνακας Α τεσσάρων στοιχείων με τιμές:
Α[1]=3, Α[2]=5, Α[3]=8, Α[4]=13 και το παρακάτω τμήμα αλγορίθμου:
i <- 1 j <- 4
Όσο i<=3 επανάλαβε
πρόχειρο <- Α[j]
A[j] <- Α[i]
Α[i] <- πρόχειρο
Γράψε   Α[1], Α[2], Α[3]
i <- i + 1
j <- j – 1
Τέλος_επανάληψης
Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανισθούν κατά την εκτέλεσή του.
Μονάδες 9

Τα θέματα σε pdf, 2011, Επαναληπτικές, Ημερήσια

Θέμα B, Ερώτημα 2, 2012, Επαναληπτικές, Ημερήσια

Δίνονται οι πίνακες DATA[7], L[7], R[7], οι οποίοι περιέχουν δεδομένα, όπως φαίνονται στα παρακάτω σχήματα:
er2themabaepp-2012-imerisia-epanaliptikes
Χρησιμοποιώντας τους ανωτέρω πίνακες, να εκτελέσετε το παρακάτω τμήμα αλγορίθμου και να συμπληρώσετε τον πίνακα τιμών, αφού τον μεταφέρετε στο τετράδιό σας.
ΓΡΑΜΜΑ <- ΄Σ΄
Κ <- 1
Όσο DATA[K] <> ΓΡΑΜΜΑ
επανάλαβε
Εκτύπωσε DATA[K]
Αν DATA[K] > ΓΡΑΜΜΑ τότε
Κ <- L[K]
αλλιώς
Κ <- R[K]
Τέλοςαν
Τέλος
επανάληψης
Εκτύπωσε DATA[K]

Πίνακας τιμών

ΓΡΑΜΜΑ Κ ΟΘΟΝΗ (ΕΚΤΥΠΩΣΗ)
Σ

Μονάδες 10

Τα θέματα σε pdf, 2012, Επαναληπτικές, Ημερήσια

 

Ερώτημα 1, Θέμα Β, 2011, Επαναληπτικές, Ημερήσια

Δίνεται τo παρακάτω τμήμα αλγορίθμου, το οποίο διαβάζει έναν θετικό αριθμό από τον χρήστη. Αν δοθεί μη θετικός αριθμός ζητάει από τον χρήστη άλλον αριθμό.
Αρχή_επανάληψης
Διάβασε α
Μέχρις_ότου α>0
Να ξαναγράψετε στο τετράδιό σας τον παραπάνω αλγόριθμο τροποποιημένο, έτσι ώστε:
α. Να υπολογίζει και να εμφανίζει πόσες φορές δόθηκε μη θετικός αριθμός. Αν δοθεί την πρώτη φορά θετικός αριθμός να εμφανίζει το μήνυμα “Σωστά”.
(μονάδες 4)
β. Να υπολογίζει και να εμφανίζει τον μέσο όρο των μη θετικών αριθμών που δόθηκαν. Αν δεν δοθούν μη θετικοί αριθμοί να εμφανίζεται κατάλληλο μήνυμα.
(μονάδες 2)
γ. Να υπολογίζει και να εμφανίζει τον μεγαλύτερο κατά απόλυτη τιμή μη θετικό αριθμό που δόθηκε. Αν δεν δοθούν μη θετικοί αριθμοί να εμφανίζεται κατάλληλο μήνυμα.
(μονάδες 5)
Μονάδες 11

Τα θέματα σε pdf, 2011, Επαναληπτικές, Ημερήσια

Θέμα B, Ερώτημα 1, 2012, Επαναληπτικές, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος
Αλγόριθμος
Διοφαντική
Για x από 0 μέχρι 100
Για y από 0 μέχρι 100
Για z από 0 μέχρι 100
Αν 3*x+2*y-7*z=5 τότε εκτύπωσε x,y,z
         Τέλος_επανάληψης
    Τέλος_επανάληψης
Τέλος_επανάληψης
Τέλος Διοφαντική

Να κατασκευάσετε στο τετράδιό σας το διάγραμμα ροής που αντιστοιχεί στον παραπάνω αλγόριθμο.
Μονάδες 10

Τα θέματα σε pdf, 2012, Επαναληπτικές, Ημερήσια