Επιλογή Σελίδας

Θέμα Γ, 2005, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται πίνακας Α[Ν] ακέραιων και θετικών αριθμών, καθώς και πίνακας Β[Ν-1] πραγματικών και θετικών αριθμών.

Να γραφεί αλγόριθμος, ο οποίος να ελέγχει αν κάθε στοιχείο Β[i] είναι ο μέσος όρος των στοιχείων Α[i] και Α[i+1], δηλαδή αν Β[i] = (Α[i] + Α[i+1])/2.

Σε περίπτωση που ισχύει, τότε να εμφανίζεται το μήνυμα «Ο πίνακας Β είναι ο τρέχων μέσος του Α», διαφορετικά να εμφανίζεται το μήνυμα «Ο πίνακας Β δεν είναι ο τρέχων μέσος του Α».

Για παράδειγμα:

 

Έστω ότι τα στοιχεία του πίνακα Α είναι:

1,    3,   5,   10,   15

και ότι τα στοιχεία του πίνακα Β είναι:

2,    4,   7.5,   12.5.

Τότε ο αλγόριθμος θα εμφανίσει το μήνυμα «Ο πίνακας Β είναι ο τρέχων μέσος του Α», διότι 2 = (1+3)/2, 4=(3+5)/2, 7.5= (5+10)/2, 12.5=(10+15)/2.

Μονάδες 20

Τα θέματα σε pdf, 2005, Ημερήσια

Θέμα Δ, 2005, Μαΐου-Ιουνίου, Ημερήσια

Σ’ ένα διαγωνισμό συμμετέχουν 100 υποψήφιοι. Κάθε υποψήφιος διαγωνίζεται σε 50 ερωτήσεις πολλαπλής επιλογής.

Να αναπτύξετε αλγόριθμο που να κάνει τα παρακάτω:

α. Να καταχωρεί σε πίνακα AΠ[100,50] τα αποτελέσματα των απαντήσεων του κάθε υποψηφίου σε κάθε ερώτηση. Κάθε καταχώρηση μπορεί να είναι μόνο μία από τις παρακάτω:

  1. Σ αν είναι σωστή η απάντηση
  2. Λ αν είναι λανθασμένη η απάντηση και
  3. Ξ αν ο υποψήφιος δεν απάντησε.

Να γίνεται έλεγχος των δεδομένων εισόδου.

Μονάδες 4

β. Να βρίσκει και να τυπώνει τους αριθμούς των ερωτήσεων που παρουσιάζουν το μεγαλύτερο βαθμό δυσκολίας, δηλαδή έχουν το μικρότερο πλήθος σωστών απαντήσεων.

Μονάδες 10

 

γ.    Αν  κάθε  Σ  βαθμολογείται  με  μονάδες, κάθε  Λ  με  -1 μονάδα και κάθε Ξ με 0 μονάδες τότε

i. Να δημιουργεί ένα μονοδιάστατο πίνακα ΒΑΘ[100], κάθε στοιχείο του οποίου θα περιέχει αντίστοιχα τη συνολική βαθμολογία ενός υποψηφίου.

Μονάδες 4

ii. Να τυπώνει το πλήθος των υποψηφίων που συγκέντρωσαν βαθμολογία μεγαλύτερη από 50.

Μονάδες 2

Τα θέματα σε pdf, 2005, Ημερήσια

Θέμα B, 2005, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα προγράμματος και μια συνάρτηση:

Διάβασε Κ

L <- 2

Α <- 1

Όσο Α < 8 επανάλαβε

Αν Κ MOD L = Ο τότε

Χ <- Fun(Α, L)

αλλιώς

Χ <- Α + Ε

Τέλος_αν

Εμφάνισε L, Α, Χ

 

A <- A + 2

L <- L + 1

Tέλος_επανάληψης

……………

Συνάρτηση Fun(Β, Δ) : Ακέραια Μεταβλητές

Ακέραιες: Β, Δ Αρχή

Fun <- (B + Δ) DIV 2 Tέλος_συνάρτησης.

Να γράψετε στο τετράδιό σας τις τιμές των μεταβλητών L, A, X, όπως αυτές εκτυπώνονται σε κάθε επανάληψη, όταν για είσοδο δώσουμε την τιμή 10.

Μονάδες 20

Τα θέματα σε pdf, 2005, Ημερήσια

Θέμα Α, Ερώτημα 3, 2005, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου:

S <- 0

Για Ι από 2 μέχρι 100 με_βήμα 2

S <- S + I

Τέλος_επανάληψης

Εμφάνισε S

  1. Να μετατραπεί σε ισοδύναμο με χρήση της δομής Όσο
    … Επανάλαβε

Μονάδες 5

  1. Να μετατραπεί   σε   ισοδύναμο   με   χρήση   της   δομής
    αρχή_επανάληψης… μέχρις_ότου.

Μονάδες 5

Τα θέματα σε pdf, 2005, Ημερήσια

Ερώτημα 2, Θέμα Α, 2005, Μαΐου-Ιουνίου, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη Λάθος, αν είναι λανθασμένη.

  1. Η ταξινόμηση είναι μια από τις βασικές λειτουργίες επί των δομών δεδομένων.
  2. Τα στοιχεία ενός πίνακα μπορούν να αποτελούνται από δεδομένα διαφορετικού τύπου.
  3. Ένα υποπρόγραμμα μπορεί να καλείται από ένα άλλο υποπρόγραμμα ή από το κύριο πρόγραμμα.
  4. Στην επαναληπτική δομή Όσο …   Επανάλαβε δεν γνωρίζουμε εκ των προτέρων το πλήθος των επαναλήψεων.
  5. Κατά την εκτέλεση ενός προγράμματος μπορεί να
    αλλάζει η τιμή και ο τύπος μιας μεταβλητής.

Μονάδες 10

Τα θέματα σε pdf, 2005, Ημερήσια

Ερώτημα 1, Θέμα Α, 2005, Μαΐου-Ιουνίου, Ημερήσια

  1. Να αναφέρετε ονομαστικά τα κριτήρια που πρέπει απαραίτητα να ικανοποιεί ένας αλγόριθμος.

Μονάδες 5

  1. Ποιο κριτήριο δεν ικανοποιεί ο παρακάτω αλγόριθμος και γιατί;

Για Ι από 2 μέχρι 10 με_βήμα 0

S<-S+I

Τέλος_επανάληψης

Εμφάνισε S

Μονάδες 5