Επιλογή Σελίδας

Θέμα Β, 2003, Μαΐου-Ιουνίου, Ημερήσια

Να γράψετε στο τετράδιό σας τις τιμές των μεταβλητών Ν, Μ και Β, όπως αυτές τυπώνονται σε κάθε επανάληψη, και την τιμή της μεταβλητής Χ που τυπώνεται μετά το τέλος της επανάληψης, κατά την εκτέλεση του παρακάτω αλγόριθμου.

Αλγόριθμος Αριθμοί

Α <- 1

Β <- 1

Ν <- 0

Μ <- 2

Όσο Β < 6 επανάλαβε

        Χ <- Α + Β

       Αν Χ MOD 2 = 0 τότε

                 Ν <- Ν + 1

      αλλιώς

                Μ <- Μ + 1

     Τέλος_αν

     Α <- Β

     Β <- Χ

     Εμφάνισε Ν, Μ, Β

Τέλος_επανάληψης

Εμφάνισε Χ

Τέλος Αριθμοί

 

Μονάδες 20

Τα θέματα σε pdf, 2003, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Γ, 2003, Μαΐου-Ιουνίου, Ημερήσια

Ο Δείκτης Μάζας του ανθρώπινου Σώματος (ΔΜΣ) υπολογίζεται από το βάρος (Β) σε χλγ. και το ύψος (Υ) σε μέτρα με τον τύπο ∆ΜΣ=Β/Υ2. Ο ανωτέρω τύπος ισχύει για άτομα άνω των 18 ετών. Το άτομο ανάλογα με την τιμή του ∆ΜΣ χαρακτηρίζεται σύμφωνα με τον παρακάτω πίνακα:

ΔΜΣ<18,5 «αδύνατο άτομο»
18,5<∆ΜΣ<25 «κανονικό άτομο»
25<∆ΜΣ<30 «βαρύ άτομο»
30<∆ΜΣ «υπέρβαρο άτομο»

Να γράψετε αλγόριθμο ο οποίος:

α. να διαβάζει  την  ηλικία,  το  βάρος  και  το ύψος του ατόμου

Μονάδες 3

β. εάν η ηλικία είναι μεγαλύτερη των 18 ετών, τότε

  1. να υπολογίζει το ∆ΜΣ

Μονάδες 5

  1. να ελέγχει την τιμή του ∆ΜΣ από τον ανωτέρω πίνακα και να εμφανίζει τον αντίστοιχο χαρακτηρισμό

Μονάδες 10

 

γ. εάν η ηλικία είναι μικρότερη ή ίση των 18 ετών, τότε να εμφανίζει το μήνυμα «δεν ισχύει ο δείκτης ΔΜΣ».

Μονάδες 2

Παρατήρηση:   Θεωρήστε ότι  το βάρος,  το ύψος και η ηλικία είναι θετικοί αριθμοί.

Τα θέματα σε pdf, 2003, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Δ, 2003, Μαΐου-Ιουνίου, Ημερήσια

Μια αλυσίδα κινηματογράφων έχει δέκα αίθουσες. Τα ονόματα των αιθουσών καταχωρούνται σε ένα μονοδιάστατο πίνακα και οι μηνιαίες εισπράξεις κάθε αίθουσας για ένα έτος καταχωρούνται σε πίνακα δύο διαστάσεων. Να γράψετε αλγόριθμο ο οποίος:

α. να διαβάζει τα ονόματα των αιθουσών.

Μονάδες 2

β. να διαβάζει τις μηνιαίες εισπράξεις των αιθουσών αυτού του έτους.

Μονάδες 3

γ. να υπολογίζει τη μέση μηνιαία τιμή των εισπράξεων για κάθε αίθουσα.

Μονάδες 7

δ. να βρίσκει και να εμφανίζει τη μικρότερη μέση μηνιαία τιμή.

Μονάδες 5

ε. να βρίσκει και να εμφανίζει το όνομα ή τα ονόματα των αιθουσών που έχουν την ανωτέρω μικρότερη μέση μηνιαία τιμή.

Μονάδες 3

Παρατήρηση:   Θεωρήστε ότι οι μηνιαίες εισπράξεις είναι θετικοί αριθμοί.

Παρατηρήσεις που αφορούν στα ΘΕΜΑΤΑ 2ο, 3ο, 4ο

  1. Οι εντολές σε έναν αλγόριθμο μπορούν ισοδύναμα να γραφούν με μικρά ή κεφαλαία γράμματα.
  1. Όπου γίνεται χρήση εισαγωγικών, μπορούν ισοδύναμα να χρησιμοποιηθούν μονά ( ‘ ) ή διπλά εισαγωγικά ( » ) .

Θέματα σε pdf. 2003, Ιουνίου, Ημερήσια

Ερώτημα 2, Θέμα Α, 2003, Μαΐου-Ιουνίου, Ημερήσια

Να γράψετε στο τετράδιό σας τους αριθμούς της Στήλης Α και δίπλα τα γράμματα της Στήλης Β που αντιστοιχούν σωστά. (Να σημειωθεί ότι σε κάποια στοιχεία της ψευδογλώσσας της Στήλης  Α  αντιστοιχούν περισσότερα  από ένα παραδείγματα  εντολών της Στήλης Β).

Στήλη Α

Στοιχεία ψευδογλώσσας

Στήλη Β

Παραδείγματα εντολών

1.          εντολή εκχώρησης α. Επίλεξε*  Χ

Περίπτωση 1

    X <- Χ + 1

Περίπτωση 2

    X <- α * β

Τέλος_επιλογών

2. δομή επιλογής β.   Όσο   Χ   <   0 επανάλαβε

                 X <- Χ – 1

      Τέλος_επανάληψης

3. δομή επανάληψης γ. α <- β + 1
  δ. Αρχή_επανάληψης

        Ι <- Ι – 1

    Μέχρις_ότου Ι < 0

ε. Αν Χ = 2 τότε

          Χ <- Χ/2

   Τέλος_αν

Μονάδες 10

*H εντολή Επίλεξε είναι πλέον εκτός ύλης.

Τα θέματα σε pdf, 2003, Μαΐου-Ιουνίου, Ημερήσια

Ερώτημα 1, Θέμα Α, 2003, Μαΐου-Ιουνίου, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-6 και δίπλα τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη Λάθος, αν είναι λανθασμένη.

  1. Ένας αλγόριθμος είναι μία πεπερασμένη σειρά ενεργειών.
  2. Οι ενέργειες που ορίζει ένας αλγόριθμος είναι αυστηρά καθορισμένες.
  3. Η έννοια του αλγόριθμου συνδέεται αποκλειστικά με την Πληροφορική.
  4. Ο αλγόριθμος τελειώνει μετά από πεπερασμένα βήματα εκτέλεσης εντολών.
  5. Ο πιο δομημένος τρόπος παρουσίασης αλγορίθμων είναι με ελεύθερο κείμενο.
  6. Ένας αλγόριθμος στοχεύει στην επίλυση ενός προβλήματος.

Μονάδες 12

Τα θέματα σε pdf, 2003, Μαΐου-Ιουνίου, Ημερήσια