Επιλογή Σελίδας

Θέμα Β, 2001, Ημερήσια, Επαναληπτικές

Δίνεται το παρακάτω τμήμα αλγορίθμου:
Κ= 4
Όσο Κ >= 1 επανάλαβε
Α<-1
Αν Κ<>2 τότε
Για i από 1 μέχρι Κ
Α<-2*Α
Τύπωσε  i , Α
Τέλος_επανάληψης
Τέλος_αν
Κ<-Κ/2
Τέλος_επανάληψης
Καθώς εκτελείται το παραπάνω τμήμα αλγορίθμου, ποιες τιμές τυπώνονται με την εντολή Τύπωσε i , Α;

Μονάδες 20

ΛΥΣΗ:  (περισσότερα…)

Θέμα Γ, 2001, Ημερήσια, Επαναληπτικές

Να αναπτύξετε αλγόριθμο ο οποίος υλοποιεί τη λειτουργία ενός αυτόματου τυποποιητή πορτοκαλιών που είναι η παρακάτω:

Για κάθε πορτοκάλι που εισάγεται στον τυποποιητή, διαβάζεται η τιμή του βάρους του (Β) και η διάμετρος του (Δ). Το πορτοκάλι κατατάσσεται ανάλογα με το βάρος και τη διάμετρο του ως εξής:

Αν 100 < Β < 150 και 8 < Δ < 10, τότε τυπώνεται το μήνυμα «πρώτη διαλογή». Αν 6 < Δ < 8, τότε, ανεξαρτήτως βάρους, τυπώνεται το μήνυμα «δεύτερη διαλογή». Σε κάθε άλλη περίπτωση τυπώνεται το μήνυμα «χυμοποίηση».

Μονάδες 20

ΛΥΣΗ: (περισσότερα…)

Θέμα Δ, 2001, Ημερήσια, Επαναληπτικές

Κατά τη διάρκεια Διεθνών Αγώνων Στίβου στον ακοντισμό έλαβαν μέρος δέκα (10) αθλητές. Κάθε αθλητής έκανε έξι (6) έγκυρες ρίψεις που καταχωρούνται ως επιδόσεις σε μέτρα. Να αναπτύξετε αλγόριθμο, ο οποίος:

α. εισάγει σε πίνακα δυο διαστάσεων τις επιδόσεις όλων των αθλητών
Μονάδες 3

β. υπολογίζει και καταχωρεί σε μονοδιάστατο πίνακα την καλύτερη από τις επιδόσεις κάθε αθλητή
Μονάδες 5

γ. ταξινομεί τις καλύτερες επιδόσεις των αθλητών που καταχωρήθηκαν στο μονοδιάστατο πίνακα
Μονάδες 8

δ. βρίσκει την καλύτερη επίδοση του αθλητή που πήρε το χάλκινο μετάλλιο (τρίτη θέση).
Μονάδες 4

ΛΥΣΗ: (περισσότερα…)

Θέμα Α, Ερώτημα 5, 2001, Ημερήσια, Επαναληπτικές

Αντιστοιχίστε σωστά τις εκφράσεις της Στήλης Α με τις αλγοριθμικές έννοιες της Στήλης Β, γράφοντας στο τετράδιο σας τους αριθμούς της Στήλης Α και δίπλα το γράμμα της Στήλης Β.

Στήλη Α Στήλη Β
Εκφράσεις Αλγοριθμικές έννοιες
1. Χ<-Χ*2 α. αριθμητική έκφραση (παράσταση)
2. 3 + Α>Β β. μεταβλητή
3. τύπωσε Β γ. λογική έκφραση (παράσταση)
4. όσο Κ < 3 επανάλαβε δ. δομή ακολουθίας
εντολές ε. δομή επανάληψης
τέλος _ επανάληψης στ. εντολή εκχώρησης
Χ – (Χ/2) * 2 ζ. εντολή εξόδου

Μονάδες 10

ΛΥΣΗ:  (περισσότερα…)

Θέμα Α, Ερώτημα 4, 2001, Ημερήσια, Επαναληπτικές

Δίνεται το παρακάτω τμήμα αλγορίθμου:
Χ <- Α
Αρχήεπανάληψης
Χ<-Χ+2
τύπωσε το Χ
μέχριςότου Χ >= Μ
α. Να δώσετε τη δομή επανάληψης «Για … από … μέχρι … βήμα» η οποία τυπώνει ακριβώς τις ίδιες τιμές με το πιο πάνω τμήμα αλγορίθμου.
Μονάδες 7
β. Τι θα τυπωθεί, αν Α = 4 και Μ = 9;
Μονάδες 3
γ. Τι θα τυπωθεί, αν Α = -5 και Μ = 0 ;
Μονάδες 3

ΛΥΣΗ: (περισσότερα…)

Θέμα Α, Ερώτημα 2, 2001, Ημερήσια, Επαναληπτικές

Για τις απλές αριθμητικές πράξεις:

α. να αναφερθούν οι αντίστοιχοι τελεστές

Μονάδες 2

β. να δοθεί η σειρά προτεραιότητας (ιεραρχία) των τελεστών αυτών στις αριθμητικές εκφράσεις.

Μονάδες 2

ΛΥΣΗ:  (περισσότερα…)

Θέμα Α, Ερώτημα 1, 2001, Ημερήσια, Επαναληπτικές

Να γράψετε στο τετράδιο σας, ποιες από τις παρακάτω εντολές εκχώρησης είναι συντακτικά σωστές και ποιες λάθος.
α. 2* Α  <- Α
β. Α <- 3*Α + 5
γ. Β + 5 <- «Α»

Μονάδες 3

ΛΥΣΗ: (περισσότερα…)