Επιλογή Σελίδας

Θέμα Γ, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Ένα ξενοδοχείο χρεώνει την ενοικίαση των δωματίων του ανάλογα με τον αριθμό των ημερών ενοικίασης και την τουριστική περίοδο, σύμφωνα με τον παρακάτω πίνακα:

ΑΡΙΘΜΟΣ ΗΜΕΡΝ ΤΟΥΡΙΣΤΙΚΗ ΠΕΡΙΟΔΟΣ
ΧΑΜΗΛΗ ΥΨΗΛΗ
1-3 40€ ανά ημέρα 70€ ανά ημέρα
4-7 30€ ανά ημέρα 55€ ανά ημέρα
>7 25€ ανά ημέρα 50€ ανά ημέρα

Να αναπτύξετε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:

Γ 1.       Nα περιλαμβάνει κατάλληλο τμήμα δηλώσεων.
Μονάδες 2

Γ2.       Για καθεμιά από τις 500 κρατήσεις του ξενοδοχείου κατά το προηγούμενο έτος:
α. Να διαβάζει τον αριθμό των ημερών ενοικίασης καθώς και την τουριστική περίοδο που έγινε η κράτηση, εξασφαλίζοντας ότι η επιτρεπτή τιμή για την τουριστική περίοδο είναι ΧΑΜΗΛΗ ή ΥΨΗΛΗ.   (μονάδες 3)
β. Να καλεί υποπρόγραμμα με είσοδο τον αριθμό των ημερών ενοικίασης και την τουριστική περίοδο, το οποίο να υπολογίζει, με βάση τον προηγούμενο πίνακα, τη χρέωση της κράτησης. O υπολογισμός της χρέωσης δεν γίνεται κλιμακωτά.  (μονάδες 2)
γ.     Να εμφανίζει τη χρέωση της κράτησης.  (μονάδα 1)
Μονάδες 6

Γ3.      Nα υπολογίζει και να εμφανίζει τη συνολική χρέωση των κρατήσεων του ξενοδοχείου για καθεμιά τουριστική περίοδο του προηγούμενου έτους.
Μονάδες 4

Γ4.       Nα κατασκευάσετε το υποπρόγραμμα του ερωτήματος Γ2.β.
Μονάδες 8

Τα Θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ (περισσότερα…)

Θέμα Δ, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Μια εταιρεία έχει δύο υποκαταστήματα, ένα στην Αθήνα και ένα στη Θεσσαλονίκη. Σε κάθε υποκατάστημα εργάζονται 10 πωλητές.

Να αναπτύξετε αλγόριθμο σε ψευδογλώσσα, ο οποίος:
Δ1. Για καθέναν από τους 20 πωλητές της εταιρείας, να διαβάζει το όνομά του και τον κωδικό του και να τα καταχωρίζει σε κατάλληλο δισδιάστατο πίνακα, έτσι ώστε στις πρώτες 10 γραμμές του πίνακα να υπάρχουν τα στοιχεία των πωλητών του υποκαταστήματος της Αθήνας και στις επόμενες 10 τα στοιχεία των πωλητών της Θεσσαλονίκης. Να θεωρήσετε ότι όλα τα ονόματα και όλοι οι κωδικοί είναι διαφορετικοί μεταξύ τους. Μονάδες 2

Δ2. Για κάθε παραγγελία της εταιρείας στη διάρκεια του προηγούμενου έτους, να διαβάζει τον κωδικό του πωλητή. Αν ο κωδικός ανήκει σε πωλητή της εταιρείας, να διαβάζει το ποσό της αντίστοιχης παραγγελίας που πήρε ο πωλητής (δεν απαιτείται έλεγχος εγκυρότητας) ή, διαφορετικά, να εμφανίζει το μήνυμα «Άγνωστος κωδικός». Η επαναληπτική διαδικασία να τερματίζεται όταν δοθεί, ως κωδικός πωλητή, η τιμή ΤΕΛΟΣ. Μονάδες 8

Δ3. Να υπολογίζει τις συνολικές πωλήσεις κάθε πωλητή στη διάρκεια του προηγούμενου έτους και να τις εμφανίζει μαζί με το όνομά του. Να θεωρήσετε ότι κάθε πωλητής πήρε παραπάνω από μία παραγγελία στη διάρκεια του προηγούμενου έτους. Μονάδες 4

Δ4. Για κάθε υποκατάστημα να βρίσκει και να εμφανίζει τα ονόματα των τριών πωλητών με τις μεγαλύτερες συνολικές πωλήσεις στη διάρκεια του προηγούμενου έτους. Να θεωρήσετε ότι οι συνολικές πωλήσεις όλων των πωλητών είναι διαφορετικές μεταξύ τους. Μονάδες 6

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

ΛΥΣΗ (περισσότερα…)

Θέμα Β, Ερώτημα 2, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Δίνεται μονοδιάστατος πίνακας Α[40] και το παρακάτω ημιτελές τμήμα αλγορίθμου, το οποίο αντιγράφει όλα τα στοιχεία του Α σε ένα δισδιάστατο πίνακα Β[8,5] κατά γραμμή. Δηλαδή, τα 5 πρώτα στοιχεία του μονοδιάστατου πίνακα τοποθετούνται στην πρώτη γραμμή του πίνακα Β, τα επόμενα 5 στη δεύτερη γραμμή κ.ο.κ.

I <-- 1 
K <-- 1
Για M από 1 μέχρι …(1)…
             B[I, K] <-- A[…(2)…]
              …(3)... <-- …(4)…+ 1
             Αν …(5)… > …(6)… τότε
                        I <-- I + …(7)…
                        K <-- …(8)…
             Τέλος_αν 
Τέλος_επανάληψης

Να γράψετε στο τετράδιό σας τους αριθμούς (1) έως (8), που αντιστοιχούν στα κενά του αλγορίθμου, και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε το τμήμα αλγορίθμου να επιτελεί τη λειτουργία που περιγράφεται.

Μονάδες 8

Τα θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ

I <-- 1 
K <-- 1 
Για M από 1 μέχρι  40  
    B[I, K] <-- A[ Μ ] 
    Κ  <--  Κ  + 1 
Αν  Κ  >  5  τότε 
I ← I +  1  
K ←  1  
Τέλος_αν 
Τέλος_επανάληψης

Θέμα Β, Ερώτημα 1, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Δίνεται ο παρακάτω αλγόριθμος:

Αλγόριθμος θέμα_Β1
                ΠΛ <-- 0
                Σ  <-- 0
                Για Ι από 100 μέχρι 10 με_βήμα -3 
                       Αν Ι mod 2 <> 0 τότε
                             Σ <-- Σ + Ι 
                       Αλλιώς
                             ΠΛ <-- ΠΛ + 1 
                       Τέλος_αν 
                Τέλος_επανάληψης 
                Εμφάνισε Σ, ΠΛ 
Τέλος θέμα_Β1

Να  σχεδιάσετε στο τετράδιό σας το αντίστοιχο διάγραμμα ροής.

Μονάδες 12

Τα θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Ερώτημα 5, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Δίνεται το παρακάτω τμήμα αλγορίθμου:

Για K από A μέχρι B μεβήμα Γ
       Εμφάνισε K
Τέλος
επανάληψης

Να γράψετε στο τετράδιό σας για καθεμία από τις παρακάτω περιπτώσεις τις τιμές των Α, Β, Γ, έτσι ώστε το αντίστοιχο τμήμα αλγορίθμου να εμφανίζει:

  1. όλους τους περιττούς ακεραίους από το 100 μέχρι το
  2. όλους τους ακεραίους από το -20 μέχρι και το 10 σε φθίνουσα σειρά.
  3. όλα τα πολλαπλάσια του 3 από το 1 μέχρι το 80.

Μονάδες 9

Θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ

  1. Α = 101, Β = 999, Γ = 2
  2. Α = 10, Β = -20, Γ = -1
  3. Α = 3, Β = 80, Γ = 3

Θέμα Α, Ερώτημα 4, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Να μεταφέρετε στο τετράδιό σας με συμπληρωμένα τα κενά τον παρακάτω πίνακα αληθείας:

Λογικές Μεταβλητές

Λογικές εκφράσεις

Α

Β ((ΟΧΙ Α) Ή Β) ΚΑΙ Β (ΟΧΙ Α) ΚΑΙ (ΟΧΙ (Β Ή Α))

Αληθής

Αληθής

Ψευδής

Ψευδής

Ψευδής Αληθής

Μονάδες 6

Τα θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ

Λογικές Μεταβλητές

Λογικές εκφράσεις

Α

Β ((ΟΧΙ Α) Ή Β) ΚΑΙ Β (ΟΧΙ Α) ΚΑΙ (ΟΧΙ (Β Ή Α))

Αληθής

 Αληθής

Αληθής

 Ψευδής
 Αληθής

Ψευδής

 Ψευδής

Ψευδής

Ψευδής Αληθής  Αληθής  Ψευδής

Θέμα Α, Ερώτημα 3, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Δίνεται η εντολή εκχώρησης:

Ε <- ((Α mod 5 >2) ΚΑΙ (C <> ‘Αληθής’)) Ή ((D=ψευδής) ΚΑΙ (Β > Α/3))

Θεωρώντας ότι οι αριθμητικές μεταβλητές που περιέχονται σε αυτήν παίρνουν θετικές τιμές, να γράψετε στο τετράδιό σας το όνομα κάθε μεταβλητής της εντολής και, δίπλα, τον τύπο που πρέπει να έχει, ώστε η εντολή να είναι συντακτικά σωστή.

Μονάδες 5

Τα θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ

Α: Ακέραια B: Πραγµατική (ή ακέραια) C: Χαρακτήρας D: Λογική E: Λογική

Θέμα Α, Ερώτημα 2, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Να αναφέρετε ονομαστικά τις τυπικές επεξεργασίες πινάκων.

Μονάδες 10

Τα θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ

Θέμα Α, Ερώτημα 1, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και, δίπλα, τη λέξη ΣΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Για τη γραφική απεικόνιση της δομής ενός προβλήματος χρησιμοποιείται συχνά η διαγραμματική αναπαράσταση.
  2. Κάθε μεταβλητή παίρνει τιμή μόνο με εντολή εκχώρησης.
  3. Σε μια δομή δεδομένων η διαγραφή αποτελεί την αντίστροφη πράξη της συγχώνευσης.
  4. Οι συμβολικές γλώσσες είναι ανεξάρτητες από την αρχιτεκτονική κάθε υπολογιστή.
  5. Η τελική τιμή μιας έκφρασης εξαρτάται από την ιεραρχία των πράξεων και τη χρήση των παρενθέσεων.

Μονάδες 10

Τα θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ

  1. Σωστό 2. Λάθος 3. Λάθος 4. Λάθος 5. Σωστό